VideoHelp Forum
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. Member lacywest's Avatar
    Join Date: Aug 2001
    Location: California
    Search Comp PM
    Hey guys ... My wife had some old movies on our Directv box that she wanted saved ... I was using my Panasonic EH50 but the disc drawer is misbehaving and wont eject out. So at the moment ... I cannot go that route.

    I hooked up the HD PVR ... I did a custom mod and I do have a fan blowing air inside to keep the chip cool.

    I've made several captures with it and I got one video with the audio synced up just fine with TMPGEnc 4.0 XPress.

    I've been trying to do some more and the audio is messed enough that it is not usable.

    I'm using programs like ... TMPGEnc 4.0 XPress ... TMPGEnc DVD Author 3 with DivX Authoring ... TMPGEnc Authoring Works 4.

    I just want to make a decent DVD compliant mpg file and use ... ConvertXtoDVD 4 ... to make a DVD.

    The movies I am trying to convert are ...

    First one I tried to convert ... When Love is Not Enough - Lois Wilson Story.M2TS ... came out perfect

    The Sons of Katie Elder.M2TS ... audio did not line up correctly

    Clash of the Titans.M2TS ... audio did not line up correctly

    Should I skip using ... m2ts ... for the format to capture as ... and try a different one.

    I believe the other choices are ... mp4 ... and ts.

    Any idea or suggestions ... thanks in advance.
    Last edited by lacywest; 27th May 2010 at 21:07. Reason: typo
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Are the m2ts files out of sync? or after you converted?

    Maybe try videoredo tvsuite 4 preview.
    Quote Quote  
  3. Member lacywest's Avatar
    Join Date: Aug 2001
    Location: California
    Search Comp PM
    Originally Posted by Baldrick View Post
    Are the m2ts files out of sync? or after you converted?

    Maybe try videoredo tvsuite 4 preview.
    A few days ago when messing around with the videos I would have a hard time answering whether they played in sync with the video.

    I just now tried to play ... Sons of Katie Elder.m2ts ... with VLC and it is playing okay.

    Last night I downloaded version 4 of Video Redo ... VRDTVSH264-4-20-5-600.exe. Crap happened ... I did have version 3.20 installed and it interfered with using the trial key for 15 days of full functions. Being able to use it for 15 minutes of video is not enuff to see how well it works.

    So I rebooted to WIN 7 and installed it ... and I now have full functions for 15 days. Works just fine in WIN 7 Ultimate x64.

    I loaded ... Sons of Katie Elder.m2ts ... and since it was late ... I told it to save as a mpg video and went to bed. Here is what it said when I got up ... hours later.

    Here is the screenshot of what it said ...

    Click image for larger version

Name:	VideoRedo Errors in Sons of Elder.jpg
Views:	114
Size:	144.5 KB
ID:	2020

    VRDo 4 ... found 3 errors and it played just fine ... now to trim the excess junk off and see if ... ConvertXtoDVD 4 ... can process it correctly.

    I will post the results from doing this.

    Question ... This trial version of VideoReDo 4 Suite ... seems to work well ... If I give in and pay 95 bucks for the full version ... will this be a forever subscription or will I have to pay again ... a year later when they update the program
    Last edited by lacywest; 28th May 2010 at 18:51. Reason: add picture
    Quote Quote  
  4. hmm.. here's my take on these things..

    You may want to consider the alternative freeware route, to rip it from the original .m2ts source into separate aud/vid files and then remux them back again. That may clear up the matter altogether, or may not..you have to test-try and see for yourself. Not everyone's cases are the exact same..because of differences in each persons computer/chipset and decoder setup.

    Some tools come to mind are Yamb, txMuxer and mp4Creator are the most popular. If one doesn't do so well, there is the other, and so on..until one works the most cleanly. Thats been my experience with various (h264/mpeg2 wrapped in ps or ts type containers) sources like these.

    I find that playing externally made aud/vid sources don't always cooperate cleanly during playback. It makes things harder and condensending at times when working with originals ala debugging. You could potentially spend hours if not days trying to track the root of the source problem(s) before you realize demuxing was the solution afterall.

    The problem could stem from the equipment that wrote the .m2ts, to the signal being weak on occasion, causing sparatic (telecine, timing or "linking" type) miss-behavior of sorts, and so on. If source medium is "digital" then it will stem from signal strength problems, else if .m2ts is based on "captures" then it is related to real-time encoding issues.

    Thats why its wise to demux these source types and remux them back (if you want the orignal layout) or demux and re-encode to another format altogether. Sometimes it is standard practice. Again, is a person to person scenario.

    Even if you only demux then you have the ability to review / analize the video (and audio) for errors and things. Ifs its "digital" then its signal strength related and glitches and things will crop up throughout the recording session, or, if it is "capture" based then it is probably dropped frames here and there or an encoding problem in-between there somewhere.

    Sometimes the simplest resolution to these types of issues is to just demux and remux simply because in most cases the writer application/equip produces faulty containers.

    -vhelp 5381

    VHELP's - Sample Clips [last: 12.29.06],
    my YouTube videos
    Quote Quote  
  5. Member lacywest's Avatar
    Join Date: Aug 2001
    Location: California
    Search Comp PM
    The Sons of Elder.m2ts ... I had figured it was screwed up and was a lost case to get to play correctly. After I used HD-PVR to record it from the Directv box ... I deleted it ... to provide more room for more Directv recordings. I started to think that was a mistake.

    But now I have high hopes again.

    A couple of times while recording shows using the ArcSoft capture program ... I had it on full screen and my wife and I didn't realize we were watching stuff from our Directv Box thru the ArcSoft capture program ... no audio out of whack ... picture looked great. I think it was when the mouse pointer went wiggling by that I realized how we were viewing the shows on our Directv box.

    That system is not the one in my profile. Here are the specs ...

    MSI Mobo ... K9N6PGM2-V

    AMD Athlon 64 X2 5600+ Brisbane 2.9GHz 2 x 512KB L2 Cache Socket AM2 65W

    4 Gigs of DDR 2 Ram ... only 2 slots so the ram is Kingston ... PC2-6400 ... 2 Gigs each

    Nvidia 9500GT 1GB of video ram

    One WD [I believe] 160 GB SATA drive ... dual boot ... WINXP MCE2005 and WIN 7 x64 Ultimate

    And a Seagate external 500GB USB drive [Walmart @ $75 bucks each ... I bought 3 of them] that is used to record TV shows. At this moment a second Seagate 500GB is also sitting on top of the Tower ... velcro strips keeping it from falling off ... we have cats and they like to sit on top of the tower. Frikking CATS !! ... Amber jumped off and as she jumped off ... she pushed the reset button ... LOL ... I now have a piece of cardboard covering that area so her stinking paws wont reboot the tower ... LOL

    The second 500GB drive is the one I carry into the garage and do the editing and stuff on this PC [see my specs]

    The remote control that comes with the HD-PVR ... it does control the Media Center in WIN 7.

    I have a very very long USB cable going under the rug - under my bed ... that controls a Wireless Logitech mouse and keyboard. Paid $40 at Walmart for the package ... dont use a mouse pad ... mouse works just fine on my bed comforter or on top of my chest while watching TV.
    Last edited by lacywest; 29th May 2010 at 20:22. Reason: typo
    Quote Quote  
  6. Member fritzi93's Avatar
    Join Date: Nov 2003
    Location: U.S.
    Search Comp PM
    I've had audio/video captures get out of sync with the HD-PVR for two reasons:

    1) OS hard drive getting flaky. I discovered this when I started getting the occasional "ati2dvag" blue screen error, indicating corrupt video drivers. Re-install of the drivers would solve the "ati2dvag" error for awhile. This made me suspect the Hauppauge drivers may be getting corrupted too. Re-installing the Hauppauge drivers would solve the async problem...for awhile. In short, a new OS hard drive eliminated driver corruption and that source of the problem once and for all.

    2) If on the rare occasion I allow my capture drive to get too fragmented or full, that can cause sync problems as well. Once I was aware of this and was more careful about housekeeping, that source of the problem also went away.

    At any rate, a number of times I've been able to fix a file by remuxing, as vhelp suggests, using tsMuxer, and rendering to another drive. I recall on some (not all) of these occasions having to also adjust the audio offset.
    Pull! Bang! Darn!
    Quote Quote  



Similar Threads