VideoHelp Forum
+ Reply to Thread
Results 1 to 12 of 12
Thread
  1. Member
    Join Date: Sep 2008
    Location: Planet Snack!
    Search Comp PM
    Hi. I recently got a new box with Windows Vista 64-bit. This box is more powerful than the one I was using beforehand for my video encoding. I downloaded and installed Xvid-1.2.2-07062009 for the box. I tried to open the Configure Decoder box through the shortcut in its Start Menu folder, but I get a box saying "Error loading xvid.ax The specified module could not be found". I tried the Configure Encoder option and it pops up with the same box except it says it can't find xvidvfw.dll. When I go to VDM and change the video compression mode in Save As and choose Xvid, I click Configure and get all my different encoding options. I want to be able to use Xvid for both watching and encoding videos by the way.

    What is going on? Will this be a problem?
    Quote Quote  
  2. If you're using a 64 bit version of VirtualDub you need a 64 bit version of Xvid. If you're using the 32 bit version of VirtualDub you will need a 32 bit version of Xvid. I believe there is a trick to installing 32 bit Xvid on Vista64 systems though. Something like the xvid dll has to be installed in Syswow64 rather than system32. You'll proably also have to install with administrator rights.

    64 bit xvid: http://www.overdrivetechgrp.com/Support/Files/tabid/58/Default.aspx
    Quote Quote  
  3. Member johns0's Avatar
    Join Date: Jun 2002
    Location: canada
    Search Comp PM
    Install both 32bit and 64bit xvid and delete the xvid.ax from the SysWow64 folder,then it will work,i had to do that to get 32 bit programs to work with vfw.
    I think,therefore i am a hamster.
    Quote Quote  
  4. Member
    Join Date: Aug 2005
    Location: Finland
    Search Comp PM
    The problem is that the installer of 32-bit version of xvid doesn't set up correct start menu shortcuts on 64-bit vista. The shortcuts are set up to run the configuration dialogs in c:\windows\system32 but of course this is wrong on 64-bit vista. I fixed the problem by changing c:\windows\system32 to c:\windows\syswow64 in the start menu shortcuts. For example the Configure Decoder shortcut should have C:\Windows\SysWOW64\rundll32.exe xvid.ax,Configure as the target.

    Hope this helps.
    Quote Quote  
  5. Member johns0's Avatar
    Join Date: Jun 2002
    Location: canada
    Search Comp PM
    Originally Posted by kpa
    The problem is that the installer of 32-bit version of xvid doesn't set up correct start menu shortcuts on 64-bit vista. The shortcuts are set up to run the configuration dialogs in c:\windows\system32 but of course this is wrong on 64-bit vista. I fixed the problem by changing c:\windows\system32 to c:\windows\syswow64 in the start menu shortcuts. For example the Configure Decoder shortcut should have C:\Windows\SysWOW64\rundll32.exe xvid.ax,Configure as the target.

    Hope this helps.
    That doesnt fix the problem with programs that use vfw cause they still look for the codecs in system32 and not syswow64,the fix i gave up above works with vista64 so programs like megui and uncropmkv will run without having to install ffdshow cause ffdshow causes xvid avi files to go out of sync when encoding to mkv on vista64.
    I think,therefore i am a hamster.
    Quote Quote  
  6. Member
    Join Date: Aug 2005
    Location: Finland
    Search Comp PM
    What I wrote above is for the case where you install only the 32-bit version Xvid and nothing else. I have verified that 32-bit xvid vfw codec does work correctly in 64-bit vista when using 32-bit programs, these include vegas movie studio and virtualdub. The only problem is those start menu shortcuts pointing to wrong places.
    Quote Quote  
  7. Member johns0's Avatar
    Join Date: Jun 2002
    Location: canada
    Search Comp PM
    Not true, i pointed out programs that use vfw that dont work with just xvid 32bit,some programs will still work but others wont.
    I think,therefore i am a hamster.
    Quote Quote  
  8. Member
    Join Date: Aug 2005
    Location: Finland
    Search Comp PM
    I'm just trying to provide help to OP (adalect) and based on my experience with 64-bit vista he shouldn't need to do anything else but have the 32-bit version of xvid installed and fix the start menu shortcuts.
    Quote Quote  
  9. Member
    Join Date: Sep 2008
    Location: Planet Snack!
    Search Comp PM
    Thanks for the help guys. I sort of did what kpa and jagabo suggested. Here's the link I followed: http://forum.doom9.org/showthread.php?p=680848 . But this method seems to have limitations. As for me, I guess I'll use my older 32-bit box with WinXP for encodes until there is more of a obvious presence of 64-bit Vista solutions for people like me. I guess (though I don't know for sure) that 64-bit isn't widespread and common yet and it just takes too much of a hassle to get that stuff working for now.
    Quote Quote  
  10. Member johns0's Avatar
    Join Date: Jun 2002
    Location: canada
    Search Comp PM
    What exact problem are you having now?You were given good advice how to get xvid working in vista64.
    I think,therefore i am a hamster.
    Quote Quote  
  11. Member
    Join Date: Sep 2008
    Location: Planet Snack!
    Search Comp PM
    I didn't mean to imply I had a problem with it now... but as I said, my solution requires uses 32-bit Xvid and I find that the CPU isn't used at 100%, whereas my 32-bit box uses all of its power.
    Quote Quote  
  12. Originally Posted by adalect
    my solution requires uses 32-bit Xvid and I find that the CPU isn't used at 100%, whereas my 32-bit box uses all of its power.
    Xvid isn't especially well multithreaded. On multicore systems it cannot use 100 percent of the CPU. In my experience, the Xvid codec can use 100 percent of a single core CPU, about 75 percent of a dual core CPU, and about 55 percent of a quad core CPU. Exact values will vary depending on the source and the Xvid settings.

    But just to be sure, go to Xvid's Other Options dialog and set the Number Of Threads to the number of cores you have.

    I have one computer running Win7, 64 bit, so I just checked: Xvid (32 bit version, with 32 bit VirtualDub) doesn't properly detect the two cores on. You have to set the number of threads manually.
    Quote Quote  



Similar Threads