VideoHelp Forum
+ Reply to Thread
Results 1 to 20 of 20
Thread
  1. Member
    Join Date: Jun 2007
    Location: Sweden
    Search Comp PM
    Untill now I have always used format 4:3 when shooting video. Made some 16:9 widescreen testshots with my new Sony DCR-HC96E videocamera. Captured a testshot as DV-AVI with setting 16:9 in WMM and saved it also with setting 16:9. Both files came out well when played on the computer with WMP. However when making a DVD from the file, (DVDFlick with keep aspectratio 16:9), all vertical lines and all moving objects have jagged edges and lines can be clearly seen both on computer and TV. Various DVD player setting modifications changed nothing. Typical is a vertical line which seem to be made up of pixels too far left and then pixels to far right all along it's length, this seen by enlargement in VirtualDub. None of these contour defects are seen when reverting to use format 4:3 when shooting. I am aware of that the widescreen used is "fake" and not genuine, but could the quality difference be so great that a DVD made from this 16:9 "widescreen" shot comes out so bad that according to my demands this format is unusable? Comments?
    Quote Quote  
  2. Member Krispy Kritter's Avatar
    Join Date: Jul 2003
    Location: St Louis, MO USA
    Search Comp PM
    If you can post a screenshot or two, someone will have a better chance of helping you.

    Sounds like an interlace issue to me, but I haven't worked with this type of video much.
    Google is your Friend
    Quote Quote  
  3. Your camcorder is shooting interlaced video. You need to treat it as such.
    Quote Quote  
  4. Since WMM only does interlaced, make sure your DVDFlick settings are for interlaced, too.
    Quote Quote  
  5. Member
    Join Date: Jun 2007
    Location: Sweden
    Search Comp PM
    Another testshot has been made with same method as before. When playing the DVD, DVD player settings Pan:Scan and 16:9 shows no lines on 4:3 TV but Letterbox does. What I wanted to do is to see the whole picture with the black bars top and bottom (Letterbox) but then the lines came up in the picture. Resolutionloss I presume. Is what I want to do, that is to see the whole 16:9 video picture on a 4:3 TV maybe not possible?
    Quote Quote  
  6. Member edDV's Avatar
    Join Date: Mar 2004
    Location: Northern California, USA
    Search Comp PM
    Originally Posted by bagb
    Another testshot has been made with same method as before. When playing the DVD, DVD player settings Pan:Scan and 16:9 shows no lines on 4:3 TV but Letterbox does. What I wanted to do is to see the whole picture with the black bars top and bottom (Letterbox) but then the lines came up in the picture. Resolutionloss I presume. Is what I want to do, that is to see the whole 16:9 video picture on a 4:3 TV maybe not possible?
    I don't know about the software you are using but wide DV always exits the camcorder (Digital8, MiniDV, DVCAM) full vertical height (480 or 576 lines) and horizontally squeezed. To get to 16x9 display the video is stretched horizontally in the player to 854x480 (NTSC) or 1024x576 (PAL). As such there is no vertical resizing. Interlace is preserved. Letterbox is created in the encoder or DV/DVD player.

    If the encoder is set for 4:3 and the source DV is wide, then a vertical resizing is performed in the encoder and the output is letterbox 4:3. If the encoder is set for 16:9 and the source is DV wide, then the full height horizontally squeezed version is encoded to MPeg2. If the player is set to 4:3, the player performs the vertical rescale to create letterbox.

    Vertical resizing of 480i/576i can be done separately for each field (good) or by blend deinterlace followed by resize (bad).
    Quote Quote  
  7. Member
    Join Date: Jun 2007
    Location: Sweden
    Search Comp PM
    My comparison is that when I connect the PAL camcorder to the PAL 4:3 TV and set Tv-type to 4:3 on the camcorder as specified in the camcorder manual the 16:9 recording is shown the way I want the DVD to show. That is with full picture width and the black bars top and bottom, no distortion or cropping of the picture. I can not achieve this yet with DVD.
    Quote Quote  
  8. Can you post some example images?
    Quote Quote  
  9. Member edDV's Avatar
    Join Date: Mar 2004
    Location: Northern California, USA
    Search Comp PM
    Originally Posted by bagb
    My comparison is that when I connect the PAL camcorder to the PAL 4:3 TV and set Tv-type to 4:3 on the camcorder as specified in the camcorder manual the 16:9 recording is shown the way I want the DVD to show. That is with full picture width and the black bars top and bottom, no distortion or cropping of the picture. I can not achieve this yet with DVD.
    If you feed a wide DV playback out the analog outputs, the camcoder creates the letterbox. I was describing the DV format output over IEEE-1394.

    If you want a 4:3 DVD you can specify 4:3 DV project and import wide DV. That gives you letterbox while editing. Or you can import a wide DV source into a wide DV project and then encode as 4:3. Or you can encode wide and then let the DVD player create the letterbox. I like the last option so that the DVD can play wide on a 16:9 TV or letterbox on a 4:3 TV depending on DVD player settings.
    Quote Quote  
  10. Member
    Join Date: Jun 2007
    Location: Sweden
    Search Comp PM
    The jagged look of lamposts and colums seems to be an interlaceproblem as mentioned earlier by Krispy Kritter. When the captured file is played in WMP no problem is seen but VirtualDub shows the problem and can remove it with filter deinterlace. Result is though studdering video and audio. This problem has appeared only now in conjunction with changing my videocamera format from 4:3 to 16:9. I have processed scores of 4:3 DV casettes with WMK, WMP, DVDFlick and Imageburn but only now encountered this problem. This is out of my league. Please comments.
    Quote Quote  
  11. Originally Posted by bagb
    When the captured file is played in WMP no problem is seen
    WMP and Microsoft's DV decoder automatically BOB deinterlaces DV AVI for display. This is why you see no interlace comb artifacts.

    Originally Posted by bagb
    but VirtualDub shows the problem
    VirtualDub shows you the frames as they are, as they were received from the camcorder, so you see the interlace comb artifacts.

    Originally Posted by bagb
    and can remove it with filter deinterlace.
    Yes, but you don't want to if you are making a DVD.

    Originally Posted by bagb
    Result is though studdering video and audio.
    While playing in VirtualDub? VirtualDub is not optimized as a player so its playback is often jerky, especially when filtering. If you are playing a file saved from VirtualDub -- what codec did you use? If you saved as uncompressed RGB (the default if you don't select a codec) you will get jerky playback because the hard drive can't keep up with the data rate.

    Originally Posted by bagb
    This problem has appeared only now in conjunction with changing my videocamera format from 4:3 to 16:9. I have processed scores of 4:3 DV casettes with WMK, WMP, DVDFlick and Imageburn but only now encountered this problem. This is out of my league. Please comments.
    Somewhere along the line I suspect the video is being resized with a non-interlace aware resizing filter. You should be able to convert interlaced 16:9 DV AVI to interlaced 16:9 MPEG for DVD without deinterlacing and without any resizing (both use a 720x576 PAL frame size). Burn that to DVD with the proper field order and the video will look exactly the same as viewing the original DV tape on TV.
    Quote Quote  
  12. Member
    Join Date: Jun 2007
    Location: Sweden
    Search Comp PM
    I tested with the free watermark version of a "Cucusoft" converter and the artifacts disappeared however moving objects now have a non continous motion. At last some progress which I will try to develop further.

    What I wonder is where in the chain of WMK/Capture - Save Movie, DVDFlick DVD authoring and Imageburn a non-interlace resize filter could pop in.
    Quote Quote  
  13. Examine your video after each step with VirtualDubMPEG2 or VirtualDubMod (because these can read MPG and VOB files). It should look the same. If it looks different that tells you where the problem is occuring.
    Quote Quote  
  14. Member
    Join Date: Jun 2007
    Location: Sweden
    Search Comp PM
    Captured 16:9 with WMK.
    Saved movie 16:9 with WMK.
    Converted to MPEG and burnt DVD with "Cucusoft".
    Capturefile, Moviefile, TS file and VOB file all look the same in Virtualdub,
    that is they show "comb"lines. In another forumthread I have read that to see those lines in the PC is correct display of the AVI file and they should not show on a burnt DVD displayed on a TV.
    When my DVD is displayed on a TV the video is without "comb"lines, but sluggish with studdering sound. Comments wanted please.
    Quote Quote  
  15. Member Krispy Kritter's Avatar
    Join Date: Jul 2003
    Location: St Louis, MO USA
    Search Comp PM
    Have you tried the disc in a different dvd player? It's possible the disc is fine and that you dvd player just doesn't like the brand/type of media that you are using.
    Google is your Friend
    Quote Quote  
  16. Member
    Join Date: Jun 2007
    Location: Sweden
    Search Comp PM
    I have changed discbrand to test this but seen no difference. I have not yet tested in another player.

    What I have done is to test the Thalin filter in VirtualDub. I get the picture quality I want but the audio is then terrible in spite of various audio settings. The audio sounds like an old taperecorder that flutters.

    It seems like I have a "save" problem from VirtualDub since when the filtered video is played in VirtualDub it is what I am looking for but when the saved file is played in another player the result is awful. The Thalin filtering makes the original file about ten times bigger when processed. Various compression settings have made the saved file smaller but not changed the bad quality.

    If I can solve the problem with saving from VirtualDub I get what I am looking for.

    Comments please.
    Quote Quote  
  17. Member
    Join Date: Jun 2007
    Location: Sweden
    Search Comp PM
    I have now ventured through scores of software for video deinterlacing and filtering. Have read article after article on the subject and tested various proposals on how to deal with this issue. What bothers me is that my earlier captured DV and then burnt to DVD were totally free of artifacts and interlacetraces. One thing mentioned in a few places though is that the encoder must be set for interlaced encoding. I tested this and found no special result of that setting when DVD played on TV. What I did though was to repeat an earlier capture/burn with Sonic My DVD. To my surprise did the earlier totally impossible videoclip come out of this without artifacts and interlacetraces and with smooth fine quality (my opinion). The same clip I have tried to clean up in VirtualDub, AviDemux etc but no setting there even came close to the result from Sonic MyDVD.
    I am no fan of MyDVD because it has in the past only been trouble to me but now suddenly it worked on this clip. Has anybody got a clue on what it is in MyDVD that removes artifacts and gives no traces of interlace on the resulting DVD?
    Quote Quote  
  18. MyDVD either deinterlaced or handled the interlaced video properly (kept it interlaced, kept the corrrect field order, and flagged the DVD files properly). Open one of the DVD VOB files with VirtualDubMod and see if it has interlace comb artifacts.
    Quote Quote  
  19. Member
    Join Date: Jun 2007
    Location: Sweden
    Search Comp PM
    The MyDVD VOB file has interlace comb artifacts when opened in VirtualDub. When the DVD is played on TV (tubetype) there are no signs of any such thing. My understanding is that it should be so since the TV works interlaced. The only difference I have noticed (GSpot) is that MyDVD capture comes out TFF while all other capture I have tried comes out BFF. However the quality of the MyDVD DVD is exellent, only on zooming up to 300 - 400 % can you see a slight garbling in contours.
    I have tried both ways, deinterlace and keep interlaced. Deinterlace removed artifacts but reduced the videoquality and smoothness. Keep interlaced through all steps and the result is full of interlace artifacts.
    Possibly something goes wrong while trying to keep interlaced. It pussels me that I have made so many DVD's before without a trace of interlace artifacts and with according to my opinion good quality and suddenly it all collapses and a lot of filtering and other intrusions must be made on the video to get any result at all. Then suddenly a software I had dumped long ago because of to much trouble solves the issue!?
    Quote Quote  
  20. Member
    Join Date: Jun 2007
    Location: Sweden
    Search Comp PM
    An observation lately is that if the DivX compressor is set to deinterlaced encoding the result is exellent without any filters whatsoever when using VirtualDub.
    Quote Quote  



Similar Threads