VideoHelp Forum
+ Reply to Thread
Results 1 to 15 of 15
Thread
  1. Member
    Join Date: Nov 2006
    Location: United States
    Search Comp PM
    I've been trying for the last two days to author a dvd using some only free programs.

    I converted all the files to .mpg using Super. I used the mpeg II option with 4:3 aspect and 29.97 fps

    1) Then I used DVDStyler to author an .iso file, and burned it to a DVD using ImgBurn.
    The DVD came out fine, worked on my computer. But I couldn't play it on my home theater DVD player. It gave some error message saying something like 'Cannot play due to area limitations' I'm pretty sure I set everything to NTSC, thinking that was the problem, still nothing.

    2) Next I tried using GUIforDVDAuthor, and when I tried to add the files to the menu, it gave me an 'SCR moves backwards! SCR=0.00' error. And said 'Mux OK = No' and would not create the DVD.

    3) So I ran all the videos through ReJig, which gave me all .m2v files. So I put those in the menus in GUIforDVDAuthor, and it liked those files. No error messages, it said 'Mux OK = Yes' So I told it to create the DVD, and everything worked fine... but it had no sound! I rechecked and now it is asking for separate audio files of .mp2 .ac3 .m2p .mpa or .dts file types.

    I'm just trying to put some movie files I have on my computer onto a DVD I can play in my home theater system (for free). So if anybody knows how to solve any of the problems listed above, or can come up with another way to author the DVD I'd really appreciate it! I don't need any fancy options or anything. I'd prefer to put a title menu on the disc, but it's not critical.

    Thanks in advance!
    Drew
    Quote Quote  
  2. 1) sounds like a Region Code problem. This has nothing to do with NTSC versus PAL. See if there is some setting somehwere in that application (DVDStyler) that specifies which regions the created disc will be allowed to be played in, and make sure your region is among them.

    2) can't help with that one.

    3) M2V files do not contain audio in my experience. So you need to get the audio out of your sources (demux) and add that into the DVD creation process along with the M2V files.

    I use TMPGEnc to create DVDs with no problems so I have no experience with any of those applications you are using.
    Quote Quote  
  3. Member
    Join Date: Nov 2006
    Location: United States
    Search Comp PM
    i downloaded that program too, but all i could get out of it was the ability to convert .avi .wmv etc to .mpg files, how can you author a dvd with that?
    Quote Quote  
  4. There are two TMPGEnc applications, one which you mention, that allows creation of DVD-Compliant MPEG2 format files (among other formats), and the other, TDA, which allows authoring a DVD from such files.
    Quote Quote  
  5. Member
    Join Date: Nov 2006
    Location: United States
    Search Comp PM
    oooh... well like i said i'm trying to do this as cheaply as possible, i noticed that one is $90

    thanks anyways
    Quote Quote  
  6. I understand that there are freeware DVD Authoring applications out there, I've just never used any so I can't recommend one.
    Quote Quote  
  7. Member
    Join Date: Feb 2004
    Location: Australia
    Search Comp PM
    drewbagel,

    What about windows movie maker?
    Its free, should be already on your PC as you have XP (start-> all programs -> accessories

    Just plonk your MPEG files in there and follow the steps.
    Quote Quote  
  8. WMM can now author DVDs? First I heard of that.
    Quote Quote  
  9. Member
    Join Date: Nov 2006
    Location: United States
    Search Comp PM
    Originally Posted by bobkart
    WMM can now author DVDs? First I heard of that.
    yeah that makes two of us
    Quote Quote  
  10. Member
    Join Date: Feb 2004
    Location: Australia
    Search Comp PM
    Opps sorry, there is an option to save to CD - i thought it was DVD.
    Quote Quote  
  11. Member
    Join Date: Nov 2006
    Location: United States
    Search Comp PM
    ok... new development with regards to (1):

    There was a video format in DVDStyler that was set to auto, so I switched it to NTSC, clicked 'just generate' so that it gave me .ifo .vfo .bup files, then burned those to the dvd using DVD Shrink.

    Well now the dvd player was able to play the disc, but there was some weird flickering on the bottom third of the screen.

    I'm guess that this is due to the way SUPER converted the files. What settings should I be using to convert to .mpg?

    MPEG-1 vs. MPEG-2?
    Should I scale the video to a particular size?
    Change the aspect ratio to 4:3?
    25fps vs. 29.97fps?

    Thanks!
    Quote Quote  
  12. 3) So I ran all the videos through ReJig, which gave me all .m2v files....

    I'm pretty sure, ReJig has created the .mp2 or .ac3 files as well.

    Concerning SUPER...
    1. If possible, set the output to elementary streams (m2v + mp2/ac3). I don't know the multiplexer used by SUPER, but usually each authoring application likes elementary streams better than premuxed mpg files.
    2. Use MPEG2 in a DVD compliant size See: http://www.videohelp.com/dvd
    3. Keep the aspect ratio as it is in the source
    4. If the source has 25 fps (PAL standard) keep it. If the source has 29.97fps, keep it too. If the source has 23.976fps keep it also, but apply a 3:2 pulldown to get '29.97fps' for the DVD.
    Quote Quote  
  13. Member
    Join Date: Nov 2006
    Location: United States
    Search Comp PM
    Originally Posted by borax
    3) So I ran all the videos through ReJig, which gave me all .m2v files....

    I'm pretty sure, ReJig has created the .mp2 or .ac3 files as well.

    Concerning SUPER...
    1. If possible, set the output to elementary streams (m2v + mp2/ac3). I don't know the multiplexer used by SUPER, but usually each authoring application likes elementary streams better than premuxed mpg files.
    2. Use MPEG2 in a DVD compliant size See: http://www.videohelp.com/dvd
    3. Keep the aspect ratio as it is in the source
    4. If the source has 25 fps (PAL standard) keep it. If the source has 29.97fps, keep it too. If the source has 23.976fps keep it also, but apply a 3:2 pulldown to get '29.97fps' for the DVD.
    thanks!

    1. I don't know how to break down the files into .m2v and .mp2/.ac3 with super. The way I use it, it just outputs as a .mpg file.
    4. I'm not sure how to check what the source framerate is. Does it matter that the DVD player I'm trying to play it on is NTSC?
    Quote Quote  
  14. 1. I don't know SUPER at all...
    But you can use a demultiplexer to get the elementary streams if SUPER cannot output them alone.
    4. Avicodec or GSpot will show this information. As I don't know your DVD Player, you need to check it yourself. Probably many NTSC players can also show PAL (25 FPS), but as I live in a PAL country (where nearly all players support both standards), I'm sure.
    Quote Quote  
  15. Member
    Join Date: Sep 2006
    Location: Ohio, United States
    Search Comp PM
    Originally Posted by drewbagel423
    ok... new development with regards to (1):
    .......
    Well now the dvd player was able to play the disc, but there was some weird flickering on the bottom third of the screen.

    I'm guess that this is due to the way SUPER converted the files. What settings should I be using to convert to .mpg?
    .............
    Thanks!
    I've had good luck with gui4ffmpeg and it's ultra simple to use. It produces D1 DVD compliant MPEG2 with AC3 audio by default. I didn't see what type of input file you have in your posts but this program takes a wide variety.

    Load your file in and select NTSC.
    Enter the output file location and name (xxxx.mpg)
    Hit the "Generate Key"
    Hit the encode key (and wait).

    If your input file is mpeg2 and you know the bitrate, you should set the bitrate to equal or up to 20% greater, but at least 4000 -- otherwise just use the default bitrate already filled in.

    If source is mpeg2 and interlaced, you should add the following to the optional flags area:
    -flags ilme+ildct -top 1
    This preserves interlacing through the re-encode.
    Quote Quote  



Similar Threads