VideoHelp Forum
+ Reply to Thread
Results 1 to 13 of 13
Thread
  1. Hi,

    I have avi file encoded using H264. I try to open using VirtualDub for processing. An error message "Could not locate decompressor for format 'H264'" is displayed. I have install H264 codec and ffdshow to my computer. Has any one known this problem? Please help.

    Kinlun Yu
    Quote Quote  
  2. Always Watching guns1inger's Avatar
    Join Date: Apr 2004
    Location: Miskatonic U
    Search Comp PM
    Try installing quicktime alternative. You might also use the latest g-spot or similar to confirm that it is what you think it is.
    Read my blog here.
    Quote Quote  
  3. Member
    Join Date: Dec 2004
    Location: Australia
    Search Comp PM
    From the error it is definatly an avi with the fourCC H264. Really no need to check and qt alt won't help.

    What exactly is "H264 codec"? If you mean x264; it isn't a codec, it is an encoder only.

    In ffdshow, go into the VfW decoder config and enable H.264 decoding (set from disabled to libavcodec).
    Quote Quote  
  4. There is more message that I don't show on my previous post. "VirtualDub requires a video for Windows (VFW) compatible codec to decompress video. DirectShow codec, such as those used by Windows Player, are not suitable."
    I just install quicktime alternative to my computer and open my video with VirtualDub, The problem does not be solved. Also, I run ffdshow and go into the VfW decoder config, I saw the H.264 is enabled (show as "libavCodec"). Is my H.264 decoder is not for VFW? If yes, do I need install H.264 decoder for VFW?

    Thanks

    Kinlun YU
    Quote Quote  
  5. this sounds similar to a problem i had not that long ago, basically, it means that the video was encoded in a manner that virtualdub cant understand, you can use a differant program to convert it such as super...basically how i now understand it, is there's two differant forms of x.264, one that is compatable with virtualdub and one that isnt........for all practical purposes, the one that is compatable with virtualdub is generally a little bit outdated, so a lot of people use the other version instead....
    Quote Quote  
  6. Member
    Join Date: Dec 2004
    Location: Australia
    Search Comp PM
    So you have it setup something like:
    Quote Quote  
  7. celtic_druid,

    Yes, I have setup the H.264 just like screen that you attached in your post. Is there any problem in the setup?

    Kinlun Yu
    Quote Quote  
  8. Member
    Join Date: Dec 2004
    Location: Australia
    Search Comp PM
    You accessed the settings via the "VFW codec configuration" short cut or from the codec selction in VDub? If from the short cut, make sure that ffdshow actually shows up on the list.
    Quote Quote  
  9. Member
    Join Date: Nov 2009
    Location: United States
    Search Comp PM
    Originally Posted by celtic_druid
    You accessed the settings via the "VFW codec configuration" short cut or from the codec selction in VDub? If from the short cut, make sure that ffdshow actually shows up on the list.
    How do you edit 'from the codec section in vdub'?
    Thanks
    Quote Quote  
  10. Try DirectShow plugin, and in the Open video file.. window select file type:
    DirectShow input driver as you see in the picture:
    Name:  névtelen.JPG
Views: 58982
Size:  33.3 KB

    The source of plugin:http://www.virtualdub.org/beta/DShowInputDriver-0.5.zip
    Extract it to the plugins folder.
    Quote Quote  
  11. Member
    Join Date: Feb 2007
    Location: United Kingdom
    Search Comp PM
    Try the free comparable program AVIDemux:
    http://avidemux.razorbyte.com.au/

    On that page get the latest SVN build (at this time it's revision 6129)

    It is as easy to use as Virtualdub.
    Quote Quote  
  12. Best bet to opening non-native files in VirtualDub is using an AVISynth script. You'll still need the codecs, ffdshow is what I use mostly, but it allows a very large range of file types to work in VirtualDub.

    Most of the time the only line needed in the AVISynth script file is:
    DirectShowSource("complete path with file name and extension here")

    Naturally you would then open this AVS file in VirtualDub.
    Quote Quote  
  13. I would agree that AVIsynth is your best bet....create txt document and all you need is this:

    DirectShowSource("filename.ext")

    You may have to include the full path to your file, eg: DirectShowSource("c:\users\owner\desktop\filename. ext")

    .ext is short for extension. It can be AVI, MP4, FLV, etc.......

    Save it as "filename.avs" and drag it into vdub.

    But I'm having a slightly different problem working with h264 videos.

    I can play them in VLC or MPC no problem, but if I import it into vdub 1.9.11 or vdubmod 1.5.10 the aspect ratio is wrong, the movie gets compressed a little horizontally. If i export something, the exported video is also squashed.

    I've used the directshow filter plugin 0.91 and I've tried with avisynth and i get the same problem both ways.

    What's interesting is if I drag the avisynth script into MPC it will also display the wrong aspect ratio. The only difference I can see is when I playback the file is does not seem to invoke Haali (no icons in the system tray), but if I try to import it then it will invoke Haali. If I disable Haali, I can't import the video.

    I only have FFDshow and Haali media splitter installed for codecs.

    I was sure I did not have the problem a month ago, maybe I change a setting somewhere. But I setup a bunch of virtual machines and I get the same thing on all of them.

    I've tried 2 or 3 other mp4 directshow input plugins, but the directshow 0.91 or avisynth seem to be the best.

    I'm thinking it a directshow problem but can't pin it down.
    Quote Quote  



Similar Threads