VideoHelp Forum
+ Reply to Thread
Results 1 to 28 of 28
Thread
  1. I have mediaplayer classic v6.4.8.6. I have an .avi and a .srt file of identical names. I recently formatted my computer and updated my old media player classic to the newest version. I used to be able to watch an .avi with an .srt file in the old media player classic and goto the "play > subtitles" option and enable subtitles. Now I can't because it is grayed out. I got a program called Sub-edit Player and the subtitles work with it. I would like it to work with my media player classic. Please help!
    Quote Quote  
  2. Member
    Join Date: Dec 2004
    Location: Australia
    Search Comp PM
    Make sure that output is set to VMR7/9.
    Quote Quote  
  3. Member fritzi93's Avatar
    Join Date: Nov 2003
    Location: U.S.
    Search Comp PM
    Yeah. View -> Options -> Playback -> Output -> DirectShow Video -> VMR7(renderless) or VMR9(renderless). Then when you play the file go to Navigate -> Subtitle Language.

    IIRC, Celtic Druid has been involved in the development of MPC. Thanks for that! And if I'm wrong, nevermind.
    Pull! Bang! Darn!
    Quote Quote  
  4. Thanks guys, that worked!!!!
    Quote Quote  
  5. Member
    Join Date: Jan 2006
    Location: United States
    Search Comp PM
    I am using media player classic v.6.4.8.7. (the french version but I doubt that it is the origin of my problem) and I have a problem similar to the one arnie22112000 mentioned: I'm trying to load subtitles contained in a .srt file while playing an .avi. When I click on 'Load Subtitles' I get this error message:

    "To load subtitles you have to change the video renderer type and reopen the file.
    -DirectShow : VMR7 or VMR9 renderless
    -RealMedia: special renderer for RealMedia, or open it through DirectShow
    -Quicktime: DX7 or DX9 render for QuickTime
    -ShockWave: n/a"

    I don't really know what a render is but I changed everything according to what they say in View -> Options -> Playback -> Output -> (VMR9renderless and DX9 were in grey, so i did VMR7renderless and DX7). I closed the file and reopened it, but I still got the message when I tried to load the subtitles. I rechecked the options and they were properly set this time.

    I reinstalled media player classic ... same thing.

    Do you have any ideas how to solve this?
    Thanks

    ------------------

    I just installed media player classic on my neighbor's computer and tried to play the same .avi and I had no problem loading the subtitles. So obviously there's something on my computer that prevents it from working.

    Thanks for your help
    -- N --
    Quote Quote  
  6. Member
    Join Date: Jul 2005
    Location: california
    Search Comp PM
    Did anyone find a solution to this because I'm having the same problem. I changed the render settings to those it suggests but still get that notice when I try to load subs. I got the subs off of the web so I'd like to check in Media Player Classic to see if the timing is right before ripping the disc and adding the subs in DVDAuthorGUI.
    Quote Quote  
  7. Member
    Join Date: Jan 2006
    Location: United States
    Search Comp PM
    I never got it to work on my own computer. But I never had any problems on all the other computers (total of 4) on which I tried to play in Media Player Classic avi files with subtitles that I got online.

    So, if all you need is to check the timing of that ONE movie, my advice would be to save yourself some time and troubles, and just try it on a friend's computer.

    Cheers !
    -- N --
    Quote Quote  
  8. ecc, try using VLC, its free. Plays tons of sub formats.
    Quote Quote  
  9. Member
    Join Date: Jul 2005
    Location: california
    Search Comp PM
    VLC seems to work. When I played the DVD with the subtitle track, the display was erratic. Some subs only flashed on briefly. I thought there might be an error with the subs or the program. However, when I played another media file from my hard drive (and forgot to disable the loaded subs from the other one), the subs displayed normally. Perhaps the DVD would play back smoother with the subs if it were ripped to the hard drive because of my computer's overloaded memory. In any case, I think I can reauthor the disc with the subs since they do seem to be synced to the dialogue.
    Quote Quote  
  10. Member
    Join Date: Feb 2008
    Location: Canada
    Search Comp PM
    I am trying to play and .mkv file when I open it in vlc the subs work but they go off the screen to the right, I cant make them work in mpc at all. I did the VMR7(renderless) thing and now mpc wont even open the file. plz someone help
    Quote Quote  
  11. Member
    Join Date: Feb 2010
    Location: italy
    Search PM
    guys,
    same problem here.
    Media player classic shows subtitles, but the entire Navigate menu and the Subtitles menu under Play
    ARE DISABLED/GREYED OUT
    what should I do?
    thanks in advance
    Quote Quote  
  12. Member
    Join Date: Feb 2010
    Location: Italy
    Search Comp PM
    Hey, I have exactly the same problem. Subtitles work but I can't switch them on or off, the sutitle submenu is greyed out and so is the subtitle synching bar activation. The keyboard shortcuts involving subtitles don't work. There's an interesting faq here: http://www.codecguide.com/faq_subtitles.htm but it still doesn't work. EDIT: Ok, the faq makes subtitles submenus work in 32 bit version. They don't seem to work no matter what with 64 bit version.
    Last edited by Cooperdale; 18th Feb 2010 at 06:37.
    Quote Quote  
  13. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    And you are sure that it's switchable subtitles? Try in VLC or MPCHC or use separate subtitle filter like vsfilter.
    Quote Quote  
  14. Member
    Join Date: Feb 2010
    Location: Italy
    Search Comp PM
    Originally Posted by Baldrick View Post
    And you are sure that it's switchable subtitles? Try in VLC or MPCHC or use separate subtitle filter like vsfilter.
    They work in VLC. Yes I'm actually using Mpchc, and I can confirm that submenus stay greyed out when using an external filter such as vsfilter. The submenus are not greyed out when you're using mpc or mpchc own subtitle filter. But they're always greyed out on 64 bit version. What I'm trying to do, by the way, is find the best media player for real-time syncing of subtitles. I'm about to build a htpc and I need a media player which is very flexible in the subtitle area. The 32 bit version is fine now that I've made it work, but there are some things I don't like. Maybe I should open a new thread about this, don't want to go ot.
    Quote Quote  
  15. Read the 3rd post it tells you exactly what you need to do. If you still have problems you need to go to File > Open File... > your file > OK
    Quote Quote  
  16. Member
    Join Date: Feb 2010
    Location: Italy
    Search Comp PM
    Originally Posted by raphen View Post
    Read the 3rd post it tells you exactly what you need to do. If you still have problems you need to go to File > Open File... > your file > OK
    I did all that when I had this problem. It was no use with the 64bit version. Anyway now I'm using Vlc, maybe a recent update fixed this.
    Quote Quote  
  17. I had same issue, but fixed it. Have an avi file with an srt file. Using Media Player Classic x64 Ed. v1.3.12490.

    After selecting VMR7 and VMR9 renderless I didn't have subtitles. Only when I went to Options-Subtitles menu and checked "override placement" did it work.

    **Update.

    Just tried it again and it didn't work. While playing the video I clicked the srt file from another window and dragged and dropped into the playing movie. It worked. BTW, for the drag-and-drop to work you cannot have "Playlist" displayed (checked under View).
    Last edited by e6bwhiz; 28th Feb 2011 at 12:04.
    Quote Quote  
  18. Member
    Join Date: Nov 2010
    Location: Singapore
    Search Comp PM
    so...i registered just to answer all the questions...
    this is what worked for me: go to your task bar when viewing the video and right-click on haali media splitter.
    then you can select your audio/subs. and that's all

    hope that helps!
    Quote Quote  
  19. NkR
    Join Date: Dec 2006
    Location: Mauritius
    Search Comp PM
    For 64 bit users
    1. install k-lite 64 bit (http://www.codecguide.com/klcp_64bit.htm)
    2. install Media player classic 64 bit (http://mpc-hc.sourceforge.net/download-media-player-classic-hc.html)
    open Media player classic then goto View > option > Internal filters > disable matroska (untick the box) and other formats for which you want to use external filters. click apply, OK then restart Media player classic.

    That all. Now you can change language/subtitle by Navigation > audio/subtitle language.

    use the full links which are for 64 bit.
    Last edited by Neelendra; 15th Nov 2010 at 04:17. Reason: 64 bit links added
    Quote Quote  
  20. Thank you for linking to the faq. Worked for me A small correction, in my case (XP) the Haali Media Splitter icon was on my system tray, near the clock.
    Originally Posted by Gwinvere View Post
    so...i registered just to answer all the questions...
    this is what worked for me: go to your task bar when viewing the video and right-click on haali media splitter.
    then you can select your audio/subs. and that's all

    hope that helps!
    Quote Quote  
  21. Member deepcut's Avatar
    Join Date: Nov 2011
    Location: London, UK.
    Search Comp PM
    Hi. For most files i have no problem with subtitles in MPC. I recently tried to watch a film in HD (.MKV format) and couldn't get the subtitles to work.

    I have tried all of the steps outlined here, on both my WinXP 32-bit machine and my Win7 64-bit machine.

    Nothing has worked so far, tha Halli medis splitter tray icon has options for French/English or No subtitles but this doesn't work. Sometimes the Navigates/Subtitles option is greyed out, sometimes it is clickable but only has 'no subtitles' as the option.

    I have re-downloaded the subtitles file, i have looked at it in notepad and it isn't broken.

    I then tried an SD version of the film in .AVI format and am having the same problem.

    My 32-bit version of MPC is 1.5.2.3456, so is the 64-bit version.

    When i play the file with SubEdit, the subtitles appear but they zoom along at about 5 per second.

    Any help greatly appreciated.
    Quote Quote  
  22. Member
    Join Date: Jan 2012
    Location: Palhoça, Brasil
    Search PM
    How to add srt subtitles in 3D SBS mkv Video file using Windows Media PLayer Classic ?
    Quote Quote  
  23. Member bahjan's Avatar
    Join Date: Jan 2010
    Location: in the past
    Search Comp PM
    Okay, so I have discovered a problem displaying subtitles in Media Player Classic too

    1. I did as in post 3 Options - Playback - Output - and changed DirectShow - I tried the VMR7 and VMR9 but nothing (yes, I did click 'Apply' first) but nope I still get message : To load subtitles you have to change the video renderer and reopen file -DirectShow: VMR7/VMR9 (renderless) or Haali Video Renderer - RealMedia Special Renderer for RealMedia or open it through DirectShow -Quicktime DX7 or DX9 renderer for Quicktime

    2. I did try Options - Subtitles and selected 'override placement' - but again no change.

    3. The Haali Video Renderer doesn't seem to be on my system (I'm using XP SP3) ??

    I am opening dvd files via VIDEO_TS.IFO not just VOBS The odd thing is MPC runs with subtitles in Jubler, I just wanted to run the video files with subs outside the programme to check for sychro issues, as Jubler only uses AVI (and they seem out of sync) Besides, I want to add subs to better quality VOB files, so I assume converting AVI to VOB would undo any re-syncing I do in Jubler. Could it be Jubler has changed the settings and only expects subs to be run from inside it? This does not seem to be the problem for others on the thread.

    I think I might try SubtitleEdit......
    Last edited by bahjan; 27th Jan 2012 at 10:45.
    Quote Quote  
  24. Member
    Join Date: Feb 2012
    Location: japan
    Search PM
    All you need to do is get the subtitles into the same folder as the video, and make sure the subtitles file and the video file both have the exact same name. When you restart the movie (I use classic media player), the subtitles should come up automatically. No need to load subtitles or anything. Enjoy the show.
    Quote Quote  
  25. Member bahjan's Avatar
    Join Date: Jan 2010
    Location: in the past
    Search Comp PM
    Thanks for the advice. I put xvid.avi and .srt in together but still came up with the rendering error as above. Is it because I am using the wrong format for MPC?
    Quote Quote  
  26. Member
    Join Date: Feb 2012
    Location: japan
    Search PM
    im not good at these types of things, but... I had the same problem, then I downloaded a separate subtitle file for the movie i wanted to watch. and then put it in the same folder as the video file, and i changed the name of the subtitle file to exactly match the name of the video file--EXCEPT i left the suffix .srt on the subtitle file. Apparently, that is very important. Then, i simply opened the movie in MPC and played it. The subtitles were automatically at the bottom of the movie. I didn't have to load anything, and so no more error messages.

    the video i was watching at this time was an mkv file, but i've used this method with .avi files and had no problems... i don't know about an xvid.avi file... >_<

    If this doesn't work... i have no idea what to do >_<
    Quote Quote  
  27. Member bahjan's Avatar
    Join Date: Jan 2010
    Location: in the past
    Search Comp PM
    I was trying again with this issue and stumbled across the solution (for me anyway) First to explain, I have several AVI files with .srt subtitle files.

    1. Make sure your avi/vob file/s and .srt file have exactly the same name ie if more than one file something like this: film_1.avi then the srt should be film_1.srt. In short, everything before the .vob .avi and .srt must be the same and in the same folder.

    2. In MPC - File -Options - Playback I set 'Direct Show' 'RealMedia' and 'Quicktime' to 'System default' and 'Direct Show Audio' to 'System Default'
    As soon as I set DirectShow to 'default' instead of the VMR7 or VMR9 renderless as suggested by MPC message - the subtitles re-appeared ! Don't ask me why MPC threw out the unhelpful message....

    3.MPC - In Player - Formats I selected all formats and ticked all the autoplay options.
    Last edited by bahjan; 8th Mar 2012 at 05:22.
    Quote Quote  
  28. Hey guys!
    I'm not good in English but i wanna help..so plz forgive me if i have a mistake in Grammar ok ^^.
    I have same subtitle problem when i watched a movie with MPC Player ( the newest version ), so, i tried to change some options and it worked..Here they come:
    1- Click View in MPC toolbar and choose Option ( or you can press "O" anw )
    2- Can you see " Output " in " Playback" ? Click it.
    3- In the Output screen, you have to choose "Video Missing Render 7 (renderless)" in "DirectShow Video" and the same choice with RealMedia Video, Quicktime Video (Video Missing Render 7 (renderless) ). About Audio Renderer i chose "3. Default DirectSound Device (00800000)", i did not know about this option but it worked, so, whatever. Finally, press Apply > OK.
    4. Now you close the MPC Player and open it again, so you can load the subtitle for the movie.
    P/s: The subtitle must has the same name with the movie. If not ?? You must rename it.
    I hope it will work with you, too.
    Quote Quote  



Similar Threads