VideoHelp Forum
+ Reply to Thread
Results 1 to 12 of 12
Thread
  1. My problem is that a DVD I created using ffmpegx 0.0.9t (and the ffmpegx dvd encoder) from a .avi XVid file plays fine in my newer MDD G4 1.25 desktop box, but the same DVD plays horribly in my old Pismo G3 500 and in a friend's old 366 MHziMac. 75% of the screen has a green translucent hue that flickers.
    The same DVD will play ok in the old machines if I use VLC as opposed to Apple's DVD Player, but VLC runs too slow on these machines -jerky video.

    I have tried:
    Encoding the DVD with the mpeg2enc encoder instead of the ffmpeg one
    Tried older ffmpegx v 0.0.9r with older codecs
    Tested the .DVD folder itself before burning; it also has the green hue when I play its VIDEO_TS folder in DVD Player on older machines.

    Still got the green hue when playing the DVD on older DVD machines. It's a shame cos I need to use the Pismo's video-out to watch DVDs on my TV.
    Odd tho cos Ive made several DVDs in the past in exactly the same way and they've always worked fine in older machines, as long as I burn them on a slow setting.

    Anyone seen something like this before?
    Quote Quote  
  2. One more thing...

    I encoded the DVD as 'NTSC FILM', which corresponds to the original .avi file fps etc; and then I also tried encoding it as PAL -this also made no difference. Still got the green hue.
    Quote Quote  
  3. I think your problem is the framerate.

    NTSC DVD supports a framerate 29,97 fps or of 23,976 fps with 3:2 pulldown, which fakes the 29.97.

    If you are using NTSC film, you either need to manually apply pulldown in the tools tab if using ffmpeg to encode, or make sure to turn on the 3:2 option if using mpeg2enc to encode.

    Alph
    Quote Quote  
  4. The original .avi is 23.976 fps, I encoded (ffmpeg encoder) on setting 'DVD 16:9' with manually added letterbox, and framerate 'NTSC FILM' which is also 23.976 fps. I thought this was enough, as original and output movie fps are the same.
    So, I should also go to the 'Pull' tab in Tools, and select my film there to add these flags? At what stage? It says to select an .m2v file. I dont recall getting a .m2v file at any stage in the .avi to DVD conversion process
    Thanks for the help

    bllx
    Quote Quote  
  5. After you encode with ffmpeg

    -if you had the normalize audio on, you get a .mpv and an ac3 file. You can simply change the mpv to m2v and apply pulldown from the tools tab and then remux and author your video and audio

    -if normalize was off, then you get a .mpg file which you can then demux with Mpeg Streamclip to .m2v and .ac3, and then apply the pulldown, remux and author as above.


    Cheers
    Quote Quote  
  6. OK, Im re-encoding the .avi to DVD with ffmpeg and Normalise audio on.
    I'm going to get a .mpv file and a .ac3 file, and also a .DVD folder, the 'finished' result.
    So, you say I should ditch that .DVD folder; apply pulldown to the mpv (first changing its suffix to .m2v), and then create a new .DVD folder for burning from the m2v and the ac3 files? How do I create a burnable .DVD folder from the pulldown-applied m2v and the ac3 file?
    Thanks again
    Quote Quote  
  7. After you apply pulldown.

    Using the lastest versio nof FFMPEGX, in the tools tab, under Mux,

    -select your pulldown.m2v file for video
    -and your original ac3 file for audio
    -check author as DVD (video_ts)
    -Hit the mux button.

    Cheers

    P.S.
    -It would have been possible to demux your first VOB with Mpeg Streamclip instead of re-encoding.
    -When you encode you can avoid creating the first DVD folder by unchecking the Author as DVD checkbox in the options tab
    Quote Quote  
  8. Well alph, I did it all exactly as you said, and I got a new muxed DVD no problem. However exactly the same green effect is still present when I play the VIDEO_TS file in the Pismo.
    Oh well. Thanks for trying.
    It's a weird one though, VLC playing the same dvd withought the green problem but Apple's DVD Player making it green, on the same computer.
    Quote Quote  
  9. I'm not sure about the older computers, but didn't some of them have hardware decoder which could be causing this: ie vlc does not use the decoder.

    Are you burning the video_ts to DVD, or are you just trying to play the vob in Video Player afer copying it over a network or something?

    I'm quite sure the green you see are missing frames; I'd be curious to know if a burnt DVD plays properly.

    Also, what OS is on the Pismo?

    These are just ideas I'm putting forward for consideration. Maybe someone else can run with one of them.

    Cheers,
    Alph
    Quote Quote  
  10. Maybe that's it, maybe the G4 plays DVDs without using any hardware encoder, but the older computers use one, and this is creating the problem.

    On my first attempt I burned an actual DVD, which alerted me to the problem when I tried to play it in the Pismo. Since then tho, subsequent DVDs I created in testing, I left as .DVD folders and tested them like that.

    All computers involved are running same OS, 10.4.2

    You say the green is probably a sign of missing frames: but then wouldn't the playback look jerky? It plays very smoothly, it's just got the colour badly wrong.
    Quote Quote  
  11. BTW have also managed to test the DVD I made in a regular DVD player not a computer. Has same issue of green everywhere, and also plays very badly, jerkily.
    Consumer DVD machines decode in hardware don't they?
    So there must be something about the dvd I created that doesn't get on with hardware decoding for playback, but is ok with software decoding.
    Can't imagine what. Anyone got any ideas?

    BTW thanks a lot alph for your help.
    Quote Quote  
  12. Given the problem with the commercial standalone DVD player I'm inclined to think that your original file or the encode was bad. It seems the problem had nothing to do with your Pismo or the framerate per say.

    Try running your AVI through FFMPEGX's Fix tool in the tools tab. Once that is done, check that the audio is still in sync by playing the the AVI in VLC. Make sure to check near the end of the movie too. If the audio is ok, try re-encoding this "Fixed" AVI.

    You might want to test this with a small portion, 5 minutes or so, of your movie by using the split tool in the Filter tab. Always make sure you keep your original AVI around however.

    No guarantees, but probably worth a try

    Alph
    Quote Quote  



Similar Threads