VideoHelp Forum
+ Reply to Thread
Results 1 to 20 of 20
Thread
  1. I have noticed that when you 'obtain' videos that have the AC3 audio format, they are often also very quiet. This can be very annoying for obvious reasons.
    Also without a special codec that I found very hard to get you cannot increase the volume using VirtualDub. So i made this guide. It is quite lengthy, but it works!


    The tools you need are:

    Goldwave
    virtualdub (or Mod)
    Lame MP3 Codec (or any other Audio Compression codec)


    1. Open up GoldWave.

    2. Click File>Open and pick the video file:



    3. After it has loaded, click effect>volume>maximise:



    4. Not in the box on the top right of the window that comes up, choose a suitable value.
    I normally choose +15dB, but put it up and listen to the preview.



    5. After this has done, click file>save as... And save the output Wav file

    6. Close goldwave, and open VirtualDub. Click File>Open video File:



    7. Click Audio>Wav Audio. And pick the file you saved from Goldwave.



    8. Click Audio>Full processing mode. Then Audio>Compression. And in the box that comes up Click Lame MP3 on the left and The bitrate you want on the right:



    9. Click Video>Direct Stream Copy.

    10. Click File>Save As Avi...

    11. Choose a file name and click OK

    12. Wait for it to finish encoding and then you are done:




    I am welcome to any comments, or criticism.
    Quote Quote  
  2. AC3 is untouched from the DVD. When you play your AVI on your DVD/MPEG-4 standalone is it too soft? Mine isn't. So, is it only soft when played on a computer? For many people it is. What does that tell you? That it's the AC3Filter that's causing it. The default settings play at too low of a volume. I haven't found one person's soft AC3 problem that hasn't been cured by going into the AC3Filter Config and changing the Preset to loud. You can also play with the sliders if you want.

    The AC3 has already been normalized. Just blindly boosting the decibal rate is almost sure to cause clipping. It may or may not be noticeable, but it's there. Try and open one of your MP3s in MP3Gain and check. Reencoding the AC3 to MP3 kind of defeats the purpose of having the AC3 in the first place. Just my opinion.
    Quote Quote  
  3. I guess you are right.
    But My stand alone does not play AVI files so i wouldn't be able to check this.
    Also I can't see anywhere in my AC3 filter to change the preset to loud.
    Quote Quote  
  4. Hi-

    My stand alone does not play AVI files

    You could also just play a regular DVD. It's the same AC3 audio. There is such a thing as badly mixed AC3, though, like when the music is too loud and the dialog is too soft, and you have to constantly adjust the volume. But that's a different problem

    Anyway, I'm using version 0.70b of the AC3Filter. I think it's old now, but it works, so I haven't bothered to upgrade. In the lower left corner of the Main Tab are the Presets, and one of them says loud.

    However, I'm far from an audio expert. It's just that I've never had this quiet AC3 problem myself, although I have often read about it, and after advising others of this "fix", they're happy.

    It looks like a well written guide, and creating it and the pics must have taken you some time. So, if it helps a few people, it will have been worth it. Maybe some other people will chime in soon with their opinions.
    Quote Quote  
  5. I just clicked on that AC3Filter link (cool feature that this site has-creating the links to the software automatically), and the picture of the latest version shows that same Preset in the lower left corner. You might have to make sure that your AC3 is being decoded by the AC3Filter, rather than by some other filter you may have installed.
    Quote Quote  
  6. Well my DVDs played at a fine volume but these 2 avi files played reay quietly. I do have only 1 AC3 filter installed, and it does have the preset thing, but there ins only one under there: Default.
    Quote Quote  
  7. Download the new version. It includes a couple of presets the older versions didn't have.
    Cheers, Jim
    My DVDLab Guides
    Quote Quote  
  8. Thanks for the effort and the info.
    Quote Quote  
  9. great stuff, works really well,
    thou step 4 took a read or two to understand,,

    4. Not in the box on the top right of the window that comes up, choose a suitable value.
    I normally choose +15dB, but put it up and listen to the preview.

    i assume it was meant to be NOW not NOT
    apart from that typo, wicked, very easy to follow
    thanks heaps
    "Red ship crashes into blue ship - sailors marooned."


    Quote Quote  
  10. Member
    Join Date: Oct 2007
    Location: United States
    Search Comp PM
    Great tutorial! My only comment here would be that Goldwave is a commercial editor...and there are SO many other freeware products out there that I'd modify this simply to use whatever your favorite WAV editor is. My personal recommendation would be to use Audacity. It's quite awesome and quite FREE! That said I use Nero Wav editor most of the time - but that too is commercial (came with my Nero Burner software so you may already have that too if you use the retail Nero product).

    I used this tutorial for a couple of AVIs that had low AC3 volumes and I could not BELIEVE how much faster I was able to boost the volume!!! Previously I was de-muxing and re-muxing the whole shebang with Full Video Processing and that just takes HOURS. I feel like such a schmuck now...all I had to do was process the audio. *sigh* Live and learn.

    By the way, I was brought here by Google and I'm seeing the number of requests for this procedure increase quite a bit recently. BEFORE you do ANYTHING like this...check your AC3 Filter setting and make sure the preset is set to LOUD!!! I'll bet you dollars to donuts it isn't! It would appear the last update to the software left the preset too low and many, many folks are running into the low volume AC3 problem. If you fix that preset, you'll likely avoid ALL of this re-encoding nonsense. In my case, the preset was already loud, so I did really have to redo the AVI files I was having a problem with...hopefully you will not have to.
    Quote Quote  
  11. Member
    Join Date: Nov 2008
    Location: United States
    Search Comp PM
    I think I followed the instructions well, but step 8 does not display LAME MP3 as a choice. I rebooted, no change. Can anyone help me with the correct install for LAME?
    Quote Quote  
  12. You need to install LAME ACM, not the DirectShow version.
    http://www.rarewares.org/mp3-lame-dshow-acm.php
    Quote Quote  
  13. Member
    Join Date: Nov 2008
    Location: United States
    Search Comp PM
    That was it. Thanks
    Quote Quote  
  14. Member
    Join Date: Feb 2009
    Location: Australia
    Search Comp PM
    I'm stuck at step 7...VirtualDub wont open the Wav files I've saved.
    Help please
    Quote Quote  
  15. Member
    Join Date: Feb 2009
    Location: Australia
    Search Comp PM
    Nevermind...Thought it meant to open the Wav file when you click "Open VIdeo File..." thought that was a bit odd. Other than that, cheers
    Quote Quote  
  16. Member
    Join Date: Mar 2008
    Location: United States
    Search Comp PM
    Standalone players handle it differently. Mine, (for example), quite
    often plays avi's with presumably original ac3, very,very quietly.
    I can't hear a thing. I usually have to do something similar to this tutorial
    or else I can't watch the file. I usually use besweet for the conversion,
    but end up with a similar result.
    Quote Quote  
  17. Member
    Join Date: Nov 2002
    Location: United States
    Search Comp PM
    I'm converting all of my friends videos off of his COX cable box to DivX and all of them need to have the audio raised. For some reason, COX lowers the volume on all the recordings so if he listens to a recording, he has to turn the volume up and when he goes to watch TV or a DVD, he blows his speakers up the volume is so loud.

    You can bypass the Goldwave step in the guide by using the built-in volume adjuster in Virtualdub. Audio > Full Processing > Volume (set to +15.1bB) > Compression > Lame MP3

    EDIT: This only works for 2 channel AC3 since Virtualdub does not handle 6 channel AC3. You can import a 6 channel AC3 file and direct stream copy but the volume of the file needs to be fixed (with Belight?) before importing to Virtualdub.
    Quote Quote  
  18. just to add my 2 cents worth. having had the same problem ie low audio, avi via usb on a media centre, i ran the avi thru " format factory"
    choose all to avi/pick or add the avi/ output setting/ audio stream setting / change audio channel to 6 and the volume db to 12db

    when u play back now be sure to turn down the volume before starting, its loud
    Quote Quote  
  19. Thanks a lot... Heres the smart deal...

    I have been trying this in Windows XP and was having so much trouble with this. I downloaded Video with 6 channel audio output and no voice in WMP. Its possibly because my sound card and speakers does not support 6 channels and I am not using the proper hardware and speakers . I tried with power DVD 11 and it was OK, I could hear the voices but still the volume was too low and I tried my normal 2 channel speakers to its fullest but still couldnt hear properly. I downloaded all codecs, tried all methods on internet to change 6 channel output to 2 channel outpul while playback, but ended up in no success. I also tried the method in this thred, but ended up in creating a file which does not have proper AV synchronisation.

    At last, this worked 100%. I could playback 6 channel AC3 Video on a 2 channel stereo speakers/headphones with absolute clarity as I could play a normal 2 channel audio playback. The solution was very simple. I Had dual OS Win XP and windows 7 ultimate 64 bit. I booted on to Win 7 64 bit and played using the media player, the problem is solved completely.

    Cheers Mates.
    Quote Quote  



Similar Threads