
 

VideoReDo TVSuite Overview

Learn how to use VideoReDo TVSuite:

●     Screen Layout - An overview of the VideoReDo screen. 
●     Getting Started - How open open files, navigate, create selections, and 

save your work.
●     Using Preview Mode. 
●     Using the thumbnail and audio graph.
●     Using Ad-Detective - How to setup and run VideoReDo's computer assisted 

commercial detection.
●     Importing Video from a DVD.
●     Creating a Video Title using the Title Editor.
●     Authoring and Burning a DVD.
●     Reference to individual dialogs.
●     Keyboard shortcuts - A complete list of Keyboard shortcuts.
●     How to Register Your Copy of VideoReDo.
●     Getting support and help.

 
 

VideoReDo TVSuite Help - © 2003-2007 DRDSystems, Inc.



 
Screen Layout 

 
The VideoReDo screen layout is intuitive yet powerful. Its customizable navigation controls provide 
speed and flexibility to quickly find material in long videos, yet accurately position to the exact frames 
you want to cut.

Click on the appropriate label to learn more.
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Getting Started 

 
Overview:

Editing MPEG video is a snap with VideoReDo.  This section will take you through the basic features 
and capabilities of the program.

VideoReDo works directly with compressed digital video, specifically MPEG1 and MPEG2. It allows you to 
remove unwanted scenes from a video program (cutting) and piece together scenes from multiple programs 
into one seamless file (joining). Since VideoReDo works without decoding and re-encoding the source material, 
the original video quality is preserved through multiple edits. Edit points are accurate to a single frame, and, with 
a variety of rich navigation tools you can move quickly through your video programs to find the exact material 
you want to include or exclude from your output file. 

VideoReDo will automatically fix MPEG files that contain corrupted or missing audio or video material resulting 
in MPEG files that stay in sync. Should your original source program not be in perfect audio/video sync, 
VideoReDo has the tools that let you adjust the audio back into perfect synchronization. 

VideoReDo adds additional options such as real-time preview of your edits, computer assisted 
commercial detection, and thumbnail previews. 

TVSuite adds the additional capabilities to import your titles from a DVD as well as author and burn DVDs.

For additional information:

●     Quick Start Guide 
●     Navigating the video program 
●     Managing selections 
●     Joining multiple programs together 
●     Authoring and Burning a DVD 
●     Getting Help 

 
 

VideoReDo TVSuite Help - © 2003-2007 DRDSystems, Inc.



 
Using Preview Mode 

 
VideoReDo has two modes, Edit Mode and Preview Mode. Edit mode is the default when a file is opened 
and is the mode in which cuts are marked and manipulated. Preview mode gives you an opportunity to 
preview your work before saving. In edit mode, the navigation bar shows the entire original program and is 
colored red and green to indicates where in the original program the marked cuts and scenes are. When you 
switch to preview mode, the navigation bar switches to a purple color. In addition the thumbnail window, 
if displayed, changes background color. 

In preview mode, all displayed time codes are based on their position in the output file, not the input file, and 
scene markers which lie in cut sections will not be visible. 

Switching between modes:
You can toggle between preview and edit either by pressing the P key, or pressing the center, film strip, section 

of the preview buttons: .  

 
You can also switch from preview mode back to edit mode, by clicking on either of the selection button:  
 
When you switch between modes, the cut regions are transferred into diamonds on the preview navigation bar. 
 

  
Jumping to the next or previous cut:

You can jump to the next or previous cut by pressing the right or left arrow of the preview button:  

or pressing the Tab or Shift+Tab key.  
Automatically previewing your cuts:

VideoReDo lets you automatically preview your cuts. To enable this feature, set the Preview Lead-in (secs) 
on the General Parameters option page to a non-zero value. Then when you jump to the next or previous cut 
while in preview mode, VideoReDo will automatically jump to the Lead-in seconds before the cut and start playing. 

 

Preview Mode Zoom:

Zoom mode is used to magnify a section of the navigation bar to better see cut points and scene markers. Its 
useful when editing long programs where the markers may be too close together to be distinguished from 
one another. 

The "Z" key will toggle zoom on and off. You can also press the "F7" and "F8" keys to decrease or increase 
the level of magnification. These same options are available on the View menu as well. 

Standard view: 

Zoomed view: Note that the navigation bar only shows the zoomed or magnified area. The lower slider has 
been replaced with the a graphic highlighting the zoomed area within the entire timeline. 



Changing the zoomed area: 

You can increase or decrease the zoomed area by positioning the mouse on the edges of the zoom window 
( see #1 below ) and dragging them to the left or right. If you prefer, pressing the "F7" or "F8" keys to decrease 
or increase the zoom window size.

To move the zoom window, click inside the zoom area in zoom bar (see #2 below). The cursor will change to 
the image of a hand and you can then drag the zoom window to the desired position. You can also pressing 
the comma or period keys to move the zoom area left or right, respectively.

 

Chapter Marks: 

Chapter marks are displayed in preview mode based upon settings in Tools>Options>Chapter Marks.

Green triangles above the timeline represent the locations of chapter marks. Chapter marks based on cuts 
are represented by black lines with diamonds ( see #1 below.) Chapter marks based on scene markers 
are represented by red lines (see #2 below.)
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Using the thumbnail and audio graph 

 
The thumbnail and audio graph is an advanced navigation tool of VideoReDo. 

There are four parts to the thumbnail window. Starting from the top: 

1.  Cut Line: The thin red and green line at the top indicates which frames will appear in the saved output file. 
Red indicates the frames will be cut, while green indicates the frame will be included.

2.  Thumbnails: The thumbnails will span the width of the application. The center thumbnail, surrounded by a 
green frame corresponds to the currently displayed frame in the main video window.

3.  Audio graph: The audio graph displays the relative volume levels of the audio stream. The graph is auto-
scaling based on the displayed data and does not represent absolute audio levels. Therefore we do not 
recommend using the graph to compare levels between programs or different sections of the same program. If 
the audio is AC3 and contains both 2.0 and 5.1, the audio will display in different colors (see above) which can 
be customized using the Thumbnail Options screen. 

 
Note: For performance reasons, the audio graph is only displayed for thumbnail intervals of 2 seconds or less.  

4.  Time code: The time code line shows the timecode for each frame. A "P" suffix next to the time code 
indicates that this is a "Pseudo Frame", created for display purposes only for 3:2 pulldown material. Edits cannot 
be performed on these frames as they are generated for playback only. 

Note: The audio graph and time code sections are optional and can be disabled using the Thumbnail 
Options screen. 

Activating the thumbnail window:
The thumbnail can be displayed or removed either by pressing the F11 key or clicking on View > 
Show Thumbnails.

Changing the thumbnail interval: One of the most powerful features of the thumbnail window is the ability 
to change the interval between each thumbnail from single frame to multiple seconds. There are 10 
different interval presets which can be customized using the Thumbnail Options screen. To change the interval 
use one of the following methods:

1.  Use the + or - keys to increase or decrease the interval by one step. 
2.  Double-click the mouse on the center thumbnail to decrease the interval by one step.
3.  Press Ctrl+<number key> (e.g. Ctrl+0) to switch the interval to a specific step. 
4.  Right-click on the thumbnail window to display a menu from which you can select a thumbnail interval: 

 

 

Navigating using the thumbnail window: The the thumbnail window can be used as a navigation tool 
as well.

1.  Clicking on a thumbnail will cause the video to jump to that frame. If you double-click on a thumbnail 
frame, VideoReDo will jump to that frame and change the display to the next lower interval.

2.  Press one of the number keys to jump to specific frame. The center frame with the green 
surround corresponds to the number '5'. The frame immediately to the left is '4' the frame to the right is '6'. 
Likewise two frames to the left and right are the keys '3' and '7'. You can only use the keyboard to jump the 
5 frames to the left of the current frame or 4 frames to the right of the current frame.



Thumbnails in preview mode:
The thumbnail window operates the same in preview mode with two exceptions: (1) The background color of 
the thumbnail window changes and (2) the Cut Line bar is not displayed. You can customize the background 
color of the thumbnail window for both edit and preview modes using the Thumbnail Options screen. 
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Using Ad-Detective 

 
Ad-Detective is the VideoReDo capability to detect, mark and cut commercials. Depending upon your 
preferred method of working, it can be used interactively or in a batch oriented mode. In an interactive mode, 
Ad-Detective is used to augment the manual search and editing process, while in a batch oriented mode, the 
entire program is first scanned, marked for possible commercials with the results saved as a VideoReDo 
project file. Later on, the results of this scan are reviewed by accuracy and final editing. Which method you use 
is based upon your working style as well as the amount of time you have. Complete Ad-Detective scans 
generally take about 12 minutes / hour of video although actual performance will vary greatly based upon the 
the speed of your CPU as well as the type of material. HD material can take substantially longer to process. 

Interactive Mode: 

To start an Ad-Detective scan from the current location, click on the Ad-Detective arrow button:  or 
pressing Ctrl+A. VideoReDo will start to decode frames looking for scene changes. When a scene change 
is found, a red marker is placed on the navigation bar timeline. Additional behavior such as pausing, 
or automatically cutting the commercial is determined by settings in the Ad-Detective Parameters dialog.  
 
To stop a scan, press the arrow button again, the pause / play button, or the space bar.  

Batch mode:
You can run Ad-Detective from the batch VideoReDo Batch Manager by selecting the Ad Detective Scan as 

the batch destination type:  
 
This option will run Ad-Detective against the entire program and save the scene markers in a VideoReDo 
project file (VPrj).

Scene Markers:

Scene markers indicate the possible location of commercial breaks which occur when scenes change 
between programs and commercial material. Scene markers appear as red flags along the navigation bar:  

 

To jump to a scene marker: You can jump to the previous or next scene marker by pressing F5 or F6. 

The scene jump arrows . If you switch to preview mode, only those scene markers which are in un-
cut areas will be visible. If also selected as chapter marks, a green triangle will appear when in preview mode.

To remove or manually add a scene marker: To remove a scene marker, place the cursor on top of 
a marker by jumping to it and then pressing A or selecting Add / Remove from the Ad-Detective menu. Doing 
the same action where there is currently no scene marker will add a new marker. 

To remove all scene markers: Press Ctrl+Shift+A or click on the "Clear All Scene Marks" on the 
Ad-Detective menu.
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Open DVD title folder 
 

Open DVD title folder
 

To open a DVD title either from a DVD or from a VIDEO_TS folder copied to your hard drive, click on the menu 
File > Open Title from a DVD. A standard folder broswer window will be displayed. You can either point to a 
specific VIDEO_TS folder or the parent folder.

 

VideoReDo will search the IFO and VOB files in the VIDEO_TS folder to create a list of all the titles on the 
DVD. Unfortuneatly, there are no actual text titles on a DVD so we can present you with the length of each 
found title. 

Hide titles without audio: Very often DVD menus, espeically motion menus, can look like full titles. Check 
this option to hide these menus that don't contain audio.

Audio Stream: If there are multiple audio streams in this title, use this list to select the one you want to edit.

Once you click OK, VideoReDo will create a .VLST file containing the list of VOBs that comprise each title 
and automatically open the file.
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Title editor

 

Show TV safe area: Many television sets, especially CRT-based ones do not show the entire video picture, 
but clip a portion of all the margins. The amount of clipping differs from set to set, but all sets are guaranteed 
to show at least 80% of the broadcast picture. When placing titles and other text in on a menu screen, its 
is recommend that you keep them in the safe area. Checking this option displays a dashed rectangle of the TV 
safe area.

Remove Title: Click this button to remove the title from the current video. It is only displayed once a title 
has been added to the video.

Title Properties: The options in this box determine if the menu template should be encoded in 4:3 or 
16:9 aspect ratio. You should also select a video resolution that matches the video resolution of the video you 
are editing. VideoReDo will resize the title, automatically to the match the video resolution, but if you edit at a 
low resolution and VideoReDo needs to size it up, the text and graphics will have a "jagged" look to them.

Text box properties: Text boxes are the basic object used by the menu template. Each text box can have 
its own dimensions, and text style (font, color, etc). To modify the attributes or contents of a text box you will 
need to select it by clicking anywhere in the text box. When a text box is selected it will highlighted with a 
rectangle with resizing handles. 

Center text box: While a text box is selected, click on one of these button to center the text box 
vertically, horizontally or both. 

Add text box: Click on this button to add a new text box. The text box will be placed on the screen 
and automatically selected.

Remove text box: Click this button to remove the currently selected text box.

Background properties: The two options in this box are used to change the background of the menu. 

Solid color: Select this option to set the back to a solid color. To select a different color simply click on the 



color sample.

Graphic / Select Image: Select "Graphic" and press "Select Image" to copy any recognized graphic file (.
bmp, .jpg, .gif, .png, etc), to the menu background. Graphic files are stretched to fit the actual dimensions of 
the menu, which are 720x480 for NTSC and 720x576 for PAL. 
 
If there is a graphic object on the system clipboard, for example a frame capture, you can paste the graphic 
using the Edit menu at the top of this dialog. 
 

Text Properties: The controls are used to set how text is displayed. If a text box is selected changes to 
the settings will affect the selected text box. If no text box is selected then changes to the Text properties 
become the style when adding new text box. The text property box is divided into three sub-frames: Font, 
Outline and Shadow. The following graphic shows examples of different text effects. Outlining and shadowing 
can be very effective for making text visible against a graphical background.

File menu: In addition to saving and storing title pages, with Load Template and Save Template, the 
Save as Default Template saves the current title as a template for all new titles. This includes, 
background, text boxes and the text box style.

More about editing text boxes: 

To edit the contents of a text box:  
Select the text box by click on it once, or use the tab key to cycle through the text boxes. Then using the 
mouse, double click again on the text box to select its text. You can then replace the text or use the 
arrows, backspace and delete key to modify its contents.

To move a text box: 
With the mouse: Click anywhere inside the box, and while holding down the left mouse button drag the text 
box around the screen. 
 
With the keyboard: Select a text box with the mouse, or use the Tab key to cycle through all the text boxes one at 
a time. Then, use the four arrow keys (left, right, up, and down) to move the text box one pixel at a time. If you 
hold down the ctrl key at the same time, movement will be in 5 pixel increments.

To resize a text box: 
With the mouse: Select a text box so that it draws it outline with the 8 resizing handles. Press and click on one 
of the resizing handles. Then while still holding down the left mouse button, drag the handle to expand or 
contract the text box. 
 
With the keyboard: Select a text box with the mouse, or use the Tab key to cycle through all the text boxes one at 
a time. While holding down the shift key, use the four arrow keys to expand or contract the size of the text box 
one pixel at a time. If you hold down the ctrl key at the same time, movement will be in 5 pixel increments.

To create multiple text boxes of the same size and text style: 
1) Select a text box. 
2) Click on Edit > Copy. 
3) Click on Edit > Paste, repeat.

Aligning text boxes: This is generally best done with the keyboard. When a text box is selected, its 
location and dimensions are displayed just underneath the template sample. You can then use they board 



sizing commands to match vertical and horizontal positions and sizes. 

Copying text styles between text boxes: Text styles can be easily copied from one text box to another. 
1) Select a text box. 
2) Click on Edit > Copy 
3) To copy the text style to all text boxes, click on Edit > Paste Style All. 
4) To copy to another text box, select the destination text box and click on Edit > Paste Style.

To auto fit text to an existing text box:  
1) Select a text box. 
2) Click on Edit > Auto fit text. The title editor will enlarge or reduce the text size to fit the current dimensions of 
the selected text box. To preserve readability of the title, the smallest font size used for auto fit is 14 points. 
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Create DVD project

 

DVD Folder and Burn Options: The parameters in this frame control the names and locations of 
the DVD output process.

VIDEO_TS location: All DVD contain a folder called VIDEO_TS which contains the program material (.
VOB files) and control files (.IFO and .BUP) . During the authoring process VideoReDo builds a copy of 
the VIDEO_TS file on your hard drive which will be eventually burned to the DVD. The default location value 
is based upon where you last authored a DVD as well as the filename being authored. For example if you 
last authored to c:\temp\MyFiles.DVD, future VIDEO_TS folders will be stored under the c:\temp folder. Use 
the button on the right to select or create a new folder.

Author to VIDEO_TS: Select this option to simply author to a VIDEO_TS folder on the hard drive. No 
burning will be done at this time.

Author to VIDEO_TS and burn DVD: This option creates the VIDEO_TS folder on your hard drive and 
then automatically burns a DVD.

Create ISO file: An ISO is single file which is an image of a burned DVD. Many burning applications, 
including VideoReDo can burn a DVD from an existing ISO file.

Burning options: If you are burning or creating an ISO file, the following options can be set:

Verify disc after burning: After the initial burn is complete, VIdeoReDo will re-read the burned DVD 
and compare each file on the DVD with its corresponding file in the VIDEO_TS folder on the hard disc. Because 
of tight tolerances of writable DVDs it is not unusual to find that the burning process. While checking this option 
can double the amount of time it takes to burn the DVD it insures that the DVD contains a complete and 
accurate copy of the files on the hard drive. 

Delete VIDEO_TS after burning: After burning is complete the VIDEO_TS folder on the hard drive will 
be deleted. Enabling this option also enables the verify option.

Erase RW disc automatically: If you are using a read-write DVD disc, checking this option will 
automatically erase the contents before burning. If you don't check this option and your RW drive isn't blank, 
the DVD burning application will warn you that the contents of the disc isn't empty and ask you to either erase it 
or use a different disc. 

Volume name: Each DVD has a volume name of up to 31 letters and numbers. The volume name is 
for informational purposes only and isn't displayed during playback.

Estimated DVD Size: This graphic shows the estimated output size of the DVD. The output size is based 
upon an estimate of the sizes of the source titles and your edits to those titles. If your source files, such as 
some transport stream files, contain multiple simultaneous programs the estimated size can be way off. In 
those cases you might want to save your edits first to a separate file and then reload the edited file for 
authoring. The look of this graphic will change when you alter the DVD output size option as described below.



Menu Options: The settings in this box determine if your DVD will have a menu and how it will 
look. VideoReDo can create a single paged, top-level menu. 

Create DVD menu: 
No menu: Select one of these two options. If "No menu" is selected the first title on the disc will 
be automatically started with the DVD is inserted into your player. If Loop titles is checked then the 
title will be automatically repeated over and over. The other options in this box are only enabled if 
you create a DVD menu.

When DVD starts: This option controls the behavior of the menu when a disc is first inserted into your player. 
If "Display menu screen" is selected the menu screen will be initially displayed and the user will need to select 
and click on one of the titles to being play. When "Auto play video" is selected, the first title on the disc will 
begin play.

When title ends: This setting determine what happens after each title completes play. "Play next title" will 
have the DVD player start to play the next title. After the last title the menu is displayed. "Return to menu" will 
have the player return to the menu after each title completes.

Template: You can select which template to base your menu on. VideoReDo comes with default menus for up 
to 4, 6 and 12 title DVD in both 16x9 and 4x3 aspect ratios. When you create your own custom templates they 
will appear in this list as well.

Edit Template: Click on this button to edit the existing template or to create a new template using the 
template editor.

Change text: Use this button to quickly change the text on this title menu using the customize dialog.

Output options list: The list items identifies the status of the critical parameters in determining how the 
audio and video will be encoded and placed onto the DVD. To the left of each item is a status symbol: 

 A green check mark indicates that no recoding is required. 
 

A yellow circle indicates minor recoding. Minor recoding is usually very quick with the only exception being 
that program with very long GOPs can take additional time to recode the longer GOPs to DVD compliant 
GOP lengths. Audio recoding or aspect ratio changes take place extremely quickly. 
 

The yellow triangle is used to show that a major recoding is taking place. Usually its related to some aspect 
of the video such as converting HD video to SD video required by DVDs. Cropping and resizing or changing 
the overall bit rate also require major recoding. These options are set by clicking on the "Change output 
options" button.

Accept non-compliant DVD settings: The DVD specification is limited to MPEG2 video of 
specific dimensions. For NTSC it is usually 720x480, 704x480, 320 x 480, or 320x240. For PAL it is 
720x576, 704x576, 352x576, or 352x288. However most modern DVD players can accept and play DVDs with 
non-standard dimension such as Tivo created 480x480 video or a variety of dimensions broadcast via satellite 



and DVB. If this option is checked the VideoReDo authoring engine will use your source video directly 
without recoding. This will significantly speed up the authoring process.  
 
Non-compliant videos are still limited to SD material so if your source material is hi-definition it will be grayed out. 

Change output options: While VideoReDo attempts to automatically determine an optimal set of 
output settings, you can change these settings by clicking here. There are three output option topics:

●     Video settings
●     Picture cropping and resizing
●     Audio settings 

DVD output size: The DVD output size field can be critical in determining whether or not recoding will 
take place. DVD are limited to 4.7 GB for single layer discs and 8.5 GB for dual layer. A third option 
"unlimited folder only" will permit VIDEO_TS folders of any size to be created up to a maximum size of about 10GB.  
 
When you select "Create DVD", VIdeoReDo adds up the estimated output size of each file to estimate how 
many bytes will be in the VIDEO_TS folder. It also adds about 225 MB as a fudge factor for DVD disc and 
menu overhead. If the size is less than the DVD output size then the files are marked as "no recoding 
required". However if the combined total of the files won't fit, then VideoReDo will automatically attempt to lower 
the output quality by reducing the bit rate of the files so that the files will into the specified size. All the titles on 
the disc are equally affected.
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Reference 

 
Please click on the topic below for additional information:  

●     Context and Edit Menu Options available from the edit and context menu.

●     Joiner Editing How to add, remove or change the sequence of joined program material.

●     Keyboard Shortcuts Complete list of keyboard shortcuts for VideoReDo

●     MPEG Program Information Dialog box which displays the internal formats of the MPEG2 Program headers

●     Create Trimmed File Copy How to copy a portion of your raw input file. Primarily used for support purposes.

●     Output Processing 
Complete 

Description of the fields displayed after your edits have been saved.

●     Overlapping Selections Description of your options when a new selection intersects with an existing selection.

●     QuickStream Fix Facility to quickly fix all the timing codes in an MPEG file.  It will also re-synchronize out of order audio and video.

●     Video Frame Capture Captures the currently displayed video frame to the Windows Clipboard or a BMP file.

●     Stream Selection Dialog to choose which set of audio and video streams in your file to edit.

●     Change Display Properties This dialog will let you adjust the brightness and contrast of your display.

●     Set Thumbnail Parameters This dialog is used to configure the thumbnail and audio graph window.

●     Set Ad-Detective 
Parameters 

Dialogs to tune the sensitivity and behavior of the Ad-Detective scans.

●     Batch Builder Use to process multiple files at one time 

●     Thumbnail Options  Set thumbnails view parameters 

●     Output File Options Set output file parameters such as aspect ratio, bitrate, GOP length, audio, and insert empty NAV packets 
for dvdauthor (formerly .VOB output.) 

●     Title Editor Dialog to create title for video from the main menu an Joiner dialog.  

●     Open DVD Title Folder Dialog to select and open titles from a DVD or hard drive folder . 

●     CRID Files Dialog for opening and managing CRID files. 

●     Create DVD Project Dialogs for authoring and burning DVDs. 

●     COM Interface Reference list and examples for VideoReDo's COM interface 

 
Program Options

 



●     General Parameters Description of parameters which affect the behavior of VideoReDo.

●     Navigation How to change the behavior of the navigation buttons, sliders, and keyboard commands.

●     Stream Parameters Options to change the format of the output video stream.

●     File Types How to make VideoReDo the default program for opening MPEG files.

●     Playback Devices How to tailor VideoReDo to make optimal use of your sound card and video adapter.

●     Start Up Control the behavior of VideoReDo when the program begins.

●     Chapter Marks Change the behavior and format of VideoReDo's chapter marking capabilities. 

●     Audio Alerts Enable audio alerts and sound selection.

●     Enhanced PlusFeatures Control some of the enhanced features of VideoReDo. 

●     Transport Stream Output Tailor the way transport streams are written. 

●     Topfield .REC Output Customize the metadata options when outputting a Topfield .REC formatted file. 

●     MCE (DVRMS) Output Customize the metadata options when outputting a DVRMS formatted file. 

●     Titling Customize the Title durations. 

●     DVD Settings Specify folder locations, encoding and DVD burning parameters 
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Keyboard Shortcuts 

 
Relative movement keys: These keys move the program forward or backward by the specified interval. 
When held down, as opposed to being immediately released, these keys will automatically repeat allowing you 
to quickly zoom through sections of the video program. The repeat rate may be set using the keyboard option in 
the Windows Control Panel.

Simulates pressing the back , or forward  120 second buttons. The exact number of seconds may 
be modified with the Navigation options dialog.

Backward or forward one frame. Behavior may also be altered by simultaneously pressing the shift and 
control keys.  Please see the Navigation options dialog to see all the movement options.

Simulates pressing the back , or forward  buttons. The exact number of second may be modified 
with the Navigation options dialog.

Jump keys: These keys move the program to a specific location in the file:

 

Jump to the beginning (home key) or the end of the program. In zoom mode, jumpto the beginning or end of 
the zoomed segment of the timeline.

In zoom mode, jump to the beginning or the end of the program. 

B sets the bookmark to the current cursor position the navigation bar. The bookmark is display as a (triangle). 

J jumps to the current bookmark. 

These actions may also be selected from the context popup menu by pressing the right mouse button.

Jumps to the start (S Key) or end (E Key) selection marker. These actions are also available from the 
context popup menu.

 

Tab jumps to the next selection marker in the cut or scene list. Shift+Tab jumps to the previous selection 
marker in the cut or scene list. Identical to pressing the left or right arrow on the preview buttons: 

Jump to a specific time code. 

Action keys: These keys affect the actions and/or operation of the program.

Toggles Pause / Play. You can also left-click the mouse anywhere in the video to toggle between pause and play.

Marks the beginning (F3) or end (F4) of a selection. Same as pressing the  and   
buttons. When One-Click Selection is enabled, the Sel. Start / Sel. End button labels are changed to Mark In / Mark 
Out indicating that One-Click Selection is active. These actions are also available from the context popup menu. 

In Cut mode, this key will add the selected material to the cut list. Same as pressing:  

In Scene mode, this key will delete the un-selected material from the output file, same as pressing:

Deletes the current frame and advances to the next frame.Pressing this key multiple times, or holding it down until 
it repeats, is useful for deleting a few successive frame.



In Cut mode, this key will include the unselected material from output file, causing the selected material to 
be deleted. Same as pressing:  

In Scene mode, this key will add the selected material to the scene list. Same as pressing:

Toggles between edit and preview mode. Same as pressing: 

 

 
M, by itsself, toggles the audio mute. Same as pressing the speaker icon:  

Shift+M and Ctrl+M raise or lower the volume.

Closes the current file.

Saves the current edits to a unique project filename and queues this project for batch processing.

Captures the currently displayed video frame to either the Windows Clipboard or a BMP file.

Toggle the information window display between program times and program sizes (MBytes). 

Inverts all the cuts. Same as pressing: 

Opens a video file.

Saves the edits to the project file.

Opens the stream selection dialog. If your file contains multiple streams, this dialog can be used to select 
which stream to edit.

Removes the current selected cuts. Same as pressing: 

Write the edited video back to disk.

Author and optionally a DVD from the currently opened file. Same as the File>Save to DVD option. If you 
have mutliple titles on the DVD title list, this option will ignore the list and only author from the single opened file. 
To author multiple titles, use the Create DVD button from the main screen or Create option from the DVD menu.

Redo the previous "undo". If you remove an edit using "Undo last edit", this key and the matching option on the 
edit menu will restore the last edit. You can click on this multiple time to restore a series of undone edits.

Undo last edit. Each time you change the cut list, VideoReDo keeps a backup copy incase you change your 
mind. You can select Undo multiple times to remove multiple edits. Once an edit has been Undone, there is no 
re-do key to restore it.

Thumbnails keys : These keys control the thumbnail behavior.

 Jump to the frame displayed by a particular thumbnail. 5 jumps to the center thumbnail. 4 to the one just to its 
left, 6 one to its right. 3 two to the left, 7 two to the right, etc. 

  Change the thumbnail display interval. Ctrl+0 jumps to the smallest interval (highest resolution), while Ctrl+9 
to the lowest resolution. 



Toggle the display of the thumbnail window. 

Display the thumbnail options dialog. 

   Increase (+) or decrease (-) the thumbnail interval. 

Ad-Detective keys : These keys control the behavior of Ad-Detective and Scene markers. 

Set or Remove a Scene marker.

Start Ad-Detective Scan 

Remove all scene markers. 

   Go to previous or next scene marker. Same as the red arrow: 

Appearance keys: These keys affect appearance of VideoReDo

Toggles the display between standard size and maximized (full screen).

Displays help appropriate for the current window or dialog.

Zoom keys 

Toggles the timeline between standard and zoom mode.

Zoom magnification is adjusted in and out.

Shifts the zoom area left or right. 

Miscellaneous keys 

Display the Tools>Show Program Information dialog. 

Reloads the current video file. VideoReDo TVSuite can edit program and/or transport stream files while they are 
still being recorded. However, the program length for the file is not updated dynamically as this would cause 
the navigation bar to constantly shift. Pressing F12 will reload the video file while retaining your present set of edits.
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Purchase and Registration 

 

You can use this dialog to purchase a perpetual license to use VideoReDo. When you purchase such a license, 
you will be asked to supply a user name. Upon validation of your payment you will receive, generally via email, 
a registration key which will remove the expiration and other trial copy limitations of the program.

To upgrade VideoReDo: Select the update radio button and upgrade using the wizard either automatically 
or manually (if your computer is not connected to the Internet.). 

To purchase VideoReDo: Select the purchase radio button and click "Register Now". Your browser will 
launch and take you to the registration screen.

To enter or change your software key:  Select the "Update my software key" radio button. The name 
and key edit controls will be enabled allowing you to enter the registration data.  For protection purposes, 
the registration key can be up to 60 characters so we suggest you copy it to the windows system clipboard 
using the select and copy functions of your email program. You can simply click on the "Paste key from 
Clipboard" button to paste it directly into the key field.

Note; When entering your key, make sure you also enter the name, as supplied with your key, into the Name: field. 

Special Note: Each license key provided for use with VideoReDo is intended for a specific user. We ask 
that you not share it with others as unauthorized usage may result in the license key being marked 
as invalid. Please review the license agreement in this help file for additional details.
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Technical Support 

 
Technical support for VideoReDo is provided, without charge, through the links at our website.  Here you will 
find multiple resources to assist you in solving problems with VideoReDo and to take maximum advantage of 
the program's features.

Support Forum: 
http://forums.VideoReDo.com  This community of VideoReDo developers and users is the primary place 
to get your questions answered quickly and learn more about the product. 

  
Email: 

support@VideoReDo.com You may email our support group directly with your questions and 
product comments. 

  
Webform: 

http://www.VideoReDo.com/Contact.htm This page provides a web-based contact form which can be 
used instead of email. 

How To Guides : 
http://www.videoredo.com/HowTos/HowToContents.htm This page contains a series of step-by -
step instructions for accomplishing some of the frequently used or sophisticated tasks with VideoReDo. 
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Adjust Audio Levels 

 
You can adjust the playback volume using the slider in the lower left of the screen. 

You can also mute audio by clicking on the speaker symbol (or pressing the "M" key).

The volume can be raised or lowered by pressing the Shft+M to raise the volume and Ctrl+M to lower it.
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Managing Selections 

 
Selections are the fundamental building blocks of the VideoReDo editing process. With selections, you 
indicate which portions of the source video program you wish to include or exclude from the edited output. There 
is no limit to the number of selections you can create during the editing process. You can also save your 
selections to a project file so that they may be retrieved for additional editing in the future.

Creating selections: Creating selections is a three step process:

1.  Navigate the video to the desired start of the selection, and press the  button. The start 

selection marker,  will appear at the current cursor position. If the new selection is to the right of end 
selection marker, the end selection marker will be moved to the end of the file. 
 

2.  Navigate the video to the desired end of selection, and press the  button. The end selection 

marker,  will appear at the current cursor position. If the new selection end is to the left of the current 
start selection marker, the start selection marker will be moved to the start of the file.   
 

3.  If you are operating in Cut Mode, you create the cut selections by pressing the  or 

 buttons. The Cut Selection button will mark the area between the selection markers as 
the selection and add that selection to the list of cuts on the right of the screen. Trim Unselect will add the 
areas outside the selection markers to the cut list creating two new selections.  A portion of the background 
on the navigator bar will be red to signify the sections of the video program that will be cut. 
 

Before Cut: 

Cut Selection: 

Trim Unselected: 
 

If you are operating in Scene Mode, scene selections are added using the  and 

 buttons. Add Selection will add the area between the selection markers, while Add 
Unselect will add the areas outside the selection markers. A portion of the navigator bar background will be 
green to signify the sections of the video program that will be included in the output program. 
 

Before Adding : 

Add Selection : 

Add Unselected : 
 
 

4.  If you have the optional Enable One-Click Selection checked on the General Parameters options page, 

the Sel. Start and Sel. End buttons will be labeled,  and .  They function the same 
as described above except that when you press Mark Out the selection is automatically Cut or Added.  This 
will save you time by not having to press the Cut Selection or Add Selection buttons.

Overlapping selections: If you attempt to create a cut or scene that overlaps a previous selected cut or 
scene, the following dialog box will appear.  



Press Combine to combine the two overlapping selections into one. 

Press Replace to delete the old selection and replace it with the new one.

or, Press Cancel to simply abort this operation.

Note: If you have the Auto Replace Overlapping Cuts selected on the General Parameters options page, the 
new cut or scene will automatically replace the previous overlapped one.

Deleting selections: 

You can delete existing selections by highlighting one or more entries in the list box and 
pressing . Simply click on an entry to turn the highlight on or off.  You can also highlight 
a selection by moving the navigation cursor into an existing selection. As the navigation cursor crosses into 
a selected area, the selection in the cut/scene list is highlighted. 

To select multiple selections: Hold the Shift key down to select a range of entries, or hold the Ctrl key down 
to select individual entries (as shown in the example to the left).

Pressing  will reverse all the entries in the list box. That is, areas that were 
previously selected to be cut will now be included, and those that were selected to be included will now be cut.

 

Modifying selections:

There are times when you might want to modify the range of a selection, perhaps to add a little more to 
the beginning, or take some off the end. Follow these simple steps:

1.  Double-click on the selection you wish to modify either by double-clicking on the entry in the cut/scene list or 
the selection itself on the navigation bar. This will cause the selection markers on the navigator bar to be 
re-positioned to bracket this selection.  
 

2.  To modify the start of the selection, simply use your mouse and/or keyboard navigation options to move 

the program to the desired start and then press, .You can always jump back to the current start of 
the selection by pressing the S key. 
 
To modify the end of the selection, press the E key (or use the context menu) to jump to the end of the section. 

Use the mouse or keyboard to navigate to the new desired end and then press, . 
 

3.  Depending upon the mode you are in, click on the  or  button. Since you 
are overlapping a previous selection, the overlapping selections dialog will appear.  Select Replace, and 
the modification is complete.
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Navigating The Video Program 

 
VideoReDo offers many ways of navigating through the video program. 

Navigating with the mouse:

All of the VideoReDo navigation functions can be completed using the mouse. Click on any of the controls in 
the picture below to view its function.

Program cursor: The program cursor  is the primary navigation tool for moving quickly through 
large sections of the program. Simply place the mouse cursor anywhere on the navigation bar and click the 
left mouse button. The cursor and video will jump to the desired location. While still holding down the mouse 
button, drag the slider to the left or right to zip through the video. Navigating using the program cursor 
will always position the video to the nearest I-Frame. For finer movements, you will need to use the other 
navigation controls. 

When the video is playing, the program cursor will automatically advance with the program time. As the 
cursor passes over a selected area, the selection is highlighted in the Cut List box. 

Note: Double clicking on the program cursor, while it is in within a selected area,  will move the start and 
end markers to surround the selection. 

Fine tuning slider: Use the fine tuning slider to move the video forward or backward in smaller 
increments. Click and drag the slider to the right to advance the program, to the left to move it backwards. 
By default, the slider will move the program up to 120 seconds in either direction. You can change this value on 
the Navigation options page. 

You can temporarily make the fine tuning slider less sensitive (i.e. more accurate) by holding down the 
control and or shift buttons while moving the slider. The control and shift buttons will reduce the range of the 
slider in proportion to their value.  For example, if the shift multiplier on the Navigation options page is 2 and 
the slider range is ±120 seconds, then holding down the shift button will reduce the range to ± 60 seconds.

Note: Dragging the fine tuning slider with the right mouse button will give you very fine control by limiting the 
range of movement to +/- one second. 

Forward and Backward Movement Buttons: The three forward and backward movement buttons will 
move the program ahead or backward by single frames, 30, and 120 seconds respectively. You can hold down 
the shift and/or control keys to increase the amount of movement. Once again, you can set the time increments 
for these controls from the Navigation options page. There are also keyboard substitutes for these controls.

Pause / Play button: Press this button to toggle between pausing and playing.  When the button background 
is yellow, the program is paused, when green the program is playing.  You can also toggle between pause and 
play by clicking  the left mouse button anywhere on the video picture itself, or simply press the space bar.

Cursor clock: The cursor clock, in the center of the screen, indicates the position of the program cursor in 
hours, minutes, seconds and frame count. This is a display-only control. The two other clocks, without 
backgrounds just below the navigation bar, display the current position of the start- and end-selection 
markers. Double-clicking on the cursor clock will let you position by entering a time code.

Navigation Bar: The navigation bar is a display-only control depicting a graphical view of your selections. 
Where the background is green, program material will be transferred to the output file, where red, it won't. 
When you open a video file in Cut mode, the background of the navigation bar will be entirely green 
indicating that the entire program will be written unless you make selection cuts. Likewise, when you open a 
video file in Scene mode, the background of navigation bar will be red indicating that nothing will be output 
until you identify selections to include.

Note: When you switch into Preview Mode, the navigation bar turns purple to indicate you are no longer in 
an editing mode. 



Bookmark: The location of the bookmark is highlighted by the triangle symbol: . To set the bookmark, 
press the "B" key or right-click to display the context-menu. You can jump to the bookmark by pressing the "J" 
key or from an option on the edit- or context-menus.

The current position of the start and end selection markers,  and  are also shown. Please see 
Managing Selections for additional information on setting the selection markers.

Navigating with the keyboard:

Many users prefer to navigate using the keyboard instead of the mouse. One benefit of navigating with 
the keyboard is that when a key is held down it automatically repeats.  This can make scanning the 
program, forward or backward, at high speed a painless process. Please see the section on keyboard 
substitutes for more detail.

Timeline Zoom:

Zoom mode is used to magnify a section of the navigation bar to better see cut points and scene markers. Its 
useful when editing long programs where the markers may be too close together to be distinguished from 
one another. 

The "Z" key will toggle zoom on and off. You can also press the "F7" and "F8" keys to decrease or increase 
the level of magnification. These same options are available on the View menu as well. 

Standard view: 

Zoomed view: Note that the navigation bar only shows the zoomed or magnified area. The lower slider has 
been replaced with the a graphic highlighting the zoomed area within the entire timeline. 

Changing the zoomed area: 

You can increase or decrease the zoomed area by positioning the mouse on the edges of the zoom window 
( see #1 below ) and dragging them to the left or right. If you prefer, pressing the "F7" or "F8" keys to decrease 
or increase the zoom window size.

To move the zoom window, click inside the zoom area in zoom bar (see #2 below). The cursor will change to 
the image of a hand and you can then drag the zoom window to the desired position. You can also pressing 
the comma or period keys to move the zoom area left or right, respectively.

s
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Quick Start 

 
This page will lead you through the most basic steps of opening, editing and saving your video program files.

Setting the program mode:

Before you start editing your video program, you need to decide whether VideoReDo should be run in Cut 
Mode or Scene Mode. The  mode is selected via a selection box on the General Parameters option dialog. 

In Cut Mode the scenes you select will be removed or cut from the output video. For example, lets say you have 
a video of a television program from which you want to remove the commercials. Using Cut Mode you 
can highlight the start and end of each commercial segment and remove them from the output file. When 
you initially open a program in Cut Mode, the navigation bar will show with a green background. The green 
area in the navigation bar indicates those portions of the video that will be saved when you save your video. As 
you "cut" or remove sections of your program, parts of the navigation bar will turn from green to red 
indicating where the cuts have been made and that those cuts will not be saved. 

In Scene Mode, only the specific scenes or segments from the program that you select will be written to 
the output file. Scene mode is often used when it is easier to identify the scenes you want to keep, such as 
when piecing together a video collection. 

When a program is opened in Scene Mode, the navigator bar's background starts out red, indicating that 
no scenes have been selected for output. Each time you select a specific scene to output, a section of the bar 
will turn green indicating that it will be included in the output file.

The program mode option may be changed at any time, but will only take effect when a new video program 
is opened.

Opening a video program file:

VideoReDo can edit MPEG1 program streams and MPEG2 program streams, transport streams as well as 
VOB streams from a DVD. There are four different ways to open a file:

1.  Selecting Open Video from the File menu (shortcut key Ctrl+O). Select an existing MPEG file from the file 
selection dialog.  You will note that there is an additional combo box at the bottom of the file selection dialog 
which keeps a list of recently used file folders. 
 

2.  Drag a file from the Windows File Explorer into the VideoReDo window. If VideoReDo is not yet opened, you 
can also drag a file from the Windows Explorer onto the desktop icon.  
 

3.  If VideoReDo is configured as the default application for your MPEG files, you can automatically start 
VideoReDo and open a file by double clicking on it from the Windows Explorer. You can enable this feature 
from the File Associations option dialog.  
 

4.  Selecting one of the most recently opened files listed at the bottom of the File menu. 

Navigating and selecting video segments:

The editing process consists of selecting video segments for inclusion (scene mode) or exclusion (cut mode). 

●     To select a segment you start by moving the current video position to the beginning of the desired segment 

and pressing .  
 

●     To mark the end of the segment, move the current video position to the end of the segment and press, 

. When you press either of these buttons, a segment indicator will appear on the navigation bar.  
 

●     Once a segment has been marked, you can elect to include it in the output video  by pressing, 

 (scene mode) or exclude it by pressing, . Pressing either of these buttons will 
add the selection to the selection list box on the right. 



There are many ways to navigate around your programs and we suggest you read the navigation page 
for additional details.  However, the simplest way to move through your program is to drag the upper slider close 
to the desired point.  Then use the lower slider to fine tune the selection point. 

Saving the edited program:

You can save the edited program by selecting "Save Video As..." from the file menu or pressing the 

 button. 
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Joining Programs 

 
Joining is used to concatenate multiple video files into a single file. MPEG program stream files are structured 
with a number of internal time stamps. The VideoReDo joiner realigns these time stamps as it puts your selection 
of files together into one file. 

The joiner is used by adding project or MPEG files to the joiner list. To add a project, open an MPEG file or 
an existing VideoReDo project. Create your cut or scene list as you normally would, but instead of saving the 
edits, add the open project to the joiner list by clicking on Joiner>Add Current Project To Joiner List. 
You can also add multiple multiple MPEG files or saved projects to the joiner list in one step using the Window 
drag and drop feature. 

Joiner Restrictions: There are a few restrictions on nature of the files that can be joined. You will be warned 
if you attempt to join files that don't meet these criteria.

1.  Files must be of the same type. You can only join MPEG-2 files with other MPEG-2 files and MPEG-1 files 
with other MPEG-1 files. 

2.  Audio sample rates must be identical. You cannot join files that have different audio characteristics. The audio 
bit rates may be different between files. 

3.  Video picture size must be the same. MPEG files can be encoded with a variety of picture sizes (i.e. 
720x480, 480x480, 640x480, ... ). The joiner will insure that only files of the same size can be joined. The video 
bit rates may be different between files. 

The Joiner List: The Joiner list is the collection of video program files along with their edit selections. Entries 
are added to the joiner list by selecting Add Current Project To Joiner List from the joiner menu.  When 
you select this command, the current edit project will be added to the joiner list. If, for example, you have 
previously selected two scenes to cut from the program, the project being added will have the cut scenes omitted. 

If you have checked  the "Prompt For Joiner Descriptions" option in the General Parameters dialog, a prompt 
will appear asking you to enter a short description to describe this segment. You may find these descriptions 
useful when editing the joiner list. The descriptions are for informational purposes only and do not affect the 
output in any way.

Edit Joiner List: This command display the Joiner Edit dialog. From this dialog you can remove or change 
the order of segments in the joiner project.

Create Video From Joiner List...:   Select this option to create a new video program file from the 
segments listed in the joiner project. 

Using the joiner to improve audio synchronization: Whenever possible, VideoReDo attempts to 
correct audio and video synchronization problems it detects in the source program. However, some 
synchronization issues can only be corrected using our manual synchronization adjustment. When a project 
is added to the joiner list, the project's current audio/video synchronization offset is remembered by the joiner. 
By default the synchronization offset is 0 meaning that the audio and video synchronization of the source file will 
be used as is. However, if you change the audio synchronization this change will persist through the 
joiner processing for that specific project. One use for this feature is to correct a video program that 
gets progressively more and more out of sync from beginning to end.

Adding multiple files to joiner in one step: You can add multiple MPEG files or VideoReDo projects 
into the joiner by dragging multiple files from the windows file explorer into the VideoReDo main window. Start 
by opening both VideoReDo and a copy of the Windows File Explorer. In the Windows Explorer select 
multiple filenames using a combination of the shift and control key. Then in one step, drag all the selected files 
into the VideoReDo window. You will be presented with the option to Combine or Join files. Select Join. The 
files will be sorted by name and added to the joiner list. 
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Getting Help 

 

VideoReDo offers many options for getting help. You can invoke help at any time by pressing the F1 key 
or selecting the "Contents" option from the help menu. When a dialog box is displayed and you press F1, the help 
system will automatically jump to the help text appropriate for that dialog. 

If you need support, please email our support staff at: support@VideReDo.com or visit our forum at http://
forums.videoredo.com. 

We also have a series of How-To guides explaining many of the basic features of VideoReDo to get you started.

http://www.videoredo.com/HowTos/HowToContents.htm
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General Parameters 

 
  

Play Video When Opened: Check this option to automatically start playing the video when you open an MPEG file. 

Preferred audio: If a video file contains multiple audio streams of different codecs, this parameter is used 
to determine which stream will be defaulted to. If 'Auto' is selected, the first audio stream found is used and 
also results in the fastest file open. Selecting one of the other options may result in scanning a number 
of megabytes into the file to determine if the preferred audio type is present. You can set how far to scan on 
the Tools>Options>Stream page. If the preferred audio encoding isn't found, VideoReDo will chose the first 
one found.

Editing accuracy: By default, VideoReDo is enabled for frame accurate editing. This means the cut points you specify will 
be accurate to within a single frame. VideoReDo will decode and re-code the frames around the cut points to insure that 
only your desired frames are included in the output file. When set to "GOP Accurate" the cut points are rounded to the next 
I-Frame or start of GOP (Group of Pictures). There are typically 15 frames in a GOP since that is the DVD standard, 
although the MPEG2 permits a GOP to have an arbitrary number of frames in it. With 15 frames in a GOP, GOP accurate 
edit points are accurate to approximately 1/2 second.

Editing mode: VideoReDo can operate in two different modes, cut mode and scene mode. In Cut mode, you indicate 
sections of the video program that will be removed by the editor. All "un-cut" sections will be included in the output file. 
In Scene mode you indicate sections ( scenes ) of the video that will be included by VideoReDo in the output file. Please 
see Getting Started for a more through discussion of editing modes. 

Default Project Folder: Changes the preferred default save location of project (VPrj) files as oppposed to video files. 
Options include source video folder, destination video folder, or the last saved project location.

Auto recovery interval: VideoReDo will maintain a backup of the current state of your editing project on disk incase 
your system or VideoReDo itself crashes. When you start VideoReDo it will scan for the auto recovery file, and if found 
ask you if you want to restore. This parameter determines how frequently VideoReDo will write to the auto recovery file. 
The auto recovery file is also written when you perform a file save or a Joiner create. It is deleted when you exit VideoReDo.

Default file save format: Chose the default output format you wish to save to. This value can be overridden using the 
"File Type" option on the File > Save dialog. Options are:

●     Program Stream (MPG) - A standard MPEG1 or MPEG2 program stream. 
●     Elementary Stream (MPV) - A demultiplexed version of the output program. Separate audio and video files will be written.
●     DVD folder (DVD) -Saving to a DVD folder will prompt for DVD project parameters and create a VIDEO_TS folder.
●     Transport Stream (ts) - Industry compliant Transport Streams.
●     DVR-MS (dvr-ms) - Microsoft Media Center files. Also known as MCE files.
●     Topfield REC (rec) - Topfield REC format. A transport stream file with a Topfield header
●     Tivo (tivo)- MPEG program stream formatted with a Tivo metadata header. If the source file is not a Tivo file, the output 

file will be formatted as an industry standard program stream. 

Queue to batch format : Chose the output format that projects queued to the batch processor will be saved as. The choices 
are same as those used by the Default File Save Format. 



Save on close options: This option affects what happens when you open a new video program or try to exit the program 
and have unsaved edits. The unsaved edit status is cleared when you save your video or perform a project save. Please 
choose from one of the following three options:

�❍     Warn if unsaved edits - If you have not saved your latest edits as either a project or new video program you will be asked 
to confirm your action. 

�❍     Autosave project -  This option will automatically save your edits as a project file. The filename will be the program 
filename, a version number and the .Vprj file type.  For example, if you are editing a program "Show.mpg" the auto 
save project filename might be, Show_001.Vprj. Note: Although project files do not consume a lot of disk space, you might 
find them cluttering up your directories if you do a lot of editing.  

�❍     No warning - This selection will let you open a new file or exit the program without a warning message. Any unsaved 
edits will be lost. 

Enable One-Click selection: One-Click selection can speed up your editing process by saving you additional mouse 
clicks.  When enabled, the Sel. Start / Sel. End button labels are changed to Mark In / Mark Out indicating that One-
Click Selection is active. When One-Click is active you can press Mark Out to automatically set the selection marker 
and perform the Cut Selection or Add Selection action.  For One-Click to work, the cursor must be to the right of the Mark 
In marker.

Auto Replace overlapping cuts: Enable this option to avoid having to respond to the Overlapping Selection dialog.  
The Overlapping Selection dialog is normally displayed if a new selection would overlap a previous one. When this option 
is selected the new selection will automatically replace the previous overlapped cut.

Queue to batch clears cut list: When checked, the cut list is automatically cleared after the current project is queued to 
the batch processor.  This option is ideal when creating multiple extractions from a single program.  Set VideoReDo to 
scene mode, select the first scene, and queue to batch.  Then, select the next scene and queue to batch, etc.   

Store .BPrj file with source video: When checked, files are stored in the same folder as the source video. This option is 
useful when not deleting project files in batch manager to provide the opportunity to easily locate and edit the file in the 
future.    

Prompt for joiner descriptions: You can check this option to be prompted for a description whenever a project is added to 
the joiner list. These descriptions will help you identify joiner segments later on.

Tooltip delay: This combo box lets you specify how quickly tool tips are displayed for the various controls on the page. 

Preview Lead-in (secs): This value is used with the preview feature. When its non-zero, jumping to the next cut using 

the Tab / Shift+Tab key or the  buttons will cause VideoReDo to position before the cut and start 
automatically playing. Its a simple way of quickly previewing your cuts. The value in this field specifies how many 
seconds before the cut the preview will start. 

Clear Recent Files / Folders: Click this button to clear the most recent file list from the file menu and the 
most recent folders drop down box in the file open dialog.
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Thumbnail Options 

 

Thumbnails are an optional feature of VideoReDo. If enabled from the View menu (or F11 key) they will appear 
just below the video display. This dialog page is used to configure operations and look of the thumbnail display:

Thumbnail Interval Seconds: The ten edit boxes in this section specify the number of seconds between 
each thumbnail image. For single frame intervals, use '0'. Decimal values are allowed, for example using 
0.50 seconds to display thumbnails at 1/2 second intervals. To display a different thumbnail interval use one of 
the following: the ctrl+<number> key, the "+" or "-" key, or right click on the thumbnail window and choose 
an interval from the displayed context menu.

Background Color: This option sets the background color of the thumbnail window. There are two colors, 
one for when VideoReDo is in edit mode and another for when Preview mode is active. Click on either button 
to change the color.

Thumbnail Size: Choose from one of three different thumbnail sizes as shown below. Note the size 
selection determines the height of the thumbnail. The width is calculated automatically from the video's aspect ratio. 

Size: Pixel 
Height Sample:

Small 40

Medium 60

Large 85

Brightness: Choose from three different levels (Normal, Bright, or Intense) of display intensity. Dark frames 
can be hard to see at normal brightness levels. This parameter changes the display brightness of the thumbnail 
and does NOT affect the output created by VideoReDo.

Display Timecode w/Thumbnail: If you want to display the time code below each thumbnail, then enable 
this feature. You can customize the time code display font size and color by clicking on the Select 
Timecode Font button. 

Audio Waveform Display: The thumbnail window can optionally display a graphical representation of the 
audio waveform. The options in this window let you choose the graph color, (2 colors if the audio is AC3 



and contains both 2.0 and 5.1,) Axis color and scaling options. The default waveform display is linear, that is 
a sound that is recorded at twice the level of another will be twice as high on the graph display. The Log 
scale option changes the scale to a logarithmic scale, which corresponds to how people perceive the 
relative difference in volumes. In general, a linear scale (Log scale not selected) will make it easier to view 
where quiet passages are in the audio waveform. 

Note: The thumbnail window automatically scales the visible waveform depending upon the data that is 
being displayed. It is not an absolute scale. 

Show "No Graph" Warning: When Visualize Audio is selected, space is reserved in the thumbnail window 
for audio graph. However, the graph is actually drawn only if the following two conditions are met:

1.  The file being edited contains an audio stream. 
2.  The interval between thumbnails is 2 seconds or less. 

If Visualize Audio is selected and VideoReDo is unable to display a graph the following warning is displayed 
if this option is selected:
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Ad-Detective Common Parameters 

 

The Common Parameters dialog is used to control the behavior the scene detection methods:

Scanning Behavior:

Pause Scan At Beginning of Block:
When checked, an interactive Ad-Detective scan will pause at the start of each commerical block. The start of 
a commerical block is identified as the first scene transition with Maximum Block Length Seconds. 

Pause Scan At End of Block:
When checked, an interactive Ad-Detective scan will pause at the end of each commerical block. The end of 
a commerical block is identified as the last scene transition followed by Maximum Block Length Seconds 
of program material. 

Pause Scan At Each Scene Change:
When checked, an interactive Ad-Detective scan will pause whenever a scene change is detected. 

Automatically Cut Detected Scenes:
If checked, VideoReDo will add the material between the begin and end of a block to the cut list.  

Disable Display Update:
If checked, the video screen will not be updated during an interactive scan. 

 
 

 
CPU Priority While Scanning:

The Ad-Detective scanning process is very CPU intensive. You can make your system more responsive by 
setting the priority option to "Low". Once the scan is complete or manually stopped, the CPU priority of 
VideoReDo will be reset to "Normal" automatically.  

Minimum Seconds Between Marks:
If two scene changes are detected within this many seconds of each other, the first one will be removed.  

Maximum Block Length Seconds:
This value should represent the maximum number of seconds between for an entire commerical block. If 
your commercial blocks are 3 minutes long or less, then set this to 180 seconds.  
 
A "start of commercial block" is defined as a scene marker with this many seconds of uninterrupted 
program material in front. 
 
An "end of commercial block" is defined as a scene marker with at least this many seconds of program 
material before another scene marker is detected.  
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DVD: Edit menu template

 

Show TV safe area: Many television sets, especially CRT-based ones do not show the entire video picture, 
but clip a portion of all the margins. The amount of clipping differs from set to set, but all sets are guaranteed 
to show at least 80% of the broadcast picture. When placing titles and other text in on a menu screen, its 
is recommend that you keep them in the safe area. Checking this option displays a dashed rectangle of the TV 
safe area.

Title Properties: The options in this box determine if the menu template should be encoded in 4:3 or 
16:9 aspect ratio. More importantly is the NTSC/PAL parameter. When you are selecting in the DVD project 
screen, only templates which match the types of video you authoring will be displayed.

Text box properties: Text boxes are the basic object used by the menu template. Each text box can have 
its own dimensions, and text style (font, color, etc). To modify the attributes or contents of a text box you will 
need to select it by clicking anywhere in the text box. When a text box is selected it will highlighted with a 
rectangle with resizing handles. 

Center text box: While a text box is selected, click on one of these button to center the text box 
vertically, horizontally or both. 

Add text box: Click on this button to add a new text box. The text box will be placed on the screen 
and automatically selected.

Remove text box: Click this button to remove the currently selected text box.

Background properties: The two options in this box are used to change the background of the menu. 

Solid color: Select this option to set the back to a solid color. To select a different color simply click on the 
color sample.

Graphic / Select Image: Select "Graphic" and press "Select Image" to copy any recognized graphic file (.
bmp, .jpg, .gif, .png, etc), to the menu background. Graphic files are stretched to fit the actual dimensions of 
the menu, which are 720x480 for NTSC and 720x576 for PAL. 



 
If there is a graphic object on the system clipboard, for example a frame capture, you can paste the graphic 
using the Edit menu at the top of this dialog. 
 

Text Properties: The controls are used to set how text is displayed. If a text box is selected changes to 
the settings will affect the selected text box. If no text box is selected then changes to the Text properties 
become the style when adding new text box. The text property box is divided into three sub-frames: Font, 
Outline and Shadow. The following graphic shows examples of different text effects. Outlining and shadowing 
can be very effective for making text visible against a graphical background.

DVD menu properties: The controls are related specifically to the DVD menuing system.

Template name: The template name is what appears in the drop down box when you select a template on 
the DVD projects page:

Highlight properties: When a DVD menu is displayed, you can use your remote control arrow keys to 
select which title to play. The currently selected title is highlighted with a rounded rectangle. The two colors in 
this highlight property determine the colors to be used by that rectangle. The Outline color is drawn first 
followed by the Shadow color which is offset by a couple of pixels to the lower left. 
 
To test your highlight colors, click on Preview buttons. This will draw the highlight around all text boxes which 
which are DVD buttons. There is only one highlight setting for all title text Below are a couple examples of 
different color highlight pairs.

 

Is DVD button: If the currently selected text box is a DVD title button this option will be checked. You can 
convert any text box into a title button by checking this box.

Button order: If the text box is designated as a DVD button, this box determines which title it corresponds to.

Add title button: Click on this to add a DVD title button. A title button is a DVD button with a place holder {Title}. 

Preview buttons: Click this button to display the button highlight rectangles.

Add disc title: Clicking this button add a new {DiscTitle} text box unless one already exists.

Add disc description: Click this button to add a new text box with a {DiscDesc} placeholder.



More about editing text boxes: 

To edit the contents of a text box:  
Select the text box by click on it once, or use the tab key to cycle through the text boxes. Then using the 
mouse, double click again on the text box to select its text. You can then replace the text or use the 
arrows, backspace and delete key to modify its contents.

To move a text box: 
With the mouse: Click anywhere inside the box, and while holding down the left mouse button drag the text 
box around the screen. 
 
With the keyboard: Select a text box with the mouse, or use the Tab key to cycle through all the text boxes one at 
a time. Then, use the four arrow keys (left, right, up, and down) to move the text box one pixel at a time. If you 
hold down the ctrl key at the same time, movement will be in 5 pixel increments.

To resize a text box: 
With the mouse: Select a text box so that it draws it outline with the 8 resizing handles. Press and click on one 
of the resizing handles. Then while still holding down the left mouse button, drag the handle to expand or 
contract the text box. 
 
With the keyboard: Select a text box with the mouse, or use the Tab key to cycle through all the text boxes one at 
a time. While holding down the shift key, use the four arrow keys to expand or contract the size of the text box 
one pixel at a time. If you hold down the ctrl key at the same time, movement will be in 5 pixel increments.

To create multiple text boxes of the same size and text style: 
1) Select a text box. 
2) Click on Edit > Copy. 
3) Click on Edit > Paste, repeat.

Aligning text boxes: This is generally best done with the keyboard. When a text box is selected, its 
location and dimensions are displayed just underneath the template sample. You can then use they board 
sizing commands to match vertical and horizontal positions and sizes. 

Copying text styles between text boxes: Text styles can be easily copied from one text box to another. 
1) Select a text box. 
2) Click on Edit > Copy 
3) To copy the text style to all text boxes, click on Edit > Paste Style All. 
4) To copy to another text box, select the destination text box and click on Edit > Paste Style.

Mixing placeholders and static text: You can mix place holders with static text in a text box. For 
example the following text boxes will number each title on the menu: 

 
 
While the following text boxes will display a title without the preceding number: 

 
 
For a list of valid place holders, please see the Customize menu screen. 

Saving and restoring templates: When you click on the "Edit template" button on the DVD Project page. 
You are actually editing a working copy of the template which when you click OK on this screen will be used for 
a single DVD. To save 

File > Load Template: Select this menu option to load an existing template. You can change the location 
of where templates are stored using the DVD settings option page.

File > Save Template: You can save the customized template for future use by storing it in the default 
custom templates folder. 

File > Save bitmap: Click this option to copy the menu template to a .jpg fie.
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DVD: Customize menu text

 

 

Menu customization: This dialog is used to change text placeholders in the menu template. There are 
three different recognized of menu place holders allowed in a menu template: 

Name Placeholder tag Maximum number
Disc title {DiscTitle} 1
Disc description {DiscDesc} 1
Title 1 to Title 12 {Title} number of actual titles, limited to 12.

Templates can be edited and created using the template editor.

When you bring up the customize menu dialog, the current template is scanned for valid placeholders. For 
each one a multi-line edit box is shown into which you can update the actual text. Each edit box allow for multi-
line entry. Text that will not fit on one line is word wrapped into multiple lines. 

To manually split a line, enter a shift+enter into an edit box.

Menu Background: The button in this box let you quickly change the background of the menu

Change Background: Press this button to select from one of the following background options:

●     Select solid color - Change the background to a solid color
●     Select image - Let you choose an existing graphic file (.bmp, .jpg, .png, .gif, etc) to use as background.
●     Grab video frame - Using a slider you can move through the currently open video to choose a specific frame 

a background. Note, since navigation is simply via a slider you won't have full access to the VideoReDo 
navigation controls. 

●     Paste from clipboard - If there is a graphic object on the system clipboard this option will be available. If 
you plan to use a frame still as a menu background, you may want to capture an image to the clipboard 
before starting the DVD authoring process.

 

Revert to original: Press this button to reset the background the original one in menu template.

Shrink text to fit: When checked, the font size in all text boxes will be automatically reduced in an attempt 



to display all the entered text. However text will not be reduced lower than 12 points as smaller fonts 
become unreadable when displayed on a TV screen. If VideoReDo needs to shrink the font size in one title 
text box, the font sizes for all the other title boxes will be changed to match. This is done to preserve a 
consistent look and feel to the menu.

Preview DVD buttons: When pressed, the selected title highlight is drawn around each of the title text 
frames. The numbers in the upper left of highlight rectangle indicate the menu button order. You can customize 
the colors used to draw the title highlight rectangles using the template editor.
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DVD output: Video options

 

Aspect Ratio: Use this option to change the aspect ratio bits in the MPEG2 sequence header. Changing these 
bits does not affect the actual video stream nor will it convert video from one format to another.  It is used when 
the actual aspect ratio recorded by the capture card is incorrect.

Force 4:3 to pillar box When the aspect ratio is set to 16:9, this prompt will appear. Checking it will re-
encode 4:3 material to be recoded to a pillar box format. In pillar box format the 4:3 video is placed in a 16:9 
box with dark bars on the left and right sides.

Force 16:9 to letter box:When the aspect ratio is set to 4:3, this prompt will appear. Checking will re-
encode 16:9 material to a letterbox format. In letter box format the 16:9 video is placed in a 4:3 box with dark 
bars on the top and bottom.

Note, All titles on a VideoReDo created DVD must be of the same aspect ratio. When mixing 4:3 and 16:9 titles 
you need to choose an overall aspect ratio for the DVD.

Bit Rate: This option is used to set the overall bit rate for all videos. It is normally calculated by automatically 
by VideoReDo so that your video will fit on to a DVD of size you specified in the project dialog. If your videos are 
of standard definition and don't need recoding, then set this value to "No change".

Deinterlace mode: Your source may be recorded in interlaced or progressive format. This option 
controls whether to convert interlaced to progressive frames before resizing and recoding or not. Interlacing 
affects the resizing logic in VideoReDo. For standard definition material interlaced material, if cropping or 
resizing, each field is indecently resized. High definition video is always deinterlaced before resizing. 
Deinterlacing, by definition, causes some loss of detail and resolution. The following options are available:

Option Behavior
Auto Let VideoReDo determine whether or not to deinterlace and the best 

deinterlacing method.
None Disable deinterlacing.
BOB Use the BOB method. In the BOB method picture data from one field is 

copied to the other field. This is often the best method for video of fast 
moving scenes. BOB is the fastest deinterlacing method.

Weave Use data from both fields to create a progressive frame. Weave tends 
creates frames of higher resolution than BOB but does not work well with 
fast moving scenes.

Smart The smart deinterlace analyzes blocks of pixels in each frame and 
attempt to determine which interlacing method (BOB or Weave) will yield 
the best picture. This method can add significantly to the recoding time.



Max GOP Length: This parameter is used to specify the maximum GOP length for all videos on the DVD. For compliant 
a compliant video, the maximum GOP length is 15 frames for PAL and 18 frames for NTSC material. However, most 
DVD players will accept GOPs much longer than that. If you are recoding your video, then we recommend leaving this at 
the default value to create a compliant DVD. 

The VideoReDo authoring engine can only accept GOPs of up to 35 frames. So no matter what value you specify for 
this parameter, VideoReDo will internally limit your GOPs to that value.

DVD Display mode: This option is used to set the display mode for 16:9 video on a 4:3 TV. The default option is 
"Letterbox" which causes the DVD player to shrink down the video, with black bars on the top and bottom, so that the 
entire picture fits onto the screen. The "Pan & Scan" option causes the DVD player to crop off the sides of the video so that 
it fills the screen but at the cost of losing a bit of the picture. (You can convert the aspect ratio of the DVD to 4:3 through 
the cropping and resize option but this involves a time consuming recode. )

Remember these settings: 
Check this box so that VideoReDo will retain these settings as the default for future DVDs.
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DVD output: Cropping and resizing

 

Cropping and Resizing: You can use this dialog to invoke cropping and resizing of your video prior to 
recoding. Cropping and resizing parameters apply to all the video on your DVD. The slider control can be used 
to choose a sample frame to display since the currently selected frame may not be a good sample to show 
when resizing (i.e. a black frame). The displayed frame always comes from the currently open video regardless if 
its on the DVD or not.

Note: Cropping and resizing will always trigger a recode. If you are already recoding there is no additional 
speed penalty for cropping and resizing.

Top / Bottom / Left / Right: Enter a number or use the arrows to indicate the number of pixels to move 
the image. As you change the values the image will illustrate a sample of the output. Positive numbers will 
expand the picture in that direction (i.e. remove material). Negative numbers will squeeze the picture and 
introduce a dark background.

Presets: To quickly convert 4:3 letterboxed material to 16:9, select "Convert letterbox to widescreen", or 
to convert pillar boxed material to 4:3 select "Convert pillar boxed to standard". Both of these options 
will automatically fill in the appropriate Top/Bottom/Left/Right values.

Maintain aspect ratio: If you check this box, then you change one dimension the opposite dimension 
is changed to maintain the original aspect ratio of the video. For example if you expand the video in the 
vertical dimension (top or bottom), the horizontal dimensions will changed automatically to preserve the 
original aspect ratio.

Reset: Press this button to reset the sizing parameters back to zero.

Remember these settings: Check this box so that VideoReDo will retain these settings as the default 
for future DVDs
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DVD output: Audio options

 

Audio Properties 

Encoding: Use this option to specify the audio stream type of the output file. Options are: No Change, MPEG 
audio, or LPCM/WAV audio 

Bit Rate: This option is used to change the bit rate of the MPEG audio stream. Changing this field affects the 
output audio stream. LPCM audio is uncompressed and does not have a bitrate option.

Language: Each audio track on a DVD carries its own language code. Use this field to specify the language code 
for this audio track..

Remember these settings: Check this box so that VideoReDo will retain these settings as the default 
for future DVDs

Note: If the audio is not 48K, the audio will be automatically reencoded to meet DVD compliant 
specifications. There is no setting for this option.
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Context Menu 

 

You can display the context menu by clicking on the right-mouse button. It is used as a shortcut for 
common program operations.  All of the functions on this menu have equivalent keyboard shortcuts. 

Set Select Start 
Set Selection End

These functions can be used to reset the current selection start and end points and are the same as clicking on the 
 or  buttons.

Cut Selection 
Trim Unselected These perform the same functions as the  and  buttons.

Go To Start Selection 
Go To End Selection

These will jump the video to the current selection start or end points. The selection start and end points 

are indicated by vertical markers on the top navigation slider bar:  and .

Go To Program Start 
Go To End Of Program

Use these options to jump to the beginning or end of the program. 
 

Go To Timecode
Jump to a specific time code using the Enter Timecode dialog. Same as double-clicking on the program time 
or pressing Ctrl+T. 

Show Plot Mask 
Toggles the Plot Mask on or off. The size of the plot mask can be set on the Tools>Options>Enhance 
Plus Features Page. 

Go To Bookmark 
Set Bookmark

Use the Set Bookmark to set a marker at the current position on the top navigation slider bar. The 
bookmark position is indicated with a triangular marker:  

Use Go To Bookmark to jump to the position indicated by the marker.
Toggle Thumbnail View Enable or disables the thumbnail view. Same as pressing F11. 

Preview Your Edits Toggles the display mode between preview and edit mode. Same as pressing P or clicking on 
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Joiner Editing 

 

You can use the Joiner Selections dialog box to change the order of video sections when the joiner is used 
to output the video. The buttons on the right are enabled only when an entry in the dialog is selected. 

Up | Down Move the selected entry up or down in the list. These buttons are used to change the order of 
scenes that will be output.

Remove Removes the selection from the list of scenes that will be output

Descripiton.Changes the description associated with the selected scene(s). The description is only used 
for identification within this dialog.

Edit selection: If the selection is a videoredo or videoredo project, it will be reloaded back into the editor so 
that you can edit it. If the selection is an title screen, the title edtor will be started with the title loaded.

Add title: In addition to joining video projects, the joiner can add title screens between segments. Each title 
is created using the title editor. The amount of time each title is displayed along with the fade-in and fade-out 
times are set in the Tools>Options>Title screen and will be the same for all titles.

Clear All Clear list of all joiner selections.

Create video from joiner list: Click to create a video from the items in the joiner list.

Menu options:

File > Load joiner project: Loads the current joiner list with items from a previously stored project. 

File > Save joiner project: Saves the current list of titles, with their edits, to a DVD project file (.DPrj). If 
there are currently items in the joiner list, VideoReDo will ask you if you want to add the items from the 
stored project or replace the current contents of the joiner list. 
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Program Information 
 

Program Information 
 
This dialog displays information from the MPEG sequence headers about the format of the data in your program file.

This window can be accessed using the keyboard shortcut Ctrl+L or from the menu: Tools>Show Video 
Program Info

Press the 'Copy to Clipboard' button to save this information on the Windows clipboard in text format. 
This capability is useful when information is needed by customer support and can be pasted directly into an 
email response.
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Create Trimmed File Copy 

 

This dialog is used to make byte-for-byte copies of portions of the original program file. Its primary use is for you 
to create small copies of files that can be uploaded to the VideoReDo support team.

Source File: If you started this dialog after a video has been opened, the Source File will be filled in with the name 
of the currently open video program file.  Otherwise, click on the "..." button to select a source file.

Output File: This is the file that portions of the source file will be copied to. Click on "..." to display the standard 
file dialog box so that you can choose an output file.

Output Options:

From Beginning: Select this option to start writing from the beginning of the file. Use the MBytes to Output control 
to specify how many MBytes of data to write.  A MByte is 1,048,576 bytes.

To End Of File: Select this option to output the desired number of MBytes at the end of the file.  For example, if 
you specify 10 MBytes to End Of File, the last 10 MBytes of the file will be copied.  Note: VideoReDo looks for 
an MPEG packet boundary before starting the output. This may result in a file that is slightly smaller the exact 
size you specify.

Start At MByte: This option is used to copy data from the middle of the file.  You will need to specify both 
the starting MByte and MBytes To Output. Once again, VideoReDo looks for an MPEG packet boundary 
before starting the output. This may result in a file that is slightly smaller the exact size you specify.

Use Selection Markers: Click on this button to have VideoReDo automatically calculate the Start MByte and 
MBytes to Output based on the position of the selection markers.  This option is extremely useful if you've 

identified a section of video you want to copy.  Position the Start and End selection markers,  and , to 
bracket the area you which to copy.  You cannot use this option if you don't have the file open for editing.

Start Copy: Click this button to start the copy process.

Please note: This function performs a byte-for-byte copy and does not create MPEG compliant files.  However, 
you can trim the end off of a video and leave the file MPEG compliant as long as you copy from the beginning.
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Output Processing Complete 

 

This dialog is displayed when VideoReDo has finished creating the output file. Items displayed in red are 
warnings which may indicate possible problems with the input or output file.

The data from this dialog is always written to the log file. 
 

Output Statistics:  
Video output frames: Number of video frames output.
Audio output frames: Number of audio frames written to the output file. 
Processed  frames/sec: Number of video frames per second processed.
Processing time (secs): Elapsed time to create the output file.

Padding output packets:
Number of padding packets written. You can reduce the amount of padding, and overall file size by not 
including padding packets. Refer to Advanced Stream Parameters for additional information.

Actual Video Bitrate (Mbps) Video bit rate in Mbps (Millions of bits per second)..

Note: Audio and frames have different durations and it normal for the number of Audio output frames to be 
quite different from the number of Video output frames. 

Warning counts: If present, these statistics may indicate potential problems with the 
source program material. These values are displayed in Red in the dialog box, and 
preceded with an "*" in the log file.

* PTS underflow:

PTS underflows occur when the presentation time stamps (PTS) fall behind the system clocks in the 
program pack stream headers(SCR). An MPEG program stream has two sets of time stamps, one for the 
overall file and another for each elementary audio and video stream. The PTS underflow indicates that the 
bit rate for at least one of the elementary streams exceeds the overall bit rate for the entire file (SCR). 

A few ( < 100) PTS underflow errors will not affect the output program. You can increase the overall bit 
rate of the file by overriding the video bit rate on the Output Options dialog.  

 
Note: If you intend to author this file to a DVD, the overall bit rate should not exceed 10 Mbps. 

* Clipped Audio Frames:

When using the audio volume adjustment to increase the volume, its possible that audio levels may be 
increased to the point of clipping. Internally, audio levels are stored as integers ranging between +/- 
32767. In increasing the volume outside of this range causes clipping. Since each audio frame is 24 msec 
long, you may be able to tolerate clipping on a few frames. The solution, if you have too many clipped 
frames, is to reduce the amount of volume adjustment. 



* Audio frame errors:

All audio frames start with a 32-bit header. An audio frame error occurs when the editor does not find the 
expected header where it thinks an audio frame should start. Audio frame errors are usually caused by 
dropped frames in the input file and if not too frequent are generally recoverable without a problem. 

However, Audio Frame Errors can also occur if the audio characteristics such as bit rate or sampling rate 
change in the middle of a program. In this case, the editor will not be able to recover. You can set the 
maximum number of allowable frame errors on the Advanced Stream Parameters option page. 

* Program clock overflow:

A program clock overflow occurs when the actual PTS clocks of an output segment exceed the calculated 
segment length. The primary cause of this problem are erroneous time stamps in the original file. 

The suggested solution is to run Tools>QuickStream Fix on the source file before editing. This will 
cause all the time stamps to be re-calculated. If the problem persists after that, please contact support.

* Input Sequence Errors: Input sequence errors occur when the temporal reference of a video frame is outside the allowable values. 
It indicates that there were some problems with the source video material, probably dropped frames.

* Video resync frames removed:

This value represents the number of video frames that were removed to keep the program's audio and 
video in synchronization.  Video frames are gradually removed if the program detects missing audio 
frames when creating the output file.  

Please refer to Advanced Stream Parameters for additional information.

* Video resync frames added: 

This value represents the number of video frames that were added to keep the program's audio and video 
in synchronization.

Please refer to Advanced Stream Parameters for additional information.

* Audio resync frames removed:

If you ask VideoReDo to detect and compensate for missing audio and video frames in the Advanced 
Stream Parameters dialog, this value will represent the number of audio frames that were removed to keep 
the audio and video in synchronization.  Typically audio frames are removed if there are missing video 
frames.

* Stream errors during decode:

If MPEG2 stream errors are encountered during the decode, the decoder will exit. This will result in the 
entire GOP being copied to the output file rather than performing a clean edit on just the frames you 
specify. 

Decoder stream errors are written to the log file along with their original timestamp.
 
 

VideoReDo TVSuite Help - © 2003-2007 DRDSystems, Inc.



 
Overlapping selections 

 
This dialog is displayed when you try to create a selection that overlaps a previous one. You will need to select 
one of the options listed:

Press Combine to combine the two overlapping selections into one.

Press Replace to delete the old selection and replace it with the new one.

or, Press Cancel to simply abort this operation.

You can disable this dialog by selecting "Auto Replace Overlapping Cuts" in the General Parameters 
options dialog. When this option is selected, new overlapping cuts will replace the existing cut.
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QuickStream Fix 

 

This dialog is used to re-multiplex an MPEG2 program stream. It will copy the input file to the output file through 
the VideoReDo stream processing routines. This means that all the time stamps in the output file, such as PTS 
and GOP headers, will be re-calculated. In addition, all the processing parameters as specified on the 
Advanced Stream Dialog will be honored as well. In other words the output file will be MPEG2 compliant file. 

The key purpose of QuickStream Fix is to re-align the time stamps in the output file. Sometimes, video 
captured from DVB Satellite or sourced from DVD VOB or VRO files may have internal time stamps that are 
not sequential.  When you normally open a file in VideoReDo it will search for these non-sequential time 
stamps and handle them gracefully.  Occasionally it is unable to do so effectively and the QuickStream Fix 
function will prove useful.

Input Program Stream: If you started this dialog after a video has been opened, the Source File will be filled in 
with the name of the currently open video program file.  Otherwise, click on the "..." button to select a source file.

Enable Filters: Check this box to enable filtering within QuickStream Fix by displaying the filtering 
dialog. QuickStream Fix Filtering will remove all frames that do not correspond to a particular video 
dimensions. This feature is useful when trying to edit a file where the video dimensions change in the middle of 
the file. VideoReDo can only edit a file with a single set of video dimensions. 

Select Stream ...: If there are multiple audio and / or video streams in your file, click this button to select 
which streams to process via the Stream Selection dialog. 

Output Program Stream: This is the file that the source file will be copied to. Click on "..." to display the standard 
file dialog box so that you can choose an output file and output file options.

Start Quick Fix: Click this button to start the processing. 

 
Note: Running QuickStream Fix in batch mode: You can process multiple files through QuickStream Fix at one 
time using our batch manager. In the batch manager, select one or more MPEG (program or transport stream) 
files to process. The batch manager will assume that you want to run QuickStream Fix on the file since 
you specified a video file rather than a VideoReDo project file.  
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Frame Capture 

 

Frame capture will copy the currently displayed video frame to a bitmap file or the windows 
clipboard. This dialog is used to determine the frame capturing options. The current video image 
can be captured to either the Windows Clipboard or a bitmap file (.bmp). You also have the option 
to save the file as a JPG, TIF, or PNG file. To initiate a Frame Capture, select Capture Frame 
from the Edit menu or simply type Ctrl+C.

Destination: Select whether you want to capture to the clipboard or a bitmap file (.bmp).

Size: VideoReDo gives you the option of four different sizes. The primary size is based upon the actual video 
image display size. The rest of the sizes are smaller versions of the primary size. 
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Stream Selection 

 

If your stream contains multiple video and/or audio streams, this dialog can be used to choose which 
stream combination to edit. By default, VideoReDo will edit the first set of streams in finds in your file.  When 
you select a different stream, your current edits will be lost and the file re-opened.

Keyboard users will notice that allowable selection is preceded by a number. Simply type that number to move 
the selection bar to the appropriate entry.

The PID numbers are the internal stream ID codes used within your file. 

Note: Currently, VideoReDo can only process a single audio / video stream pair. If there are multiple audio 
streams in a program, VideoReDo will only output the selected one. 
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Display Adjustment 

 

This dialog is used to adjust the brightness and contrast of the VideoReDo display.  It does not, in any 
way, affect the appearance of the your edited file. 

To use keyboard commands with this dialog, click on Alt+B to set keyboard focus to the brightness slider, or Alt
+C to set the focus to the contrast slider.  Then use the left and right arrow keys to move the slider.  You may 
also use the Tab key to cycle through each of the controls on this dialog. 

Pressing the "Reset" button will revert the controls back to their default positions which indicate no change to 
either brightness or contrast.

Your display adjustment settings are saved between runs and need not be enabled each time you start VideoReDo.
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Ad-Detective Parameters 

 
Ad-Detective parameters 
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Batch Builder 

 

The VideoReDo Batch Builder is used to process multiple edit project files (*.VPrj) at one time. This way you 
can perform your edits quickly using the interactive portions of VideoReDo and then have the VideoReDo 
Batch Builder handle the more time consuming output tasks at a more convenient time.

The Batch Builder relies upon VideoReDo project files. Project files are short files which contain the 
information needed to edit your files. Information such as the name of the input file and the start and end points 
of each of your cuts. You can create project files in VideoReDo by selecting "Save Project" from the File menu. 
You can also create an automatic project and queue directly into the Batch Builder by using the "Queue To 
Batch" from the File menu, or pressing Ctrl+B anytime in VideoReDo.

When you start the batch builder, any projects previously queued using the Queue To Batch (Ctrl+B)  
are automatically loaded into Batch Builder processing list. You can also load previously saved projects 
manually by selecting them into the Source Project / File: window. The batch builder will automatically create 
a destination filename based upon the input filename, destination folder, destination modifier and 
Elementary Stream Output Flag. Click on Add Entry to add it to the list of projects to be processed.

When your list of projects to be processed is complete, click either on "Save Commands" or "Save and 
Execute". Save Commands will create a windows .CMD file that you can run yourself at a later time.  Save 
and Execute will not only save the .CMD file, but execute it immediately.

Source Project / File: You may enter the name, including the file folder, of an existing VideoReDo project. 
Click on the "..." button to the right to select project(s) using the file entry dialog. Note: You can 
select multiple projects at one time in the file entry dialog. If you do so, all the 
projects selected will be entered directly into the batch list.

Destination Folder: This field is the default destination for the output file. Click on the ".." button to the right 
to browse for a folder. The destination folder along with the input file name is used to form the destination filename.

For example: Your input file is c:\source\fb1.mpg and the destination folder is: d:\edits, then the 
proposed destination filename will be d:\edits\fb1.mpg

Destination Modifier: This string, if present, precedes the output file. You can use the Destination 
Modifier alone or in conjunction with the Destination Folder.

Special note: The destination modifier will prefix the actual filename unless the 
modifier begins with a '-' or '_' in this which it will suffix the filename. 

Examples:

Original 
Filename

Destination 
Folder

Destination 
Modifier Output File

c:\temp\fb1.
mpg d:\edits VRD_ d:\edits\VRD_fb1.mpg



c:\temp\fb1.
mpg d:\edits VRD_ d:\edits\VRD_001_fb1.mpg

c:\temp\fb1.
mpg d:\edits -VRD d:\edits\fb1-VRD.mpg

c:\temp\fb1.
mpg d:\edits -VRD_ d:\edits\fb1-VRD_001.mpg

For example: You input file is c:\source\fb1.mpg, the destination folder is d:\edits and the destination modifier 
is "Cuts_". Then your proposed destination filename will be d:\edits\Cuts_fb1.mpg.  

Destination Type: Select the desired output file format:

MPG - MPEG Program Stream or MPEG
 
 
 
 
 
 
 
MPV - Elementary Streams

Separate Audio and Video into separate files.
TS - Transport Stream

Industry compliant Transport Stream.
DVR-MS

Format used by Microsoft Media Center 
REC - Topfield REC 

Topfield REC format. A transport stream with a Topfield header. 
TIVO 

Program stream file formatted with a Tivo metadata header. If the source file is not a Tivo file, the output file will 
be formatted as an industry standard program stream. 

 
VPRJ - Ad-Detective Scan 

Rather than edit a file, this destination type requests the batch manager to perform a complete Ad-Detective 
scan on the source file. The output will be VideoReDo project file with scene markers set at the 
commercial transitions. 

MPG (MPEG with blank NAV packets)
Creates an MPEG program stream, but with blank NAV packets. These files can be used directly with open 
source DVD authoring tools to avoid an extra demuxing / muxing step.

Destination Filename: This is the filename that the Batch Builder has proposed to output your edited video 
to. It is a combination of the input filename, Destination Folder, and Destination Prefix. If the filename is 
acceptable, simply click on "Add Entry" to accept the entry and add it to the Batch Builder List.

.BPRJ Disposition: The .BPrj files are project files created automatically when you select the queue to 
batch command in VideoReDo. Use this option to either have the .BPrj files deleted after processing, or left on 
your hard drive.  If you elect to have them deleted, they will only be deleted if the batch processor actually 
creates an output file.  If the .BPrj files remain on your system after batch processing then double check the 
size and content of your output files. They may indicate a problem.

Run Silently: If checked, the output progress dialog will not be displayed during batch processing. 

Add Entry: Click on this button to add the project and Destination filename to the batch builder list.

Remove: This button will be active if you have selected one or more entries in the batch builder list. Click on it 
to remove the items from the list.

Save Commands: Click on this button to have the Batch Builder create a windows .CMD for you. This .CMD 
file can be run later from the command line, windows scheduler or Run box.

Save and Execute: Click on this button to create the windows .CMD file and begin executing it immediately.
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Output File Options 
 

Output Options 
 

This dialog is displayed by pressing the "Options" button in the File Save As dialog box.

Video Properties

Aspect Ratio: Use this option to change the aspect ratio bits in the MPEG2 sequence header. Changing these 
bits does not affect the actual video stream nor will it convert video from one format to another.  It is used when 
the actual aspect ratio recorded by the capture card is incorrect.

Bit Rate: This option is used to change the bit rate fields in the MPEG2 sequence header. Changing this field 
does not affect the actual video stream. It is used when the actual bit rate, as recorded in the file, is incorrect. It 
is most often used to change the DVB 15Mbps bitrate to a  lower value so that the resultant MPEG2 stream 
is acceptable to DVD authoring programs and players.

Technical Note: If you specify a bit rate override of 10 Mbps, VideoReDo will assume that you want the 
MPEG headers to correspond to DVD specifications. The video bit rate will be set to 9.80 Mbps less the audio 
bit rate, and the overall program stream mux rate will be set to 10.08 Mbps. 

Maximum GOP Length: This parameter is used to have VideoReDo reduce the GOP size when when writing the 
output stream.  GOP size reduction is usually used to take long GOP program material, such as those captured from satellite 
or PVRs, and make the program DVD compliant.  Compliant DVDs have a maximum of 18 frames per GOP although 
15 frames seems to be a more frequently used convention. If you set the maximum GOP size to a value greater than 
4, VideoReDo will recode frames so that all GOPs in the output file will be less than or equal to that maximum size. 
This frame recoding will add significantly to the time it takes to output your video, and will also increase the file size by 
at least 10%. 

Output Empty NAV Packets : This option is used to insert blank NAV packets into an MPEG Program Stream. 
This format is suitable for input directly into some DVD authoring programs such as the open source 
program: dvdauthor.

Audio Properties 

Encoding: Use this option to specify the audio stream type of the output file. Options are: No Change, MPEG 
audio, or LPCM/WAV audio 

Bit Rate: This option is used to change the bit rate of the MPEG audio stream. Changing this field affects the 
output audio stream. LPCM audio is uncompressed and does not have a bitrate option.

Sampling Rate: This option is used to change the sample rate of the MPEG audio stream. Changing this field 
affects the output audio stream. optin can be used to convert audio to a DVD compliant format (48,000.)

Note: If you specify a change to the Audio Properties, the audio output stream is modified. This is not simply 
a change to the header information. 

Remember These Settings: This option is used to permanently use these options for output of future files 
so the settings do not need to be manually adjusted each time. 
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CRID File Dialog Box 

 

Once you select Open CRID File from the File menu, you will be presented with the above box. If you don't see 
this option on the main File menu, then CRID processing hasn't yet been enabled on the Enhance Plus 
Features option page. 

Change Folder: Click this button to change the default CRID folder location. 

Open Selection: Opens the selected file for editing in VideoReDo 

Changing the sort order: The sort order can be changed by clicking on either the Filename or Date 
column header. The first time you click on a header the programs will be sorted in ascending order. Clicking 
again will sort in decending sequence. 

Managing Files :Clicking the right mouse button on a file presents the following options 

Rename - Rename the file. 
Delete - Delete the file from your computer.
QuickStream Fix - Directly process the file through QuickStream Fix
Open Selection - Open the file for editing 

Note: Both QuickStream Fix and Open Selection will create a VLST file in the folder you specified in 
Enhanced Plus Features. This will allow for the auto-concatenation of the files for the complete program stream.
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COM Interface 

 
 
The VideoReDo COM interface lets another COM enabled application invoke and control many aspects of 
VideoReDo's behavior. In fact the VideoReDo's own batch manager uses the COM interface to create command files 
that process your edit commands. The samples shown use the Windows Scripting interface which is available on all 
Windows systems which run VideoReDo.

VideoReDo COM Interface:

Methods:

AbortOutput Aborts the current file- or joiner-save that is in progress.  
AddFileToJoiner Adds a program file or VideoReDo project to the joiner list.  
AddSceneMark Adds a new scene marker.  
AddToJoiner Adds the currently open VideoReDo project to the joiner list.  
CaptureFrame Capture a bitmap of the current frame and saves it either to the 

Windows clipboard or a file.  

ClearAllSelections Clears all sections from the cut or scene list.  
ClearJoinerList Removes all items from the joiner list.  
Close Closes the currently open file.  Any unsaved edits are lost.  
DeleteBatchProjectFile Deletes a project file as long as the output file is great then 

1MB in length. (Plus only)  

EnterRegistrationKey Displays the registration key entry dialog.  
FileOpen Opens a program file or VideoReDo project.  
FileOpenBatch Opens a program file in QuickStream Fix mode.  
FileOpenBatchPIDS Opens a program file in QuickStream Fix mode using 

the specified PIDs.  

FileSaveAs Saves the currently open file or project.  
FileSaveAsElemStreams Saves the currently open file or project as elementary streams.  
FileSaveAsEx Saves the currently open file or project in a desired format.  
GetCursorTimeMsec Returns the current cursor time in milliseconds.  
GetCutMode Returns whether VideoReDo is in cut or scene mode.  
GetCutSceneListCount Returns the number of items in the cut or scene list.  
GetCutSceneListData Returns the start or end time, in milliseconds, of a 

particular cut.  

GetFrameRate Returns the current frame rate in 100's of a second.  
GetProgramDuration Returns the length of the currently open program.  
GetSceneMarkMsec Returns the location of a scene marker in milliseconds.  
IsOutputInProgress Tests whether VideoReDo is in the middle of saving a file.  
IsScanInProgress Tests whether VideoReDo is in the middle of performing a 

commerical scan. (Plus only).  

Pause Pauses the currently open  video.  
Play Plays the currently  open video.  
QueueEditsToBatch Queues the currently open VideoReDo project to the batch 

queue.  

RemoveSceneMark Removes a scene marker.  
SaveJoinerAs Save the joiner list as a program stream.  
SaveJoinerAsEx Save the joiner list to a selected file type.  
SeekToTimeMsec Seeks the cursor to a specific point in your program.  
SelectScene Creates a selection using the specified start and end times.  
SetAudioOutputCodec Sets the audio codec that will be used when saving 

edits.  

SetCutMode Sets the editor mode to either cut or scene mode. Overrides 
the default value.  

SetFilterDimensions Restricts file saves to GOPs with a specific video 
dimension.  



SetQuietMode Sets VideoReDo to run with a minimal screen interface  
StartAdScan Starts commercial detection of the currently open file. (Plus 

only)  

WriteProjectFile Saves the current project file to disk.  
 Sample Script

Properties::

AudioAlert Sets or gets the audio alert status  
OpenedFilename Gets the currently opened filename  
OutputPercentComplete Estimate of output percent complete  
PlotMask Sets or gets the size of the plot mask.  
PreviewMode Enable or disabled the preview mode.  
SelectionEndMsec Sets or gets the location of the start selection marker.  
SelectionStartMsec Sets or gets the location of the start selection marker.  
ThumbnailDisplay Enable or disable the thumbnail display.  
ThumbnailInterval Sets or gets the thumbnail interval  
VersionNumber Retrieves the current VideoReDo version number.  

How To Start VideoReDo in Silent Mode: 

To start VideoReDo in silent mode, create the "VideoReDoSilent" COM object instead of the "Application" object. 

 

if quietMode then
  ' Start in silent mode
  '
        Set VideoReDoSilent = WScript.CreateObject( "VideoReDo.VideoReDoSilent" ) 
        set VideoReDo = VideoReDoSilent.VRDInterface 
else
  ' Start in windowed mode.
        Set VideoReDo = WScript.CreateObject( "VideoReDo.Application" ) 
end if 

 
  

BOOL AbortOutput( )
AddSceneMark( ) as Integer
 
Parameters:
none  
  
Return Values:

Function returns non-zero (TRUE) if output was in progress prior to calling this function,  otherwise zero (FALSE)

Description:  
This command will instruct VideoReDo to stop the output process. Note that output occurs in a background thread 
and you should not assume that the abort has completed when this call returns. Continue to monitor 
IsOutputInProgress until that function returns false. 

 
  

BOOL AddSceneMark( long sceneTimeMsec )
AddSceneMark( sceneTimeMsec as integer) as Integer
 
Parameters:
sceneTimeMsec Time, in milliseconds, at which to place the scene marker. 
  



Return Values:
Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command will add a scene marker to the timeline. If an existing scene marker exists within 1 second of the 
specified time, then the new marker will NOT be added. 

 

BOOL AddFileToJoiner( const char *filename )
AddFileToJoiner( filename as string) as Integer
 
Parameters:
filename Character string containing a VideoReDo project file or MPEG program file. 
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command combines a FileOpen command followed by an AddToJoiner.

 

BOOL AddToJoiner(  )
AddToJoiner(  ) as Integer

Parameters:
none  
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command adds the currently open file and its associated edits to the joiner list. 

 

BOOL CaptureFrame( int type, const char *filename, int divisor )
CaptureFrame( type as integer, filename as string, divisor as integer ) as Integer

Parameters
type 0 = copy to clipboard, 1 = copy to .bmp file.
filename filename string. Ignored if type is '0'.
divisor 1 to 8.  Shrinks the bitmap size by this factor.  
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command will copy the currently displayed video image to the clipboard or bitmap file, depending upon the value 
of the 'type' parameter.  The divisor is used to scale the image.  For example if the original video is 720 x 480 and the 
divisor is '2', then the bitmap size will be 360 x 240.

 

BOOL ClearAllSelections( )
ClearAllSelections( ) as Integer

Parameters
none  
  
Return Values:



Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command will clear all selections from the cut or scene list.

 

BOOL ClearJoinerList( )
Close(  ) as Integer
 
Parameters
none  
  
Return Values:

Function returns non-zero (TRUE) if the joiner list was not empty before this call was made,  otherwise zero (FALSE)

Description:  
Clears all items from the joiner list. 

 

BOOL Close( )
Close(  ) as Integer
 
Parameters
none  
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command closes the current file.  Same as clicking on the File > Close menu.

 

BOOL DeleteBatchProjectFile( const char *projectFile , const char *outputFile)
DeleteBatchProjectFile( projectFile as string, outputFile as string) as Integer
 
Parameters:
projectFile   Name of a VideoReDo project file.
outputFile   Name of a VideoReDo project file.
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command is used by the VideoReDo batch processor to optionally delete the temporary project files (*.BPrj) after 
batch processing. It will first check the size of the outputFile, and if its great than 1 MB delete the projectFile.  This 
check is done to insure that project file isn't deleted if VideoReDo had a problem creating the outputFile.

 

BOOL EnterRegistrationKey()
EnterRegistrationKey( ) as Integer
 
Parameters:
 None
  
Return Values:

Returns TRUE (1) if the user clicked on the "Register Key" button. 
Otherwise FALSE (0). 

Description:  
This COM command is intended for users who pre-load VideoReDo onto a system and want to be sure the system 
administrator is prompted to enter a key. 



 

BOOL FileOpen( const char *filename )
FileOpen( filename as string) as Integer
 
Parameters:
filename Character string containing a VideoReDo project file or MPEG program file. 
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command will open a VideoReDo project file or an MPEG video file. If an MPEG program or transport stream file 
is specified, then FileOpen will open the first video stream it finds and the first audio audio stream it finds for that 
video. To specify specific audio and video PIDs either use a project file or use the FileOpenBatchPIDS if running 
QuickStream Fix. 

 

BOOL FileOpenBatch( const char *filename )
FileOpenBatch( filename as string) as Integer
 
Parameters:
filename Character string containing a VideoReDo project file or MPEG program file. 
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command will open a VideoReDo project file or an MPEG video file. If the file is a video file it will be opening in 
QuickStream Fix mode and the video will not display. 

 

BOOL FileOpenBatchPIDS( const char *filename, long videoPID, long audioPID)
FileOpenBatchPIDS( filename as string, videoPID as integer, audioPID as integer) as Integer
 
Parameters:
filename Character string containing a VideoReDo project file or MPEG program file. 
videoPID The PID (program ID) of the video stream. 
audioPID The PID (program ID) of the audio stream. 
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command will open a VideoReDo project file or an MPEG video file. If the file is a video file it will be opening in 
QuickStream Fix mode and the video will not display. If the audioPID and videoPID must exist in in the video file or 
an error will be thrown. 

For MPEG program stream files including VOBS, the PIDs refer to the stream number:

●     0xE0-0xE7: mpeg2 video stream
●     0x80 - 0x87: AC3 audio stream
●     0xC0 - 0xC7: MPEG audio stream
●     0xA0 - 0xA7 LPCM audio stream 

 

BOOL FileSaveAs( const char *filename )
FileSaveAs( filename as string) as Integer
 
Parameters:
filename Character string containing a MPEG program file. 
  
Return Values:



Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command will save your current project to the specified file.

 

BOOL FileSaveAsElemStreams( const char *filename )
FileSaveAsElemStreams( filename as string) as Integer
 
Parameters:
filename Character string containing a MPEG program file. 
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command will save your current project to a pair of elementary streams. The filename specified is the video stream 
stream. The audio stream will be saved to the same base filename but with an MP2, AC3 or WAV file type, depending 
upon the type of audio encoding used in the particular stream. 

 

BOOL FileSaveAsEx( const char *filename, short outputType )
FileSaveAsEx( filename as string, outputType as integer) as Integer
 
Parameters:
filename Character string containing a MPEG program file. 
outputType 1 = Program Stream 

2 = Elementary Streams 
3 = VOB (MPEG with blank NAV packets ) 
4 = Transport Stream 
5 = REC (Topfield) 
6 = DVRMS 
7 = Tivo (or MPEG if source file isn't Tivo) 

  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command will save your current project letting you specify the output file type.

 

BOOL FrameAdvance( BOOL direction  )
FrameAdvance( direction as integer ) as Integer
 
Parameters:
direction TRUE (or 1 ) to advance the video by a single frame. FALSE (or 0) to move the video back one frame.
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command will move the video by one frame in either the forward or backward direction.

 

BOOL  GetCutMode(  )
GetCutMode() as Integer 
 
Parameters:
none  
  
Return Values:



Returns non-zero (TRUE) if VideoReDo is running cut mode. Returns zero (FALSE) if running scene mode...

Description:  
This command may be run before before a file has been opened. 

 

short  GetCutSceneListCount(  )
GetCutSceneListCount() as Integer 
 
Parameters:
none  
  
Return Values:

Returns the number of items presently in the cut / scene list. 

Description:  
If a video file is not yet open, 0 will be returned. 

 

long  GetCutSceneListData( short cutNumber, short startEndFlag )
GetCutSceneListData( cutNumber as Integer, startEndFlag as Integer ) as Integer 
 
Parameters:
cutNumber The cut or scene number. The first scene number is 1. 
startEndFlag Set to 0 to return the start of cut or scene time. 1 to return the end time of the specified cut or scene. 
  
Return Values:

Time in milliseconds. If a video has not yet been opened or the cut list is empty, -1 is returned. 

Description:  
This function, along with the GetCutSceneListCount(), is used to retrieve the locations of cut and scene 
markers. 

 

long  GetCursorTimeMsec(  )
GetCursorTimeMsec() as Long
 
Parameters:
none  
  
Return Values:

Returns the current cursor time in milliseconds..

Description:  
For example if the video position is at: 00:10:01.00, then this function return: 601000.

 

long  GetFrameRate(  )
GetFrameRate() as Long
 
Parameters:
none  
  
Return Values:

Returns the frame frame in hundreds of a second.

Description:  
For example: 29.97 frames / second is returned as 2997.  25 frames / second is returned as 2500.  If there 
isn't an open video program, 0 is returned.

 



double  GetProgramDuration( )
GetProgramDuration( ) as Double
 
Parameters:
none  
  
Return Values:

The length, in seconds, of the currently loaded program. 

Description:  
Returns a floating point number with the total number of seconds in the program.  

 

long   GetSceneMarkMsec( int sceneIndex )
GetSceneMarkMsec( sceneIndex as Integer ) as integer 
 
Parameters:
sceneIndex Scene marker number, with a range of 1 to N. Calling with sceneIndex of 0 will return the number of scenes 

markers set. 
  
Return Values:

If sceneIndex is zero, returns the number of scene markers.

Otherwise, the location of the scene marker along the timeline, in milliseconds. 

If an error such as sceneIndex is out of range, then return -1. 

Description:  
Returns the location of the scene marker along the timeline in milliseconds. 

 

BOOL IsOutputInProgress( )
IsOutputInProgress() as integer
 
Parameters:
None  
  
Return Values:

TRUE (1) if VideoReDo is processing output, otherwise FALSE( 0 ).

Description:  
This command is part of the output process.  When creating output, use one of the Save commands followed by a loop 
which continually checks this value.  As long as it remains TRUE you should sleep for a second or two and then 
recheck it.

 

BOOL IsScanInProgress( )
IsScanInProgress() as integer
 
Parameters:
None  
  
Return Values:

TRUE (1) if VideoReDo is currently performing an Ad-Detective Scan, otherwise FALSE( 0 ).

Description:  
This command is part of the batch Ad-Detective  process.  While Ad-Detective is active, this function will return TRUE 
(1).  Once Ad-Detective completes, it will return FALSE (0) indicating its OK to save the Ad-Detective project file.  As 
long as it remains TRUE you should sleep for a second or two and then recheck it.

 

BOOL Pause( )



Pause() as Integer
 
Parameters:
none  
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command will cause VideoReDo to pause a currently playing video.  If the video is already paused, it will be 
ignored.

 

BOOL Play( )
Play() as Integer
 
Parameters:
none  
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command will cause VideoReDo to start playing a previous paused video.  If the video is already playing, the 
command will be ignored.

 

BOOL QueueEditsToBatch( )
QueueEditsToBatch( ) as Integer
 
Parameters:
none  
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This command functions the same as the menu option File > Queue To Batch. It will save the current edits as a project 
and put it into the queue file for batch processing.

 

BOOL RemoveSceneMark( long sceneIndex )
RemoveSceneMark( sceneIndex as Integer) as Integer 
 
Parameters:
sceneIndex The index of the scene marker, in the range of 1 to N. 
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This function removes a scene marker from the list of scene markers. Scene markers are indexed from 1 to N where N 
is the total number of scene markers. 

 

BOOL SaveJoinerAs( const char *filename )
SaveJoinerAs( filename as string) as Integer
 
Parameters:
filename Character string containing a MPEG program file. 
  
Return Values:



Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
Use this command to save your current joiner command to the specified output file.

 

BOOL SaveJoinerAsEx( const char *filename, short outputType )
SaveJoinerAsEx( filename as string, outputType as integer ) as Integer
 
Parameters:
filename Character string containing a MPEG program file. 
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
Use this command to save your current joiner command to the specified output file. The outputType = 1 for program 
stream output, 2 for elementary stream output, and 3 for VOB (MPEG with blank NAV packet output).

 

 

BOOL SeekToTimeMsec( long timeMsec )
SeekToTimeMsec( timeMsec as integer ) as Integer
 
Parameters:
timeMsec Seek position in Milliseconds.
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This control will advance the cursor the specified point in your program. If the program is currently playing, it will be 
paused after this command completed.

 

BOOL SelectScene( long startMsec, long endMsec  )
SelectScene(  startMsec as integer, endMsec as integer ) as Integer
 
Parameters:
startMsec Time for the beginning of the scene
endMsec Ending time for the scene.
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
The function duplicates the functionality of setting the start and end selection markers and then either cutting or adding 
the scene. If the current edit mode is "Cut" then the scene will be cut from the output. If the edit mode is "Scene" it will 
be added to the output. You can change the default edit mode by using the SetCutMode() command after opening your 
file.

 

BOOL SetAudioOutputCodec( short audioCodec, short bitRateKbps, short samplingK  )
SetAudioOutputCodec( audioCodec as Integer, bitRateKbps as Integer, samplingK as Integer ) as Integer
 
Parameters:



audioCodec Audio Output Codec: 

0 = audioCodecNotSpecified, Use the default output codec. 
1 = audioCodecLPCM, Output audio as WAV (LPCM).  
2 = audioCodecMPEGL2, Output audio as MPEG1 Layer 2. 
3 = audioCodecAC3, Output audio as AC3 (not yet supported).  
 

bitRateKbps Output bitrate in KBps. Not used for LPCM. (e.g. 224 = 224,000 bps ). 
samplingK Output sampling rate in thousands (i.e. 48 = 48,000 samples / second). NOTE: This parameter is ignored 

and is intended for future support. 
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This function is used to set the audio output codec, and should be called after a file is opened, but before saving. When 
a file is opened, the default audio output codec (and bit rate) is ascertained. Using the following logic:

1.  If opening a project file (VPRJ/BPRJ) and it contains output audio codec settings these will become 
the audio codec settings.

2.  If codec is not set from a project file, the audio codec setting in the File Save options dialog is 
checked. If a codec is set this will become the output codec setting.

3.  Otherwise, the output codec will be the same as the input file. 

The output bitrate must be set to an appropriate value for the codec being used. 

 

BOOL SetCutMode( BOOL cutModeFlag )
SetCutMode( cutModeFlag as integer ) as Integer
 
Parameters:
cutModeFlag 1 to have VideoReDo run in Cut Mode.  0 to have it run in scene mode.
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
By default, VideoReDo will default operation to the mode specified by the user on the Tools>Options>General options 
page. This command lets you change the mode dynamically at run time. This command should be used after a file has 
been opened, but before any edits have been made. This command will remove any previously applied edits.  
 
Each time a file is opened, VideoReDo will reset its mode to the user specified default.  Therefore this command should 
be re-executed after each open.

 

void SetFilterDimensions( short filterWidth, short filterHeight) 
SetFilterDimensions( filterWidth as short, filterHeight as short)
 
Parameters:
filterWidth Set to non-zero to filter output to GOPs matching this width.
filterHeight Set to non-zero to filter output to GOPs matching this height.
  
Return Values:

None

Description:  
This call duplicates the video filter option on the Tools>QuickStream Fix. If both options width and height are set to 
non-zero, then only GOPs wich video dimensions which match the width and height will be output. 

The filter dimensions are cleared after each FileSave call. Therefore this command should be re-executed after each 
open if you are processing multiple files.

BOOL SetQuietMode( BOOL quietMode  )
SetQuietMode( quietMode as integer ) as Integer
 
Parameters:



quietMode TRUE (or 1 ) to have VideoReDo run in quiet mode, FALSE (or 0 ) otherwise.
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
When quiet mode is set, VideoReDo will completely hide itself during output.

 

BOOL StartAdScan( long FastSearch, long AutoCut, long DisableDisplay  )
StartAdScan( FastSearch as integer, AutoCut as integer, DisableDisplay as integer ) as Integer
 
Parameters:
FastSearch TRUE or (1) to run Ad-Detective in fast search mode.
AutoCut TRUE or (1) to have Ad-Detective automatically set the cut markers around commercials.
DisableDisplay TRUE or (1) to have Ad-Detective minimize the display while scanning.
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
This function starts the Ad-Detective scan.

 

BOOL WriteProjectFile( const char *outputFilename  )
WriteProjectFile( outputFilename  as string ) as Integer
 
Parameters:
outputFilename Character string containing a VideoReDo project file.
  
Return Values:

Function returns non-zero (TRUE) if successful,  otherwise zero (FALSE)

Description:  
Saves the current project to disk.

Properties:

AudioAlert
 

To Set: 

 

VideoReDo.AudioAlert = TRUE or FALSE;

Overrides the current value of the audio alert flag. When TRUE (1), an audio alert will sound when output is complete. 
For silent operation set to FALSE (0).

 
To Get:  

 

BOOL b = VideoReDo.AudioAlert; 

Retrieves the current value of the batch audio alert flag. By default, the audio flag is set via the program 
parameter option on the Tools>Options>Audio Alert Page. This value 

 

 

OpenedFilename
 
To Set: 



 
This property is read-only. 

 
To Get:  

 

BSTR sd = VideoReDo.OpenedFilename; 

Returns the currently open filename. If a project is opened, the video files specified in the project file will be 
returned. If the open video is a .Vlst, the .VLst filename is returned. 

 
 

 

OutputPercentComplete
 
To Set: 

 
This property is read-only. 

 
To Get:  

 

double d = VideoReDo.OutputPercentComplete; 

This property only applies while output is in progress and returns a value from 0 to 99.9 representing how 
much of the output file has been created. It should only be used as an estimate and should never be relied 
upon to determine when the output routines have finished. IsOutputInProgress should be used to check when 
output has actually been completed.

 

 

PlotMask
 
To Set: 

 

short pct = 25; 
VideoReDo.PlotMask = pct; // Cover 25% of the image from toward each edge. 

 
To Get:  

 

short pct = VideoReDo.PlotMask 

This property is used to get or set the value of the plot mask. The plot mask is used to cover the video image 
starting from the center of the picture. A value of 0 means no plot mask is displayed. A value of 50% means 
that the entire window is covered. Since the mask originates from the center of the window in each of 4 
directions. 

 

 

PreviewMode
 
To Set: 

 
BOOL bPreviewMode = 1; 
VideoReDo.PreviewMode = bPreviewMode; // Turn on Preview Mode. 

To Get:  

 

BOOL b = VideoReDo.PreviewMode;

If 1 (TRUE) preview mode is enabled otherwise its 0 (FALSE). Preview mode can be enabled or disabled by 
setting this property. 

 

 



SelectionStartMsec 
SelectionEndMsec

 
To Set: 

 

unsigned long msec = 5000; 
VideoReDo.SelectionEndMsec = msec; // Position the end selection marker to 5 seconds. 

 
To Get:  

 

long msec = VideoReDo.SelectionEndMsec;

These two properties can be used to read or set the start and end selection markers. If both markers are to 
be set, it is recommended that the SelectScene() method be used. 

 

 

ThumbnailDisplay
 
To Set: 

 

BOOL bThumbnailOn = 1; 
VideoReDo.ThumbnailDisplay = bThumbnailOn; // Turn on thumbnails. 

 
To Get:  

 
BOOL b = VideoReDo.ThumbnailDisplay; 

Property to turn on (TRUE) or off (FALSE) the thumbnail display window. 
 

ThumbnailInterval
 
To Set: 

 

long intervalMsec = 1000;  
VideoReDo.ThumbnailInterval = intervalMsec; // Set current interval to 1 sec. 

 
To Get:  

 

long intervalMsec = VideoReDo.ThumbnailInterval;

Gets or sets the current thumbnail interval in msec. This property does not turn on, or off, the thumbnail 
display. Use the ThumbNailDisplay property for that purpose. To set the interval to single frame, specify an 
intervalMsec of 0. 

 

VersionNumber
 
To Set: 

 
This property is read-only. 

 
To Get:  

 

BSTR str = VideoReDo.VersionNumber

Return the current version and build for VideoReDo as a COM string. The format is result is x.y.z.bbb - 
<Build Date>, where:

x = major version 
y = minor version 
z = release number 
bbb = build number 

For example: 

wcript.echo(VideoReDo.VersionNumber) display:



2. 2. 1. 460 - Mar 24 2006  
 

Sample script:

set Args = Wscript.Arguments 
'Wcript to do some joins and edits. 
Set VideoReDo = WScript.CreateObject( "VideoReDo.Application" ) 
Wscript.echo( VideoReDo.VersionNumber)  
VideoReDo.SetQuietMode( true ) ' Save without any display 
openFlag = VideoReDo.FileOpen( args(0) ) 
if openFlag = false then 
Wscript.echo( "? Unable to open file/project: " + args(0) ) 
Wscript.Quit 3 
end if 
VideoReDo.SetCutMode( false ) 
Wscript.echo( VideoReDo.GetFrameRate() ) 
Wscript.echo( VideoReDo.GetProgramDuration() ) 
 
if NOT VideoReDo.SelectScene( 10000, 40000 ) then Wscript.echo("Error ") 
if NOT VideoReDo.SelectScene( 60000, 80000 ) then Wscript.echo("Error") 
VideoReDo.AddToJoiner() 
 
if NOT VideoReDo.FileOpen( args(1) ) then Wscript.echo( "Open error " + args(1) ) 
VideoReDo.SetCutMode( false ) 
if NOT VideoReDo.SelectScene( 0000, 40000 ) then Wscript.echo("Error ") 
if NOT VideoReDo.SelectScene( 60000, 180000 ) then Wscript.echo("Error") 
 
VideoReDo.AddToJoiner() 
VideoReDo.AudioAlert = true  
call VideoReDo.SaveJoinerAsEx( "c:\temp\olejoiner.mpg", 1 ) ' Save as program stream 
 
While( VideoReDo.IsOutputInProgress() ) 
Wscript.Sleep 1000 
Wend 
 
VideoReDo.Close() 
Wscript.quit 0 
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Navigation Options 

 

Button movements: The values in these boxes indicate the number of seconds to move the program forward or backward. 
A value of zero seconds indicates single frame movement. The Shift- and Ctrl-Multipliers permit you to move the program 
at an accelerated rate by holding them down prior to pressing the desired button.

 Default: single frame (0 seconds). Pressing the up and down arrow keys will also simulate pressing these buttons.  Please 
see Keyboard Shortcuts for more detail.

 Default: 30 seconds 

 Default: 120 seconds. Pressing the Page Up and Page Down keys will simulate pressing these buttons.  Please see 
Keyboard Shortcuts for more detail.

Shift Multiplier: Default: Double the above values to 20, 60, and 240 seconds. In the case of single frame movement, this will double 
the number of frames moved. 

Ctrl Multiplier: Default: Triple the above values to 30, 90, and 360 seconds. In the case of single frame movement, this will triple the 
number of frames moved. 

Mouse Wheel: This option lets you select how far to advance or retard the program when the mouse wheel is rotated. 
By default, rotating the mouse wheel towards the back of the mouse will advance the program. The "Reverse 
Direction" checkbox will reverse that behavior so that rotating the mouse wheel towards the front of the mouse will 
advance the video.

Left/Right Arrow Keys: This set of combo boxes permit you to set the movement for the left  and right  arrow 

keys with and without the control and shift keys set.  
 
Note: If the arrow keys are held down for more than a second or two, they will automatically repeat allowing you 
to quickly advance through your program. 

Slider Range: This value controls the number of seconds that the lower slider will advance or retard the video.  The 
default value of 120 seconds means that moving the slider all the way to the right will advance the video by 2 
minutes. Likewise, moving the slider all the way to the left will move the video backward by 2 minutes.  

Note: When using the fine tune slider, the Shift and Ctrl multipliers increase the accuracy of navigation by reducing 
the effective range. For example with a slider range of 120 seconds and a Shift Multiplier to 2, the effective range of the 
fine tune slider will become 60 seconds if the shift key is pressed while moving the slider. 

Note: You can also use the right mouse button on the fine-tune slider to give you even greater positional accuracy. 

Reset to Defaults: Click this value to reset all the parameters to their original pre-programmed values.
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Stream Parameters 
 

Stream Parameters 
 

Detect / Resync Missing Frames:  VideoReDo continually checks for missing or corrupt audio and 
video frames. These frames may be a short and temporary annoyance when the program is played on back 
in VideoReDo or other PC-based software players. However, many DVD authoring programs do not handle 
these frames gracefully and they will create very noticeable audio and video synchronization problems on the 
newly authored DVD.  
 
VideoReDo continually checks the synchronization of the input file and will insert or remove audio or video 
frames in an attempt to maintain output synchronization. Corrections behavior is controlled by this option. 

Ignore: VideoReDo  will not attempt to correct small synchronization errors. However if the synchronization 
error is so severe that VideoReDo's internals buffers might overflow, then audio or video frames will be removed 
to reestablish synchronization. This will occur if the synchronization error exceeds 4 seconds ( 8 seconds if 
the Double Video Buffer Memory Option is selected). 

Resync - Insert Extra Video Frame: If the video starts to lags behind the audio, VideoReDo will insert 
extra replicated frames into the GOP in order to maintain sync. This setting is useful when the source material 
is digitized from old or noisy video tapes. Often these tapes create multiple video drop outs, yet the audio is 
perfect. By inserting the extra frames into the output stream, the audio track as well as sync is preserved.  

Note: The extra replicated frames can lengthen a GOP so that it is no longer DVD compliant. Although 
most modern DVD players will handle longer than compliant GOPs you can use the Maximum GOP Size 
output option to have VideoReDo reduce the newly lengthened GOP back into compliance.

Resync - Remove Audio Frames: With this option, if the video lags behind the audio, VideoReDo 
remove audio frames until the programs are back in sync.  

Note: When the audio lags behind the video, VideoReDo's only option is to remove video frames. There is 
no provision to insert additional audio frames.  

Delta Frames:  This parameter determines how much synchronization offset can be tolerated before 
VideoReDo starts to resync the program. The default value of 3 starts making fixes when the audio and video 
are out of sync by 3 frames, which is 100 msec for NTSC, or 120 msec for PAL. For 720p HD material, 
audio durations are used which either either 24 or 32 msec/frame depending upon the way the audio is 
encoded. Using a lower value will result in more frequent sync correction. This parameter is only a trigger of 
when to start synchronization correction. Once the correction is started, VideoReDo will attempt for correct sync 
to be within a audio or video frame. 

Maximum Audio Frame Errors:   Audio frames occur when VideoReDo does not find the start of an 
audio frame when expected. This situation is typically caused when the capture card drops frames when writing 
the program stream to the disk. When an audio frame error is encountered, the editor will automatically attempt 
to re-synchronize itself to the audio stream and proceed. This parameter specifies how many re-
synchronization attempts should be attempted before VideoReDo stops processing the present file. Audio 
frame errors may be encountered both during playback as well as output processing. The number of audio 
errors encountered during output processing is reported in the Output Processing Complete Dialog. By 
default, VideoReDo sets this parameter to a very high value of 32000 so that only the most corrupt audio 



streams will trigger an error.

Discontinuity Checkpoints: This number represents how thorough a check VideoReDo does of the input 
file to adjust for non-sequential time stamps. When a file is opened, VideoReDo checks the file, at evenly 
spaced intervals, to see if the time stamps are sequential. If the timestamps are not sequential, then 
VideoReDo automatically builds an internal table to compensate. The higher this value, the more sections of the 
are checked, but the slower the file will open. A value of 0 disables this feature. 
 
Non-sequential time stamps usually manifest themselves as navigation issue, where the cursor seems to 
randomly jump around. Sometimes the problems are severe enough that VideoReDo will hang while trying to 
open the program. In almost all circumstances, this problem can be rectified by running Tools>QuickStream Fix, 
but this can add minutes to the editing process as well as consuming additional disk space for the output 
file. Another possibility is to increase the number of Discontinuity Checkpoints so that the file is more 
thoroughly scanned during the open. 

MBytes to scan at file open: This value is the maximum number of bytes (times 1,000,000) that 
VideoReDo will scan to find video and audio streams when opening a file. One reason you may want to 
increase the value from its default is if when trying to open a transport stream VIdeoReDo can't find the 
desired program. This may be because the original capture starts with one set of transport parameters and 
then switches a few megabytes into the file to another set. Increasing this value, will trigger a more complete 
scan at a slight slow down in file open time.

Convert All I-Frames To GOPs: When checked, VideoReDo will insure that all I-Frames contain 
the necessary header information to be considered GOPs. This will insure the up most in DVD compatibility. 
Most source files already mark I-Frames as GOPs, however, this will option will insure that behavior.

Output Diagnostic Data To Log File:  Check this option to have VideoReDo output detailed data to its 
log file when editing or saving a video. This option is typically used if VideoReDo encounters a problem in 
the output file, such as an out-of-sync condition, and the VideoReDo support team asks you to provide 
additional information.  It is recommended that you leave this option off to save log file space and reduce 
the time it takes to save your video programs.

Double Video Buffer Memory:  The internal video buffer within VideoReDo is between 4 and 5 
seconds depending upon whether you are editing NTSC- or PAL-based programs. If the audio program drops 
out longer than this interval, VideoReDo can experience a video buffer overflow as it tries to synchronize audio 
to sync with the video.  When this option is checked, the video buffer is doubled in size so that 8 to 10 seconds 
of material is retained.  This larger buffer requires about 20MB more memory and slightly slows down 
internal processing such as navigation through the file. It is recommended that you leave this option 
"unchecked" unless your programs trigger a "video buffer overflow" error. 

Note: Some digitally captured streams, especially satellite broadcasts or Tivo extractions utilize very long 
GOPs. For these programs, you might experience better performance by enabling this option. 

Skip Encoder Conformity Checks:  VideoReDo's internal MPEG2 encoder checks to insure that the 
bit stream it is encoding conforms to the MPEG2 Main Profile. If your bit stream exceeds the parameters in 
the main profile, VideoReDo will warn you that you are editing a video that is out of MPEG specification and will 
not proceed with the edits. Check this box to disable these checks.

Ignore Transport Stream Maps: When a transport stream is opened, VideoReDo attempts to determine 
the available programs in the stream by processing the stream's program maps (PAT and PMT packets). 
Many broadcasters either omit these packets or send them with incorrect information. This can cause 
VideoReDo to not detect all the video and audio streams in the file. Checking this options disables the 
processing of these sections. Instead VideoReDo scans the first 10,000 packets of the file and tries to 
decipher what program contents are present. The disadvantage of disabling this feature is that the program 
does not always pick up each and every stream, especially secondary audio streams. The preferred mode is 
to leave this enabled unless your particular transport captures open with missing audio or video streams.

Encoder Quality: This parameter determines the level of quality used by the VideoReDo MPEG encoder. 
The quality determines the video rate of the frames which are encoded at cut points and during GOP reduction 
if you have selected to perform that function. Your choices are:

●     Auto: The bit rate is set the bit rate of the current GOP being cut / recoded. This option is best used 
when outputting transport streams since a consistent bit rate is critical to avoid PTS underflows. 

●     High: The default setting, optimizes the quality over speed and bit rate. Occasionally this setting can result 
in frames of high bit rates that may exceed the maximum bit rate for the file. One symptom of this is a high 
number of PTS underflows during output. Setting a lower encoder quality will reduce the encoders target bit 
rate and reduce the possibility of PTS underflows. At its highest setting the encoder's target bit rate is the bit 
rate specified in the MPEG header. Often this bit rate can be much larger than the actual bit rate. For example, 
all DVB broadcasts use an MPEG header bit rate of 15 Mbps, but the video bit rate may only be 3-6 Mbps. In 
this case, using the Auto or Low setting may be more appropriate.  
 



The bit rate for the file is reported on the Tools>Show Program Info dialog and may be changed using the 
Output Options dialog.  

●     Medium: At medium, the quality / bit rate is 2/3rds of the MPEG header bit rate. 
●     Low: At low, the quality / bit rate is 1/2 of the MPEG header bit rate. 

Output Stream Parameters:The following options deal with how video packets are packetized to form 
a program stream. A program is made up of one or more elementary streams where an elementary 
stream represents a contiguous stream of audio or video data. The bytes from each of these elementary 
streams are broken up into fix sized packets with each packet marked whether it belongs to an audio stream 
or video stream. Some of these packets are marked with a time stamp known as the "Presentation 
Time Stamp" (PTS) so that when played back, the audio and video are synchronized. The default options 
supplied by the program should not have to be changed. 

Start Video Frame In New Packet: If checked, a new packet will be started each time a new video frame 
is encountered.  This option should be used when VideoReDo's output is intended to be used with other 
video editors or programs that might require the files to be in a particular format. 

Add Padding To Short Packets: This option is only used when video frames are packet aligned. 
Elementary stream packets are normally fixed length except when they are truncated early due to packet 
alignment. When checked, padding data is inserted into the program stream to preserve a constant overall file 
bit rate. There is no program content in these padding packets. Checking this option (along with the video 
frame alignment) can increase file size by 5% to 10%. 

Align Packet Data To Word Boundary (DigiTV): Some software players such as the Nebula-DigiTV 
player require MPEG streams with certain internal packet alignment. You should only need to check this 
option when you intend for your videos to be played one on of these players. Otherwise, you will be wasting 
bytes within the file.  

Output PTS With Each Video Frame: Program time stamps are used to synchronize audio and 
video streams. By default all audio packets are marked with a time stamp. When checked, each video frame 
is marked with a timestamp. When not checked, only GOP frames have a timestamp. Leaving this box 
checked increases the output file by less than 800KB per hour of video.

Output PS Pack Header With All Packets: Program Stream Pack Headers (PS Packets) are used to 
keep the internal clock of the playback device (e.g. DVD player) in synchronization with the time stamps inside 
the program stream file. When checked, every elementary stream packet is preceded by PS packet. When 
not checked, only elementary stream packets with time stamps (PTS) are preceded by a PS packet. Checking 
this box adds 1-2% to the output file size.

Program Stream Packet Length: This is the length of the fix-length program stream stream packets 
(PES). There are two different sizes, one for MPEG2 and another for MPEG1  The MPEG2 value should 
be increased to 2304 for an SVCD compliant file. The default value of 2028 is the standard for DVD 
compliant program streams. The MPEG1 size of 2324 is the VCD standard and is recommended for all 
MPEG1 situations. 

Drop Frame Timecode in GOPs: If this option is checked and the video is NTSC, the timecode in the 
GOP will be coded with a drop frame timecode. The drop frame timecode is designed to account for the 
differences between 30 frames per second and the actual frame rate of 29.97 frames per second. When this 
option is not set, the timecode in the GOP is calculated by dividing the PTS by the frame rate. This option is 
not used for PAL videos. 

Multiplexor Audio Lag Msec: When a program stream is written by VideoReDo, the audio data typically 
trails a frame by a fixed amount of time. This parameter tells VideoReDo's internal multiplexor how long after 
the video frame is written to write out the audio frame. The default value of 20 msec should be sufficient for 
most situations.

Note: This parameter does NOT affect audio / video synchronization. It only changes the location of the 
audio packets in the program stream relative to their corresponding video packets. 
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File Types 
 

File Types 
 

This dialog lets you setup and maintain the relationship between file types and VideoReDo. File types are 
defined as the text that appears after the period in a filename. For example, MPEG program streams usually have 
a file type of ".mpg" or ".mpeg". When a file type is associated with a program, Windows will let you 
automatically open the file by double-clicking or right-clicking on the filename in the file explorer.  When you 
install VideoReDo it does not by default associate any files with itself.  You need to use this dialog to create 
those associations.

The File Types parameter page shows all the file types that are being related to VideoReDo. Notice that the 
file types are all in lower case and the leading period is not included.  Next to each file type are three check boxes: 

●     File Open: When checked, files of this type will be displayed as a supported file type in the File Open dialog. 
●     Project Open: When checked, files of this type will be displayed as supported file type in the Project 

Open dialog. 
●     Associate: When checked, Files of these types will be marked as being associated with VideoReDo in 

the windows shell. This means you can automatically open and edit files of these types simply by double clicking 
on them. 

Checkboxes can be toggled on or off by simply clicking on them. 

Add New File Type: Type the new file type into the "Add New File Type" edit box and click on "Add Entry". 
This will add the file type to the list. 

Register File Associations:

Automatically On Program Start: When checked, each time VideoReDo starts it will re-register 
with Windows all the file types marked with a checkbox. This option is useful if other programs compete 
with VideoReDo for the same file association.

Now: Click this button to immediately register the file types marked for association. 

To delete an existing file type from the list: Double-click on the file type entry. 
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Playback Devices 

 

This dialog is used to optimize the playback of your videos program while editing.  It does not affect, in any 
way, the format or quality of your saved edits.

Video Display Options:

Deinterlace On: If checked, VideoReDo will de-interlace the video display. Interlaced video can cause lines 
to appear on screen, especially during scenes with lots of fast moving action. Deinterlacing removes these 
artifacts with a very slight (usually un-noticeable) loss of display quality.

Interlaced Video De-Interlaced Video

Use Video Card YUV Acceleration: This option enables causes VideoReDo to request that your video 
card convert the MPEG signal from its native YUV format to the computer screen's RGB format. Most modern 
video cards support YUV hardware acceleration.  Choosing this option will often result in a slightly better 
picture quality, and will reduce the CPU usage of VideoReDo by 5% to 15%.  If you select this option, 
but VideoReDo is unable to take advantage of this feature, then VideoReDo will revert, temporarily, to 
non-accelerated mode.  A message indicating this has happened is written to the log file. For slower 
machines CPUs (less than 1GHz), enabling YUV acceleration can have a dramatic improvement of 
VideoReDo's interactive response. 

Note: If VideoReDo detects that you are editing HD material it will attempt to automatically enable YUV 
acceleration regardless of this setting. 

If you have multiple monitors on your system, you might want to disable the YUV acceleration mode as 
VideoReDo only supports YUV acceleration on the primary monitor.  You will not be able to see your video 
picture on other monitors when using this mode.

Displayed Aspect Ratio: Use parameter to force the video to display at a particular aspect ratio. In 
"Auto" mode (the default), VideoReDo will set the displayed aspect ratio according to the first sequence 
header found in the file. If the aspect ratio switches in the middle of the file, the displayed picture will not 
look correct in parts of the file. This parameter can be used to lock in a setting regardless of the file's aspect ratio.

Note: This parameter does NOT affect the output aspect ratio. That can only be changed on the Output 
Options dialog. 



VideoDriver: This drop down box lets you select which software driver VideoReDo should use to display 
the main video window while editing. This parameter does NOT affect the output video in any way. The VMR7 
or VMR9 drivers should be used if your system has multiple attached monitors. 

●     DirectX - The DirectX driver relies on DirectDraw7 and should provide excellent performance on most 
single monitor machines and should have the highest level of compatability especially on older systems. 

●     DirectX-Multi Mon: This upgrade to the DirectX driver will support systems that have multiple monitors. We 
do no recommend using as it is being phased out in favor of the two VMR filters. 

●     VMR7: The VMR7 (video mixing renderer version 7) is available, by default, on Windows XP and other 
systems where DirectX9 has been installed. It is one of the two drivers used by Windows Media Player and 
works well on systems with both single and multiple monitors.  

●     VMR9: The VMR9 driver will work on all systems that have Direct3D installed. This includes all systems with 
newer graphics cards. In terms of overhead, DirectX has the least, followed by VMR7 and then VMR9.

Audio Device:

Use default WAVE: There are two types of sound drivers on Windows system, WAVE and DirectSound. 
You might want to experiment which driver sounds the best for your system.  In most situations, the WAVE driver 
is the "safer" choice as this driver usually has a lower latency.  The latency is defined as the time from when 
the program asks the driver to output a sound and it is eventually heard by the user. When using the WAVE 
driver, VideoReDo's volume control affects the volume of all applications on your system. However, some 
newer devices especially external USB and Firewire sound devices, may not come equipped with WAVE drivers.

Use DirectSound drivers: If you can use the DirectSound drivers you should see a couple of advantages 
over WAVE drivers.  (1) You will be able to select the specific device to playback your audio.  This can be a 
real advantage for systems with multiple sound cards or audio devices.  (2) VideoReDo's volume control is 
limited to adjusting the volume of the current MPEG program.  In fact, you can have multiple VideoReDo 
instances open each playing a video program at a different volume. 

The problem with DirectSound is that some older sound card drivers introduce very high ( > 100 Msec) latency 
in the audio. In this is the case, you will have to revert to WAVE-based audio.

Edit Without Audio: If there is no audio device on your system enable this option to allow VideoReDo to 
open the file. This option may be useful if you are editing over a remote keyboard / display connection where 
the audio is severely delayed or a remote link audio driver is not available. 

Swap LPCM Audio Bytes: Enable this option if you are editing LPCM audio and the sound does not 
play properly. Some programs will reverse the order of the audio bytes in a sound track. This option 
will compensate for that behavior. 
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Start Up 
 

Start Up 
 

This dialog is to control the behavior of VideoReDo each time it starts. 

Check For Updated Version At Startup: If checked, VideoReDo will poll the VideoReDo web site to determine 
if there is a later version of the software available and inform you when there is one.  

Days Between Checks: VideoReDo will check the web site for a new version at most once per day.  You 
can increase the time between checks by setting this field to a higher number of days. 

Ask For Permission Before Accessing The Internet: When checked, VideoReDo  will ask you if its OK to access 
the internet. This option is useful if you have an internal firewall blocking requests from unauthorized programs.  
All version request checks are made using the HTTP protocol over Port 80, just like your web browser.  Other 
than performing version checks, VideoReDo performs no other internet access.

Background Graphic: Use this option to customize the background of VideoReDo's main edit screen.  You 
can choose from one of five different dynamic and pleasing backgrounds.

Solid Color: Click on this radio button to have VideoReDo use a solid color background.  Then, press the 
"Select Color" button to choose a color.

Selection Time Color: Use this option to customize the Sel. Start and Sel. End font time color displayed 
at each end of the timeline

Log File Folder: This edit box can be used to change the location of the log file. The log file folder contains 
the VideoReDo.log file and other supporting files, such as the VideoReDo.VPrj file and the batch queue file. The 
log file can be opened using Notepad from the menu by clicking ont Help>Display VideoReDo.log 
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Chapter Marks 

 

VideoReDo has the capability of creating chapter files suitable for import directly into DVD authoring programs. 
A chapter file can created either by clicking on File > Save Chapter File, or automatically everytime a file is 
saved. The parameters on this options page control the format and types of chapter marks created. For user 
who are authoring directly in VideoReDo TVSuite, there is no need to export a chapter file. However, the 
chapter markers generated by the parameters on this page are directly imported into the VideoReDo 
authoring engine.

Chapter Marks: This section determines the location of the chatper marks. There are three non-
exclusive options. You may select any combination of the three location methods: 

At Cut Points: The method will create a chapter marker at each cut point in the file. 

At Scene Markers: Checking this option will cause chapters to be created at each scene marker.

Use Equal Spacing: Create chapter markers at equally spaced intervals. You can specify how the intervals 
are placed. Minutes and seconds create chapter marks at evenly spaced time intervals. Is you specify parts, 
then VideoReDo will divide the total time of the output video by the number of specified parts to determine where 
to place the chapters.

Minimum Chapter Interval Secs: This value resolves conflicts between the various methods listed above 
by preventing chapter markers from appearing too close together.

Include first frame (0.00): Some authoring engines require a chapter marker to be placed at the beginning 
fo the file. If so, check this option. The VideoReDo's own authoring engine ignores this parameter.

Output Format: This section is used to specify the chapter filename, file format. If you are using 
VideoReDo TVSuite to author there is no need to create a chapter file as chapters are automatically imported 
into our authoring engine.

Automatically Create A Chapter File: Check this box to have VideoReDo save a chapter file each time 
a file is output. If this box is not checked, chapter files can only be created by explicitly saving them from the 
file menu. 

File Type: This option offers two choices:

1.  Text File: The chapter file will be a text file with one line per chapter according to the format you specify below.
2.  DVDAuthor XML File: DVDAuthor is a free open source DVD authoring tool which can be run from 

the command line. One option is to accept parameter input via an XML file. This option will create a 
DVDAuthor XML file with the chapter markers properly formatted.

Output File: This text box contains a template that is used to build the chapter filename. . The "%F" 
substitution will substitutes the output filename at the desired location. The chapter file is always created in 
the same folder as the output file.

Example: Output mpeg file:  c:\temp\myVideo.mpg



 Template:  %F_chapter.txt
 Chapter file name:  myVideo_chapter.txt

Line Format: This text box contains the template this is used to format each line in the chapter file. There 
are three substitution strings:

%T - substitutes the time code. The Timecode format is determined by the selection box below.

%N - Frame number. Please note that the frame number is the displayed frame number and not the input 
frame number. The displayed frame number can be different when the program employes 3:2 pulldown material.

%C - Chapter number: A sequential number which will range from 1 to the total number of generated chapters.

Example: Template: Output:
%T 00:30:10.22
Chapter %C, Frame: %N Chapter 5, Frame: 35721 

Timecode: Use this select box to choose the timecode format that is appropriate for your DVD 
Authoring program. Choose from one of these formats:

●     

HH:MM:SS:ff
●     

HH:MM:SS;ff
●     

HH:MM:SS:hh
●     

HH:MM:SS;hh
●     

HH:MM:SS
●     H:MM:SS.ff

HH = Hours 
MM = Minutes 
SS = seconds 
ff = frame number (0 to one less than number of frames / second). 
hh = hundredths of a second 

Import chapter marks on file open: this option will allow the import of the chapter marks files if the file 
had been previously edited with VIdeoReDo and a separate chapter mark file had been saved in the same 
folder with the same name.
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Audio Alerts 

 

 

This options dialog is used to set the sound that VideoReDo when it has completed outputting your edits.

Upon Output Completion Play Sound: This selection box lets you specify when a sound should be 
played. Options are: 

Never: Don't play audio when output is complete. 
Interactive Only: Only play audio on output complete only when VideoReDo is 

running in an interactive mode. 
Interactive and Batch: Play a sound whenever an output file is created. 

External WAV File: Enter or lookup a WAV Filename. Press the button to the right of the edit box 
to search for an existing WAV file on your system.
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Enhanced features 

 

The parameters on this options page control the some of the unique features now available in VideoReDo TVSuite.

Combining: Combining is the ability of VideoReDo to logically merge multiple files into single large file 
while editing. This feature is useful for situations where a single program file is split into multiple storage 
segments. For example, the VOB files on a DVD are limited, by the DVD specification, to a maximum of 1 
GByte per file. Therefore, when a title is longer there will be multiple VOB files. For example, a typical DVD may 
be VOB files named:

VTS_01_01.VOB 
VTS_01_02.VOB 
VTS_01_03.VOB 
etc.

Some video capture devices also split their files during recording. You'll notice this is the case if each program 
is made up of multiple files.

To Use Combining: You can have VideoReDo Plus combine multiple files in three different ways:

1.  When opening a video simply select multiple files in the file open dialog or drag multiple files from the Windows 
File Explorer into the VideoReDo Plus window or desktop icon. Then you try to open multiple files, VideoReDo 
Plus will offer you the option of joining or combining the files. You can change this behavior using the "Multiple 
File Open or Drag" drop-down list.  
 

  
2.  If you have a Siemens M740AV PVR, the CRID options can be enabled to automatically process the M740AV 

CRID files. 
3.  If the "Auto Combine Sequential Files" is checked, simply opening any file in a numbered sequence will cause 

the entire sequence to automatically be combined. This option is especially useful if your capture card 
creates many sequential files and you don't want to have to select each and every file.

Auto Combine Sequential Filenames: Checking this option will allow VideoReDo to auto-concatenate 
a series of files that are sequentially numbered. This feature is useful for home-recorded DVDs containing VOBs 
or Transport Streams recorded as consecutively named files. When enabled, each of the component files 
are logically appended within to so that you are editing a larger virtual file. For example, a typical DVD may be 



VOB files named:

VTS_01_01.VOB 
VTS_01_02.VOB 
VTS_01_03.VOB 
etc.

When Auto combine is checked, VideoRedo Plus will see that each of this VOBs are part of the same set and 
load all three of them, as one long file, whenever you open any of them. 

Note: When working with VOB files, the filename VTS_??_00.VOB always contains menu and background 
images. VideoReDo Plus knows not to include this VOB file name in the Auto Combine set. 

When a series of files are to be combined, VideoReDo Plus automatically creates a VLST file. This text file 
contains the list of the component files. You may select the location of the saved VLST (Videoredo file LiST) file 
by one of two methods: 

Store VLST in Source Folder : Will automatically create the VLST in the original location of the source files. 

Specify Folder : Allows you to specify an alternative folder location when your source media is write protected 
or for convenience purposes. 

Note: You must specify an alternative folder location if importing from the DVD directly. DVDs are write 
protected and the file cannot be created on the DVD. Generally, we recommend copying DVD material to your 
hard drive before editing. 

 

Auto Processing Of .CRID Files : Allows the auto-concatenation of sequential files produced by a 
Siemens M740AV receiver / DVR which receives DVB transmissions. The CRID file contains meta data 
(program name, description, etc) as well as the links to the actual files which contain the audio and 
video information. When the CRID option is enabled, an additional menu item, File > Open CRID File will 
enabled. The menu option will appear the next time you restart VideoReDo Plus. 

CRID Folder: Specify the folder location of the CRID files. 

Allow CRID Deletions and Renames: Allows for the rename and deletion of CRID files in the CRID file 
open dialog box, since by default VideoReDo Plus does not provide for alteration or deletion of the source video file,

Plot Masking Area: Allows an area of the screen to be covered with a rectangle to reduce to opportunity to 
see the program's plot while editing. Options include small, medium, large, and Extra Large. This feature can 
be enabled from the menu: View > Show Plot Mask This will allow you to edit video without previewing a 
significant portion in order to enjoy the video after editing.

Reduce CPU Priority While Saving: Checking this option slightly lowers the CPU priority of VideoReDo 
Plus during the save process. This may slightly improve system responsiveness while VideoReDo Plus is 
saving your edits while extending the time it takes to complete the output. This option also affects the priority 
when saving from batch. When output is complete, the CPU priority of VideoReDo Plus is restored to its 
normal state. 

Multiple File Open Or Drag: This drop down box lets you determine the behavior when more than one file 
is specified in the file open dialog or when multiple files are dragged into VideoReDo. There are three options: 

1.  Prompt - Each time you open multiple files you'll be offered the option whether you want to combine or join.
2.  Join - Sort the file list and add them to the joiner.
3.  Combine - Sort the file list and combine them into one logical file. 
4.  Add to DVD - Sort the file list and add them to the DVD Title List 

Remarks about Combining versus Joining: 

The VideoReDo joiner performs it's work during the output phase, each file to be joined is separately opened 
and analyzed. Part of this analysis is searching for the first I-Frame (GOP start) in the file. So, if a file being 
joined does not begin on GOP boundary the frames prior to the start of that GOP are ignored.

The combining function is an input function. Data from each file in the concatenation list (VLST file) is 
logically appended to the end of the previous file. The entire set of files is then treated as one single file 
by VideoReDo Plus. In many cases, VOB or transport stream files are split at arbitrary byte boundaries 
without regards to MPEG formats like I-Frames splits or even audio frame splits. The Auto Concatenation 
ignores these issues and will treat the input files as if the original splits never occurred.



However, using combining on files that do not come from a single source is not recommended. In this case 
you should use the joiner to ensure proper attention is paid to audio and video alignments. 

Note: Combining does minimal error checking on each component file. For example combining different file 
types, such as program and transport streams may result in unpredictable results or even program failure. 
Joining does not have this limitation as each file is opened and processed independently. 
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Transport Stream Output 

 

This options page controls the behavior of VideoReDo Plus' build-in transport stream multiplexor

Output PAT and PMT Packets: A transport stream is made up of two kinds of data, program content (i.
e. audio and video), and program specific information (PSI) data. VideoReDo will output the two required PSI 
data packets: Program Access Table (PAT) and Program Map Table (PMT). 

Pat/PMT Interval (msec): Set to the number of milliseconds, in the output file, between successive 
PSI packets. 

Use PIDS From Source File: If this option is checked, VideoReDo Plus will match the PIDs in the output 
file with the PIDs in the source file. PIDs are numbers used to associates packets with individual streams. 
Unless you have a reason to change the PIDs, we recommend you leave this option checked. Valid PID ranges 
are from 16 (decimal) to 8190 (decimal). 

Program Map PID: Enter a unique PID number. The value is assumed to be decimal unless preceded by an 
'x' in which case a hex value is assumed. 

Video PID: Enter a unique PID number. The value is assumed to be decimal unless preceded by an 'x' in 
which case a hex value is assumed. 

Audio Stream 1 PID: Enter a unique PID number. The value is assumed to be decimal unless preceded by 
an 'x' in which case a hex value is assumed. 

Show PIDS as Hex: Check this box is you wish the PID displays on this screen to be displayed in hex 
rather than decimal. 

Output Mux Rate: A transport stream is transmitted at a constant bit rate known as the Mux Rate. This is 
a critical value when creating a transport stream. If its too large, the output stream will be larger than 
necessary, and if too low, audio and video packets will underflow. VideoReDo Plus assumes that the mux rate 
will be constant for the entire stream. 

Automatic / Manual / ATSC: In automatic mode, VideoReDo Plus will sample the video to determine 
the required multiplex rate. Each sample is about 4 seconds long. The number of samples is determine by 
the Samples parameter. This method works well with relatively constant rate video. In manual mode, you will 
need to specify the actual mux rate.  
 
In ATSC mode, the mux rate is automatically set to 19.2 Mbps. Also, the Automatic and Manual modes use 
the STD-T buffer timing model while the ATSC mode uses the slightly more relaxed ATSC timing model. 

Note: When using the joiner, the sampling routine will only sample the first file listed in the joiner. This may 
mean that the actual mux rates may be not be accurate if each of the files has a different video bit rate. 

Sample: The parameter determines the number of 4 second samples used by automatic multiplexor 
Increasing this value will promote greater accuracy in determining the mux rate, although it will add to the time 
it take to outputting your edits. 



Mbps: Fill in a manual mux rate in Mbps. Decimal values are allowed (e.g. 19.2 Mbps). 

Omit Null Packets: Compliant transport streams are always constant bit rate files. Empty space in the file is 
full with Null packets to insure that the bit rate remains constant. This can cause very large files to be created if 
the multiplex rate is significantly higher than that required by the audio and video streams. When this option 
is checked, Null packets will be not be output. This option is safe to use with many software players. However, 
for fully compliant streams which may be broadcast, please leave this option checked. 

Note: If you create a stream without Null packets and later want to add them back in, simply check this option 
and run Tools>QuickStream Fix on the file. 

Abort After N Buffer Underflows: When the mux rate is too low, underflows will result. An underflow 
occurs when the audio or video data is delayed. For example, if the video bit rate is an actual 10 Mbps and the 
Mux rate is 5 Mbps, the transport stream will not be able to transmit the video data quickly enough and 
underflows will result. Use this parameter to specify how many underflows will be tolerated before output is 
aborted. A small number of underflows may be acceptable if your output is intended to be played on a 
software player or the output isn't critical.

Note: Underflows do NOT cause any loss of data in the output file. If you output a file with underflows, you 
can come back later and re-multiplex using Tools>QuickStream Fix at a higher mux rate to remove the underflows. 
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Topfield Rec 

 

This option page is used to set the metadata and output characteristics of Topfield .REC files created 
by VideoReDo.

Topfield Type:

●     Topfield PVR 5000 - Select this option if the intended destination is a Topfield 5000.
●     Topfield PVR 5800 - Select this option if the intended destination is a Topfield 5800. 

Event Text Override Templates:

These three fields are used to update the Event Name and short description in the output .rec file. If the contents 
of the edit box are blank, then the original values from the source .rec file are used. The three 
placeholders: {DATE}, {TIME}, and {ORIG} may be used in the three text boxes to substitute the current date, 
time and original text.

Event Default: This field is used as the original text for the Event Name if the source file (file being edited) is 
not a .rec file. For example: Using the values in the sample screen above, if the source file is not a .rec file, then 
the Event Name will be defaulted to 'Edited By VideoReDo Plus'.

Event Name: The value in this field will be placed in the event name section of the output file. To preseve 
the original contents, either leave the field blank or use the '{ORIG}' placeholder.

Short Description: The value in this field will be placed in the short description section of the output file. 
To preseve the original contents, either leave the field blank or use the '{ORIG}' placeholder.
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DVR-MS Output 

 

This option page is used to set the metadata and output characteristics of DVR-MS files created 
by VideoReDo.

Preserve Closed Captions: When checked, closed captions in the original stream are preserved through 
the editing process. Closed captions are normally stored as user data in the video stream and should not 
be confused with subtitles. In DVR-MS files, closed captions are treated as a seperate stream. If you are 
saving DVR-MS file to a different format, such as MPEG program stream, VideoReDo will convert the DVR-
MS captions to industry standard format. Likewise, industry standard formatted closed captions, will be converted 
to DVR-MS output when saving to a DVR-MS file.

Metadata Options: The options in the box, are used to alter the content of the metadata that is stored with 
all DVR-MS files. The metadata is used by Windows Media Center to display the title, sub-title, description 
and recording date and time.  
 
The 'Title', 'Subtitle', and 'Description' fields all behave in a similar fashion. If left blank and the source file is also 
a DVR-MS file, then the source data is copied, intact, to the output file. If you wish to override the setting you 
can enter replacement text. The three placeholders, '{TIME}', '{DATE}', and '{ORIG}', are used either substitute 
the current date and time or contents from the same field in the source file. Please see the examples at the 
bottom of this page. 

TItle: Leave blank to preserve the original metadata content, otherwise put in the overide text. This field 
refers to: "Title" metadata field.

Subtitle: Leave blank to preserve the original metadata content, otherwise put in the overide text. This 
field refers to: "WM/SubTitle" metadata field.

Description: Leave blank to preserve the original metadata content, otherwise put in the overide text. 
This field refers to: "WM/SubTitleDescription" metadata field. 

Prompt for metadata: This option tell VideoReDo if and when you want it to prompt for metadata when 
saving to a DVR-MS file.

Never: With this setting the prompt for metadata feature is disabled.

Always: Always prompt for metadata when saving to a dvr-ms file. If the source file is a dvr-ms file.

Non-DVRMS files: Only prompt if the source is something other than a DVR-MS file. This option is 
intended to add metadata to files you are importing from an application other than media center, but want 
to leave media center files alone.

Set Program Time To Edited Date and Time: When checked, the program time fields will be reset to 
date and time of the output file. Specifically the "WM/WMRVEncodeTime" field in the output file will be set to 
the current date and time. 

Clear Database Associations (WMVRRequestID): Checked, this field will be set to -1. This should 



prevent MCE from setting the edited file as another copy of the source file. 

Example: 

●     To change the title from "Jag" to "Jag Edited", put '{ORIG} Edited' in the Title field. 
●     To change the subtitle from "Drop Zone" to "Drop Zone edited at 9:00 AM" put "{ORIG} edited at {TIME}" in 

the subtitle field. 
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Titling Parameters

 

.

This dialog is used to set the durations for the titling features. VideoReDo titles are typically inserted at 
the beginning of an output video, or between titles if using the joiner. For more about titling, please see 
the Title Editor. 

Fade-in: The number of seconds to fade in the titles. If this value is non-zero, the title begins as a black 
screen and gradually transitions to full intensity over the specified period.

Title duration: Number of seconds to display the title.

Fade-out: Number of seconds to fade from full intensity back to black. Set to zero to disable this feature.

All values can be entered with decimals. For NTSC video, there are approximately 30 frames per second so a 
value of 1.034 would be equivalent to 31 frames. For PAL material, which is recorded at 25 frames per 
second, each frame is 1.04 seconds.
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DVD Settings

 

Temporary File Area: To author a DVD VideoReDo needs to process your source files into a temporary 
area on one of your hard drives. The files in this temporary area are actually elementary stream files with edits 
and recodings applied. The size of the temporary area needs to be at least as large as the DVD you creating. 
For example a single layer DVD will require a 4.7GB or larger temporary area.

Automatic - Use hard drive with the most free space: When authoring is initiated VideoReDo will 
check the free space on each of your hard drives and use the drive with the most free space. A folder, 
named VRD_DVDTEMP, will be created for storing the temporary files.

Use folder: You can control where the temporary files are stored selecting this option and choosing an 
existing folder on one of your hard drives. You can also improve the speed of authoring by assigning the 
temporary folder to a drive that other than the one where the VIDEO_TS folder is located. Optimal speed 
is obtained by locating the temporary folder on a drive that is different from both the VIDEO_TS and source 
file folders. 

 
If you name your temporary folder VRD_DVDTEMP, it will be deleted after authoring has completed. 

Personal templates folder: Change this setting to assign where customized DVD menu templates are 
kept. Please note that you will have to move an existing personal templates to the new folder.

Warn when adding non-compliant videos: When checked, VideoReDo will warn you when you add a 
non-compliant file to the DVD list. Non-compliant files, such as high-definition files need to be recoded which 
can add substantially to the time it takes create a DVD. 

Recoding speed: The recoding speed determines how hard the MPEG2 encoder works when recoding a 
DVD. Part of the MPEG2 encoding process is to search successive frames for similar video areas. This is 
called temporal motion compression. The wider the search area the more efficient the encoded file is, but the 
longer it takes to do the search. A more comprehensive search may yield a slightly higher quality output file at 
a sacrifice in encoding speed. Options are:

●     Recoding speed: Approximate Performance relative 
to Normal:

Best (slowest) 25% slower
Good (slower) 20% slower
Normal 1.0x
Fast 17% faster

Burn options: This options determine the behavior of the burner when it is started as part of the 
authoring process.

Hide VideoReDo when burning: The VideoReDo window will be minimized while burning.

Run burner minimized: The burner itself can be run minimized when this option is checked.



Maximum burn speed: The burner will attempt to determine the maximum burn speed based on the speed 
of the media used as well as the maximum drive speed. Many users have found that burning at less than 
the maximum media speed is more reliable.

Pad short VIDEO_TS folders during burn : Checking this option will create fully compliant DVDs if the 
total folder size is less than 1GB. 
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Enter TimeCode 

 

This dialog will let you jump to a specific time code in your video by entering the appropriate time into the 
edit boxes. 

This dialog can be displayed either by double-clicking on the Cursor Time window:  or 
pressing Ctrl+T. 
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License Agreement 

 

SOFTWARE LICENSE AGREEMENT 
IMPORTANT - PLEASE READ THE TERMS AND CONDITIONS OF THIS SOFTWARE LICENSE 
AGREEMENT BEFORE ATTEMPTING TO INSTALL “VIDEOREDO™”, “VIDEOREDO Plus™” or 
“VIDEOREDO TVSuite™" ("VIDEOREDO”). DRD SYSTEMS, INC. (“DRD”) IS WILLING TO 
LICENSE VIDEOREDO™ SOFTWARE TO YOU AS THE INDIVIDUAL WHO WILL BE USING THE 
SOFTWARE (“YOU”) ONLY ON THE CONDITION THAT YOU ACCEPT ALL THE TERMS OF THIS 
LICENSE AGREEMENT. THIS IS A LEGAL AND ENFORCEABLE CONTRACT BETWEEN YOU AND DRD. 
BY CLICKING THE “ACCEPT” BUTTON YOU AGREE TO THE TERMS AND CONDITIONS OF 
THIS AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS AND CONDITIONS OF THIS 
AGREEMENT, CLICK THE “I DO NOT ACCEPT” BUTTON, AND DO NOT ATTEMPT TO INSTALL 
THE SOFTWARE. 

1. Grant of License. Subject to the terms of this Agreement, DRD hereby grants to you a non-exclusive 
and non-transferable license (without any right to sublicense) to install (i) the VideoReDo™ software program 
in machine-readable object code form contained in the media (the “Program”), (ii) the associated 
written documentation provided by DRD (the “Documentation”), and (iii) any updates, revisions or upgrades of 
the Program or the Documentation provided to you by DRD (each an “Update”) (the Program, the 
Documentation and any Update are collectively referred to as the “Software”). If you receive replacement or 
backup media containing the Program, you may only use it to in fact replace the primary media and may 
not transfer the original media to any other individual or computer. All rights not expressly granted to you herein 
are hereby reserved by DRD. 

2. Scope of Use. You shall not, nor permit any party to: (i) use or make the Software available for the benefit 
of any third party, including without limitation, in an outsourcing or timesharing arrangement, or in the operation of 
a service bureau; (ii) sell, rent, loan, lease, sublicense, distribute, or otherwise transfer the Software to any 
person, firm, or entity; (iii) copy the Software, except you may make one copy of the Program in object code form 
as supplied, solely for backup or archival purposes; (iv) modify, adapt, translate, decompile, disassemble, make 
any attempt to discover the source code of the Software, or create derivative works from the Software; (v) use 
the Software in any manner not authorized by this license; or (vi) publish or distribute any Software access 
or registration keys. Portions of the Software may not be used independently of the Software. The Software 
may not be used concurrently on more than one computer or processor unless you purchase additional licenses 
for each additional concurrent user. You may use the Software on more than one computer or processor to 
which you have access, provided that you are doing so for your sole use. If you use or distribute the Software on 
a network, or multiple computers or workstations, you must acquire and dedicate a license for the Software for 
each user to whom the Software is distributed or by whom the Software is used. The Software may not be 
shared or used by different users without a separate license for each user. In the event that you provide a 
different user with any access to the Software, such user must obtain a separate license agreement. 

3. Ownership. This is a license agreement and not an agreement for sale. Al l worldwide Intellectual 
Property Rights that are embodied in or related to the Software are, and at all times shall remain, the sole 
and exclusive property of DRD, whether or not specifically recognized or protected under local laws. For 
purposes of this Agreement, the term “Intellectual Property Rights” means, collectively, rights under 
patent, trademark, copyright and trade secret laws, and any other intellectual property or proprietary 
rights recognized in any country or jurisdiction worldwide, including, without limitation, moral rights and 
similar rights. You may not delete, alter, cover, or distort any copyright, trademark, or other proprietary rights 
notice placed by DRD on or in the Software. 

4. Disclaimer of Warranty. The Software is licensed to you on an “AS IS” basis without any 
warranty whatsoever. No services, training, support or maintenance is provided to you by DRD under 
this Agreement. DRD EXPRESSLY DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, NOT 
EXPRESSLY STATED IN THIS SECTION 4, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF 
TITLE, INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some 
jurisdictions do not permit the exclusion of implied warranties, so the above exclusions may not apply to you. 

5. Limitation of Liability. IN NO EVENT SHALL DRD BE LIABLE TO YOU OR ANY THIRD PARTY FOR 
ANY DAMAGES WHATSOEVER, INCLUDING INDIRECT, SPECIAL, INCIDENTAL, OR 
CONSEQUENTIAL DAMAGES, OR DAMAGES FOR LOSS OF PROFITS OR DATA, EVEN IF DRD HAS 
BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT SHALL DRD’S LIABILITY 
EXCEED THE PURCHASE PRICE OF A PRODUCT THAT GAVE RISE TO A CLAIM. IN NO EVENT SHALL 
DRD BE LIABLE FOR YOUR COST OF PROCURING SUBSTITUTE GOODS. Some jurisdictions may not 
allow the limitation of certain damages, so the above limitations may not apply to you. 

6. Export Restrictions. You agree to comply at all times with the provisions of all applicable laws 
and regulations regarding export controls or technology transfer restrictions of any applicable jurisdiction, 
including without limitation those of the United States Departments of Commerce and State. 



7. General Provisions. This Agreement and its license shall automatically terminate upon failure by you 
to comply with any of its terms. Following any such termination, you shall immediately destroy all Software 
and registration keys in your possession. This Agreement will be governed by the laws in force in the state of 
New Jersey , excluding its conflict of law rules, and exclusive venue for any litigation shall be in New Jersey . 
This Agreement will not be governed by the United Nations Convention on Contracts for the International Sale 
of Goods, the application of which is expressly excluded. If any part of this Agreement is found void 
and unenforceable, it will not affect the validity of the balance of the Agreement, which shall remain valid 
and enforceable according to its terms. This Agreement may only be modified in a writing referencing 
this Agreement and duly signed by an authorized officer of DRD. This Agreement constitutes the entire 
agreement between you and DRD relating to the Software, and supersedes any prior purchase 
order, communications, advertising or representations concerning the Software.
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Loading and saving projects 

 
Projects are the internal list of edit selections. When you open a video file, the internal project is empty as there 
are no selections. Each time you add or change a selection the internal project is updated. You can save 
the internal project file to disk using the "Save Project File As..." from the file menu.  The currently active  
project can be saved by selecting the "Save Project" option or by simply pressing Ctrl+P.

You can open a previously saved project from the same menu. 
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Audio Synchromization and Output Volume 
 

Audio Synchronization and Output Volume  
 

You can use this dialog to alter the synchronization between audio and video streams. This might be 
necessary if the original program is out of sync. You can also adjust the volume of the output file. This is 
different from the audio level adjustment in the main display which only affects playback volume. Any 
volume adjustment is heard during playback and will be adjusted in the output file.

The primary control on this dialog is the slider. It will let you alter the synchronization by up to 1 second 
(1,000 Msec) in either direction. Move the slider to the left to cause the audio to lag behind the video. If you 
move the slider to the right, the audio will lead the video. Most people's perception of audio synchronization 
is limited to about 75-150 Msec of accuracy. That is, differences less than 75 Msec are generally inaudible.

The Repeat Sel" checkbox is used to automatically repeat the current selection until the dialog box is closed. 
You will find this useful when a section of video is located where audio / video synchronization is obvious such as 
a close-up of people speaking or the occurrence of a sharp sound effect. Note, you only need to set the 
selection markers, you don't have to actually Cut the scene to utilize the Repeat Selection feature.

The Audio Sync Adjustment is retained after you close the dialog, but is cleared whenever a new file 
is opened..

The Audio Sync Adjustment will be applied consistently across the entire file when you save your work. If 
you add the current editor project to be joined with other files, each file / project within the joiner will have its 
own sync adjustment. One particular use for this is if the audio video synchronization gets progressively worse 
from beginning to end of the video. In this case, you might consider separating your video into multiple scenes 
and adding each scene separately, with its own Audio Sync Adjustment, to the joiner. When you are 
done, create the output file via the Process / Save Joiner List menu command.

The Output Volume will be modifed when you save your file and the audio properties will also be modified 
from the original file. You can select MPEG audio and bit rate or LPCM/WAV audio during output file save 
by pressing the Options button.
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QuickStream Fix Filter

 

If your video file contains video with multiple dimensions, VideoReDo will not be able to edit it. This dialog, which 
is enabled via QuickStream Fix, will let you limit the QuickStream Fix operation to video frames of a 
particular dimension. 

Video Dimension Filter: This drop down box displays all the video dimensions that VideoReDo 
has encountered in this file. The list is created by scanning the file at equal intervals and looking at 4 
second chunks of the file at each interval.

Rescan File: Press this button to rescan the file. This is typically done after changing the number of samples.

Samples: This is the number of 4 second samples to scan. For example, if your source file is 1 hour long 
and samples is set to 8 seconds, then the sampling points will occur at 7 minute intervals. You will likely want 
to increase the number of samples if VideoReDo fails to detect multiple dimensions on its first scan. 

 
 

VideoReDo TVSuite Help - © 2003-2007 DRDSystems, Inc.


	Local Disk
	Overview
	Screen Layout
	Getting Started
	Preview Mode
	Thumbnail and audio graph
	Ad-Detective Usage
	Open DVD title folder
	Title Editor
	DVD Project Creation
	Reference
	Keyboard Shortcuts
	Purchase and Registration
	Technical Support
	Adjust Audio Levels
	Managing Selections
	Navigating the Video Program
	Quick Start
	Joining Programs
	Getting Help
	General Parameters
	Thumbnail Options
	Ad-Detective Common Parameters
	DVD: Edit menu template
	DVD: Customize menu text
	DVD output: Video options
	DVD output: Cropping and resizing
	DVD output: Audio options
	Context Menu
	Joiner Editing
	Program Information
	Create Trimmed File Copy
	Output Processing Complete
	Overlapping selections
	QuickStream Fix
	Frame Capture
	Stream Selection
	Display Adjustment
	Ad-Detective Parameters
	Batch Builder
	Output File Options
	CRID File Dialog Box
	COM Interface
	Navigation Options
	Stream Parameters
	File Types
	Playback Devices
	Start Up
	Chapter Marks
	Audio Alerts
	Enhanced Features
	Transport Stream Output
	Topfield Rec
	DVR-MS Output
	Titling Parameters
	DVD Settings
	Enter TimeCode
	License Agreement
	Loading and saving projects
	Audio Synchromization and Output Volume
	QuickStream Fix Filter


